Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Comments, trackbacks & pings »

[SOLVED] Revisiting the 'Comments are Closed' Topic


  #1  
Old Mar 3, 2010, 10:16 AM
arlandiz
 
5 posts · Aug 2009
I would like to revisit the "comments are closed" and the " How to remove " comments are closed from the end of post threads.

I have the following need. On my personal site, on some pages that are the the posting page I would like to keep comments open. On other pages that are not the posing page I would like to close the comments ; but when I close the comments I would prefer not to show the " comments are closed " . So if I go to Set ATO->Style & configure COMMENTS->Allow comments on "Page" pages, too? - to NO this closes all my comments. Not what I needed.

Next I find the " How to remove " comments are closed from the end of post thread ; in which Flynn and you replied to. AHHHHH , just the solution I was looking for ( so I thought ) . But when I apply to Flynn's solution , nothing happens.

I go to the Theme Options -> Post Info Items, and delete that term from the %comments.... tag, leaving its opening and closing single quotes. I did this in both the Home page and multi page options. But still the " comments are closed " still appears.

I went a little further. I deleted everything inside the quotation marks on both the ATA>Post Info Items>FOOTER: HOMEPAGE and in the FOOTER:Multi Post Pages . I re-refreashed my web page ...
still there the " Comments are Closed " tag.

Any Ideas ???

Here is my site : www.arlandiz.com

Thank you for time ....


Sergio Arlandiz

PS You guys are doing a GREAT JOB !
  #2  
Old Mar 3, 2010, 02:48 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
ok, first off lets review some things
1) Atahualpa allows you to have comments on pages in addition to posts.
-- set 'ATO->Style & configure COMMENTS->Allow comments on "Page" pages, too?' to YES
-- make sure dashboard->pages->edit->pagexxxx->Discussion=>Allow Comments is checked
you can shut off comments for any single page by setting it's 'Allow Comments' to NO

2) there is a bug in WordPress that will allow only one comment per page. This will be fixed in WprdPress 3.0, in the meantime you must change a WP module. See post# 14 in http://forum.bytesforall.com/showthread.php?t=5031

3) The 'Comments are closed' / '1 comment to pagexxxx' that preceeds the comments is the same on a PAGE page and a SINGLE POST page. However it is not the same as
'February 18th, 2010 | Category: Uncategorized | 3 comments'
that appear in a POST's footer (which is defined at ATO->Edit POST/PAGE INFO ITEMS->FOOTER: xxx)

So, in order to have comments on PAGES, you need to do two things
1) at ATO->Style & configure COMMENTS->Allow comments on "Page" pages, too? set to YES
2) on each PAGE check off 'Allow Comments.' in the discuession section

if 'Allow comments on "Page" pages, too?' = YES and 'Allow Comments.' is checked
comments and comment form shows up
if 'Allow comments on "Page" pages, too?' = YES and 'Allow Comments.' is NOT checked
if there are comments, they show but no form,
if there are NO comments, just text 'comments are closed' shows
if 'Allow comments on "Page" pages, too?' = NO and 'Allow Comments.' is checked
no comments or comment form shows up
if 'Allow comments on "Page" pages, too?' = NO and 'Allow Comments.' is NOT checked
no comments or comment form shows up

You control the text that shows up when the comments are closed for a PAGE or a POST at ATO->Style & configure COMMENTS->Comments Are Closed text

If after digesting all this you still have questions feel free to ask
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Mar 3, 2010, 06:01 PM
arlandiz
 
5 posts · Aug 2009
First of all let me stay that after being in the forum for a few months and just being a on looker , its bit of a privilege of exchanging communications with you.

Now ... I read and studied your prompt reply. Thank You

Here was mistake... I share it in the hope that other will not follow my footstep..

In trying to control the text so "comments are closed" would not appear , I was try to control from
ATA > Edit Post Page Info Items >Footer:Homepage
and
ATA > Edit Post Page Info Items >Multi Post Page

I was trying to do it from here because it the first place I saw that "comments are closed" could be edited. THIS WAS MY MISTAKE!

The correct place to edit or control this is
ATA> Comments >Style and Configure Comments >Comments are Closed Text

Thank You very much for showing the light !

I very much enjoy reading Flynn , you and the other participants in this forum !!!

one more time you guys are doing a great job....

Sergio

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Remove 'Comments are closed' sparksmex Comments, trackbacks & pings 7 Sep 24, 2009 07:38 AM
[SOLVED] Remove 'Comments are closed' from single post pages. Per Lund Post-Kicker, -Byline & -Footer 2 Aug 13, 2009 07:15 AM
[SOLVED] Comments closed on my blog dee Comments, trackbacks & pings 3 Jul 22, 2009 12:26 PM
Comments are Closed. iain Comments, trackbacks & pings 2 Apr 2, 2009 09:10 AM


All times are GMT -6. The time now is 12:55 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.