Forum has moved to another host, some things may be broken or shaky for a little while
Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

[SOLVED] Help with Atahualpa and Category Icons


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Feb 2, 2010, 04:05 AM
Vedder2k
 
3 posts · Feb 2010
Hi

Firstly can I just say that I really love the Atahualpa theme.

I am trying to incorporate the Category Icons plugin, but not having much luck.

I have followed the thread here: http://forum.bytesforall.com/showthread.php?t=3936

But I still cannot get the icons to show up.
I have tried the line <?php if (function_exists('get_cat_icon')) get_cat_icon(); ?> and no icon appears, so to test I changed the byline options to just have the get_cat_icon() function and it errors:

Fatal error: Call to undefined function get_cat_icon() in /home/xxxxxxx/public_html/xxxx.co.uk/blog/wp-content/themes/atahualpa/functions/bfa_postinfo.php(593) : eval()'d code on line 1

To me (and I admit I am a bit of a php/wordpress noob) the function is missing from somewhere in the Atahualpa theme.

Can someone point me in the right direction where I can find the function code, and where I need to put it?

**Update**

I switched back to the default theme, and the icons are still not showing up, even after confirming that the code is in place as per http://www.category-icons.com/2009/0...page/#more-695

I am upgrading wordpress to 2.9.1 to see if this helps.

** Update on the update**

Upgrading did not work, and the icons dont show up on the default theme.
Interestingly the icons menu seems to point to root of the domain, not the domain/blog folder where wordpress is installed. I have deleted and reinstalled the plugin, but it still does not work!

Many thanks

Stuart

Last edited by Vedder2k; Feb 2, 2010 at 04:47 AM.
  #2  
Old Feb 2, 2010, 05:16 AM
juggledad's Avatar
juggledad
 
22,151 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
If you get the error 'undefined function get_cat_icon()' that means the function is not there. It is not in the Atahualpa code, it is in the plugin's code. Did you activate the plugin?
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Feb 2, 2010 at 12:44 PM.
  #3  
Old Feb 2, 2010, 07:06 AM
Vedder2k
 
3 posts · Feb 2010
The plugin has been activated, and I can get to the options in the Icons menu on the left hand side menu, they all look ok, but for some reason the functions don't seem to have installed anywhere in my WP.

I have reinstalled the plugin, but that does not have seemed to have made any difference.

It's weird!
  #4  
Old Feb 2, 2010, 07:38 AM
Vedder2k
 
3 posts · Feb 2010
Fixed it.

First time round I installed the Category Icons plugin using the inbuilt plugin utility within wordpress.

I deleted that and uploaded the zip file from the authors site, and unzipped it, then activated the plugin and now it works!

Thanks for your help though.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Category icons seboush Header configuration & styling 6 Oct 17, 2009 10:45 AM
RSS icons disappear sirabi RSS, Feeds & Subscribing 1 Sep 15, 2009 09:02 AM
Why are my sociable icons spread out? dsegel Post-Kicker, -Byline & -Footer 1 Jun 26, 2009 03:44 PM
Bug? Atahualpa 3.3.3 Theme Options > Category Menu Bar Deahna Page & Category Menu Bars 5 Jun 1, 2009 08:46 PM
Help! Sociable icons showing faded adashofsass Post-Kicker, -Byline & -Footer 4 Apr 16, 2009 06:45 AM


All times are GMT -6. The time now is 05:26 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.