Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

[SOLVED] widget logic and atahualpa compatibility


  #1  
Old Jan 1, 2010, 05:59 PM
bigliettaio's Avatar
bigliettaio
 
128 posts · Nov 2009
Italy
I have following problem with atahualpa ( here and here ).
I'm triyng to solve this fault, and thought to use widget logic to don't displayed latest post widget.
I set on widget logic form at the bottom of Latest Posts widget :
is_404(),
and now my banners are properly displayed on the top of the post but,
now
latest posts widget are disappeared from every page....

Why ?
  #2  
Old Jan 2, 2010, 07:54 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I'm not an expert on conditional statements, but maybe what's happening is that you've used Widget Logic to say "display this on 404 pages," so it's ONLY displaying on 404 pages.
  #3  
Old Jan 2, 2010, 08:26 AM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
bigliettaio, what is the code you put in the plugin?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Jan 2, 2010, 08:34 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
You might also want to try using the Display Widgets plugin. You just select the pages you want a widget to appear or not appear on. Simple.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Jan 2, 2010, 09:11 AM
bigliettaio's Avatar
bigliettaio
 
128 posts · Nov 2009
Italy
JD i put this code:
is_404()

Ii think paulee has give the right answer: is like if i have to say to widget logic if in not 404 page displays last posts widget, but how to do?

Another "strange think" that happened to my theme:

2 different page not found are generated from the theme depending on
1) using a search form inside the theme: example
2) adding a page that not exist at the end of the url of my site: i.e.: example

Last edited by bigliettaio; Jan 2, 2010 at 09:37 AM.
  #6  
Old Jan 2, 2010, 09:39 AM
bigliettaio's Avatar
bigliettaio
 
128 posts · Nov 2009
Italy
Quote:
Originally Posted by paulae
I'm not an expert on conditional statements, but maybe what's happening is that you've used Widget Logic to say "display this on 404 pages," so it's ONLY displaying on 404 pages.
that' s true.
  #7  
Old Jan 2, 2010, 09:40 AM
bigliettaio's Avatar
bigliettaio
 
128 posts · Nov 2009
Italy
Quote:
Originally Posted by lmilesw
You might also want to try using the Display Widgets plugin. You just select the pages you want a widget to appear or not appear on. Simple.
Hi Larry, thanks for the suggestion.
  #8  
Old Jan 2, 2010, 09:58 AM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
try '!is_404()' ths says 'if NOT a 404'
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Jan 2, 2010, 01:13 PM
bigliettaio's Avatar
bigliettaio
 
128 posts · Nov 2009
Italy
Hi JD,
widget is properly displayed in every pages
BUT
in 404 page not found ALSO.

I can't understand what happened.
As explain you before it is as atahualpa generate 2 404 page not found
1st for search inside the site
2nd for url that do not exist:

try to make a search inside the site
and try to add q random word after the url

you could notice 2 different 404 page not fourd :
first un correct ( according our settings)
second displayed properly ( according our setting)

???

Last edited by bigliettaio; Jan 2, 2010 at 01:20 PM.
  #10  
Old Jan 2, 2010, 06:40 PM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Ok, what is happening here is that one page is your real 404 page - this shows up when you use xxx.com/foobar, the other page is the search result page. When you search for something and it's not there.

So that is why the widget doesn't show up on the 404 page (the !is_404 handles that) you need to add a not is_search() so try '!is_404() AND !is_search()'
of course, if you do a search and find something,the widget ill still not show up.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #11  
Old Jan 3, 2010, 03:56 PM
bigliettaio's Avatar
bigliettaio
 
128 posts · Nov 2009
Italy
OK excellent,
thank you JD,
now everythings works in the right way.


Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Inline Google Maps compatibility redwagon Plugins & Atahualpa 13 Oct 11, 2011 05:01 AM
How do you add header widget in atahualpa 3.4.4 speedywap Plugins & Atahualpa 1 Nov 25, 2009 12:45 PM
WP plugin compatibility clues jack96161 Plugins & Atahualpa 2 Oct 29, 2009 03:02 PM
Widget Voodoo Plugin and Atahualpa dilly Plugins & Atahualpa 3 Jun 4, 2009 07:53 PM
Major Widget Probs with Atahualpa XpectMore Sidebars & Widgets 2 Feb 15, 2009 12:03 AM


All times are GMT -6. The time now is 10:03 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.