Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

Using more than one New Widget Area


  #1  
Old Oct 16, 2009, 01:15 PM
Suzie
 
24 posts · Apr 2009
I have two New Widget Areas set up.

The first one is to appear only on the front page, has two cells and is located before the loop. It works as it should.

<?php if ( is_front_page() ) { ?>
<?php bfa_widget_area('name=Top Front Page&cells=2&align=9&width_1=310&width_2=350&befor e_widget=<div id="%1" class="header-widget %2">&after_widget=</div>'); ?>
<?php } ?>

The other is within the loop and it works as it should on its intended pages. I am using the "Simple Sidebar Navigation" plugin within the widget area. It is to displays on pages that I tell it too.

<?php bfa_widget_area('name=More Pages'); ?>

The problem that I am having is that this second widget area that I created is showing up on the front page. Shouldn't the closing tag from the first widget area prevent that?

Thanks,
Suzie
  #2  
Old Oct 16, 2009, 07:00 PM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
If you put the second area
HTML Code:
<?php bfa_widget_area('name=More Pages'); ?>
in the loop, then it will show up on all pages unless something else prevents it.

The first batch of code will only show up on the front page but it has no effect on the second line of code. Also, unless you are using the first batch of code to surrond other cod, it is probally - for readability reasons - better to code it in one <?php...?> group like this
HTML Code:
<?php if ( is_front_page() ) { 
    bfa_widget_area('name=Top Front Page&cells=2&align=9&width_1=310&width_2=350&before_widget=<div id="%1" class="header-widget %2">&after_widget=</div>'); 
    } ?>
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Oct 16, 2009, 10:36 PM
Suzie
 
24 posts · Apr 2009
Actually, I think that my problem is really with those new widget areas that I cannot get rid of.

I've added some new content to appear in the second set of new widget areas and that content is not showing on the front page.

I see that you are going to post how to remove them in another thread, so I will wait and try that out.
  #4  
Old Oct 17, 2009, 08:02 AM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
directions done, see http://forum.bytesforall.com/showthr...6907#post16907
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Help ! Links broken in widget in new widget area mikecnwa Sidebars & Widgets 4 Sep 16, 2009 01:56 PM
WPMU - new widget area(S) ? teros Sidebars & Widgets 3 Sep 5, 2009 04:22 AM
New Widget Area formatting calutateo Sidebars & Widgets 1 Aug 16, 2009 04:03 AM
Footer Widget Area aebrigham Sidebars & Widgets 2 Aug 11, 2009 01:26 PM
New widget area in header paulae Sidebars & Widgets 10 Jul 3, 2009 01:45 PM


All times are GMT -6. The time now is 12:01 AM.


Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.