Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

Sidebar widgets are simply not appearing


  #1  
Old Oct 7, 2009, 03:25 PM
aceseowebdesign
 
1 posts · Oct 2009
Hello Everyone,

I am using version 3.4.4 with WP 2.8.4 on a brand new blog.

Simply put, I can't get any sidebar widgets to work. I have activated all of the left, left inner, right and right inner columns but nothing works.

Also, I can't get rid of blogroll or the meta sections. I've never had this problem with this theme before so I could really use some help.

Thanks,

Ed
  #2  
Old Oct 7, 2009, 06:00 PM
juggledad's Avatar
juggledad
 
23,632 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
did you add any widgets to those areas? (dashboard->appearances->widgets)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Oct 9, 2009, 06:06 AM
BrunoRibeiro
 
1 posts · Oct 2009
Having similar problem.

On dashboard->appearances->widgets the right sidebar is empty, but on the blog it shows the Recent Posts, Blogroll and Meta widgets. On another note, I can't make the Pages widget appear in any of the sidebars (I have Left INNER sidebar, Righ INNER sidebar and Right Sidebar actives on all pages). It seems to be the only widget I can't make it to appear. I've tried to put other widgets on the same locations and didn't have any problems with those I've tried.
  #4  
Old Oct 9, 2009, 06:28 AM
juggledad's Avatar
juggledad
 
23,632 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What version of Atahualpa, WP and PHP?
Quote:
On dashboard->appearances->widgets the right sidebar is empty, but on the blog it shows the Recent Posts, Blogroll and Meta widgets.
these are the default wordpress widgets and will stay there until you add a widget to that area

Quote:
On another note, I can't make the Pages widget appear in any of the sidebars (I have Left INNER sidebar, Righ INNER sidebar and Right Sidebar actives on all pages). It seems to be the only widget I can't make it to appear. I've tried to put other widgets on the same locations and didn't have any problems with those I've tried.
if you fill in the TITLE does it show? Do you actually have some pages published?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Oct 9, 2009, 10:31 AM
atomm
 
3 posts · Oct 2009
I have exactly the same problem with Atahualpa 3.4.4, WP 2.8.4 and Php 5.2.11

The drag&drop of the widget on the right side bar area is just not enabled (no destination highlighting)

If it is a bug, is there any way to do the same operation (in my case, adding a widget to the right side bar and removing the default ones) manually ?

Thanks
  #6  
Old Oct 9, 2009, 12:11 PM
juggledad's Avatar
juggledad
 
23,632 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
does the same thing happen iusing the default theme? I've noticed in WP 2.8.4 that you have to move a widger to the 'correct' area of the sidebar and then a dashed rectangle appears that you can drop it in.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Oct 9, 2009, 03:14 PM
atomm
 
3 posts · Oct 2009
Actually in WP 2.8.4 it works as you describe with the dashed rectangle to drag in. It works in the default theme but there isn't a right bar. it also works in Atahualpa but not in the right bar and in general not very well and not with all the widgets I think. In the right bar no dashed rectangle appears.
  #8  
Old Oct 9, 2009, 03:42 PM
juggledad's Avatar
juggledad
 
23,632 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what browser? With 3.4.4 WP 2.8.4 and PHP 5.2.9 I can put widgets in all four sidebars
Have you tried another two column theme?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Oct 10, 2009, 09:22 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Same problem here. ATA 3.4.4 (also tried 3.4.3), Safari and Firefox on a Mac, PHP5, WP 2.8.4.

I have a brand-new site, clean, new install of everything. I have these plugins activated:

Akismet
Executable PHP widget
TinyMCE Advanced
WP Events Calendar

I have only the right sidebar enabled now. I had left and right for a time, and when I tried to get the Events Calendar widget to show up as an events list in the left, it worked. Now I want to get rid of it and put it in the right sidebar. No matter what I do, it won't leave the left sidebar, and I cannot drag/drop it to the right. I can't drag/drop any widget. All of this works perfectly with the default theme.

JD, I know Flynn isn't around, but would you like to get into the guts of the site and look around? I will be happy to let you in, as this might help you and Flynn figure out what's going on, in a simple environment. PM me if you're interested.

Note: I also still cannot remove 3 added widget areas. And now the Events Calendar widget is off the left sidebar in admin, but I can't drag it to the right.

Last edited by paulae; Oct 10, 2009 at 09:32 AM.
  #10  
Old Oct 11, 2009, 11:38 AM
juggledad's Avatar
juggledad
 
23,632 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Paulae, yes I think I'll have to do that (see my PM)
also, do you have any thing in the 'Inactive Widgets' area?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #11  
Old Oct 11, 2009, 01:06 PM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Ok JD. I'm traveling at the moment and will get you the info when I arrive home I a few hours
  #12  
Old Oct 12, 2009, 05:44 AM
juggledad's Avatar
juggledad
 
23,632 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Paulae, I was just playing with the site and discovered it is the 'wp events calendar' plugin causing the problem. Once you deactivate it, you can move the widgets around again.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #13  
Old Oct 12, 2009, 06:49 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Darnit! I love that calendar! Have you any clue why that's happening?
  #14  
Old Oct 12, 2009, 09:55 AM
atomm
 
3 posts · Oct 2009
ok, also for me once removed the calendar event plugin, the other widgets work again

Thanks,
Tommaso
  #15  
Old Oct 12, 2009, 02:01 PM
extremecarver
 
100 posts · Jul 2009
Well maybe plugins are triggering the same error that happens when you deactivate the Atahupalpa Page Options.

I seriously think there is an error also on atahualpas side. If you deactivate page options (clean install) the same thing happens (and it is not funny to have those page options enables as they break about any of my SEO plugins and also qtranslate).

Last edited by juggledad; Oct 12, 2009 at 02:24 PM.
  #16  
Old Oct 13, 2009, 05:48 AM
juggledad's Avatar
juggledad
 
23,632 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
How did you go about deactivating the Atahualpa Post Options?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #17  
Old Oct 13, 2009, 05:52 AM
extremecarver
 
100 posts · Jul 2009
As written by Flyn
Code:
To remove that you'd have to delete the whole section in functions.php starting with

/* CUSTOM BODY TITLE and meta title, meta keywords, meta description */
..
..
..

up to the last closing ?> at the very last line of functions.php, but leave that last ?> in there
This was working well in 3.4.1 and 3.4.2 (did not try out 3.4.4) - but empties the right sidebar in 3.4.4.
  #18  
Old Oct 13, 2009, 06:01 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
RE: the Events Calendar plugin

I reactivated it on that site, and all appears to work, except that I have to use Accessibility Mode when dealing with the widgets. Otherwise, although I can drag and drop the Events Calendar widget into a sidebar and go through the steps to configure and save it, it does not appear on the live pages, nor is it there when I go back to admin. If I enable Accessibility Mode, then I can accomplish all this.

I'm willing to do it this way because I think it's a good calendar. But why is it happening? With the WP default theme activated, the widget admin works fine without accessibility mode on. So surely there must a problem with Atahualpa, somehow. It's version 3.4.4. If you want back in to poke around, let me know.
  #19  
Old Oct 13, 2009, 06:41 AM
juggledad's Avatar
juggledad
 
23,632 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
very dangerous to follow the directions that are release specific, the code was rewritten and a routine was added to the end of functions.php - with that in mind, in 3.4.4 try this, delete lines 491-630 of functions.php

this will remove the Atahualpa Post Options. See if this fixes your issue - Note, when I deleted everything our, I could not reproduce the issue, widigets were added with no problem.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #20  
Old Oct 13, 2009, 06:50 AM
extremecarver
 
100 posts · Jul 2009
Just deleting down to 630 seems to work. - Actually you are right, pretty stupid from me deleting down to the bottom - should have checked to only delete the same lines as in the version before.

Note that on my home page and on error pages widgets were working, but not on subpages when I deleted 491-up to the last closing ?>
  #21  
Old Oct 13, 2009, 07:28 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Well, now I'm having more problems. Earlier, I was in accessibility mode. I tried to put the Links widget in the left sidebar. It didn't save. So I tried again. Now I had it twice, and it also showed up in the right sidebar, along with the damned Meta widget! All I want in the right sidebar is recent posts and recent comments. Only recent posts is showing up there on the live page, but no widget at all is showing up in widgets admin in the right sidebar. I've disabled the Events Calendar, but the problems persist.
  #22  
Old Oct 13, 2009, 08:28 AM
juggledad's Avatar
juggledad
 
23,632 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Very weird. Paulae gave me access to the site and I could not drag a widget. I switched to accessibility mode - added a text widget to the right sidebar - viewed the page - switched accessability mode off and 'Ta Da' I could now drag widgets
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #23  
Old Oct 13, 2009, 08:52 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Thanks again for your help! It's maddening not to be able to use a favorite plugin, but the overall site functionality is more important than the calendar. I've gone back, for now, to an old Perl script we'd been using, and put iframe code for it on the calendar page. I have to do some color changes so it'll look better. Yuck. http://www.aghca.org

If anybody knows of a really good events calendar plugin, let me know.
  #24  
Old Oct 13, 2009, 09:00 AM
flaneur
 
10 posts · Oct 2009
Bloomington, IN, USA
I had similar problems with Events Calendar... something to do with the way it dynamically creates one event page that contains all of the plugin information. The only option that worked was to delete the plugin.
  #25  
Old Feb 10, 2010, 03:08 PM
joan
 
50 posts · Sep 2009
Brisbane, Qld, Aust
I use Events Calendar 3. I've changed the wp2.9.1 permalink structure to %post_id/%post_name/ (eg ibooktravel.com.au/1/hello-world/), but the event shown in the calendar widget goes to ibooktravel.com.au/date/2010/03/08/?ec3_listing=events which it says does not exist... rendering the calendar useless. When I rolled back to the previous version of Events Cal, no events show up at all in the calendar. Haven't sorted it yet. I'd like to stick with the latest version of EC3, as it has such a neat widget display for the sidebar. There is no support (other than 'I'm indefinately out'), but the beta3 version is downloadable from the author's site. Its a great plugin, if only I could get it working.

I also tried The Event Calendar but it completely destroys Atahualpa's sidebars & footer.

Last edited by joan; Feb 10, 2010 at 03:15 PM.

Bookmarks

Tags
side bars, sidebar, widget, widgets

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] The blogroll simply doesnt dissappear siggiboy81 Sidebars & Widgets 1 Sep 26, 2009 12:52 PM
Widgets appearing on sidebar and on the bottom of new posts dyertribe Sidebars & Widgets 3 Jul 22, 2009 03:25 AM
right widgets cut off in IE, Firefox-right sidebar text smaller than on left sidebar daisy24 Sidebars & Widgets 2 Feb 23, 2009 10:59 AM
Set left sidebar widgets same distance from center area as right sidebar widgets daisy24 Sidebars & Widgets 2 Feb 19, 2009 05:11 AM
[SOLVED] Blogroll links not appearing in sidebar artoftroy Sidebars & Widgets 2 Jan 13, 2009 10:33 AM


All times are GMT -6. The time now is 08:07 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.