Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Home page won't load! Parse error, syntax error


  #1  
Old Aug 30, 2009, 09:01 AM
lhanft
 
88 posts · Jul 2009
Cleveland, OH
As far as I can tell, all I was doing was adding some subpages to the site. After adding one of them, when I refreshed the home page I got the following error message:


Parse error: syntax error, unexpected T_STRING in /home/shem/public_html/wp-content/themes/atahualpa342/functions.php(396) : eval()'d code on line 2

I looked at the code but nothing jumped out at me as a glaring error. How can I fix this?

PS attaching functions.php

PSS wordpress 2.8.4
atahualpa 3.4.2
Attached Files
File Type: txt functionsphp.txt (20.0 KB, 1982 views)
  #2  
Old Aug 30, 2009, 09:09 AM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
swap to the default theme and remove the last page you created. Then swap back to Atahualpa and see if it works
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Aug 30, 2009, 10:01 AM
lhanft
 
88 posts · Jul 2009
Cleveland, OH
No, it didn't work.
Here's something weird: the homepage url (http://theagnonschool.org) immediately redirects to the last page I created (and the one I deleted when I switched to the default theme). That page is http://theagnonschool.org/parents/cl...hildhood-news/. In the default theme, when that page tries to load, there's a 404 message (since the page doesn't exist). In Atahualpa, there's the parse error, syntax error message.

What else can I try?
  #4  
Old Aug 30, 2009, 10:09 AM
lhanft
 
88 posts · Jul 2009
Cleveland, OH
Juggledad,
Thanks for your help. Since I couldn't figure out what I did in creating several new pages -- or which new page -- caused the problem, I just restored last night's database backup, and all is working again.
But I really appreciate your fast help.
Lila
  #5  
Old Aug 30, 2009, 01:44 PM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Actually, your problem still exists, just try http://theagnonschool.org/dsfgsd and the error will occur.
1) what do you have at ATO->Style & edit CENTER COLUMN -> Content if NOT FOUND?
2) please set ATO->Configure CSS & JS items to 'Internal', 'Internal', 'NO' and 'YES
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Tags
atahualpa 3.4.2, homepage, parse error, syntax error

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Parse error: syntax error, unexpected '<' in the functions.php file pingitt Atahualpa 3 Wordpress theme 6 Mar 12, 2013 03:52 AM
[SOLVED] Parse error: syntax error, unexpected ':', expecting ')' in /home/cwicsol/pu norwichkaren Page & Category Menu Bars 1 Jul 12, 2009 10:04 AM
[SOLVED] Syntax Parse error PLEASE help me out.... norwichkaren Atahualpa 3 Wordpress theme 1 Jul 12, 2009 08:51 AM
Can not activate my theme due to parse erorr Parse error tanimwp Forum How-To 2 Jun 17, 2009 03:13 AM
Parse error: syntax error!!! liabelle Atahualpa 3 Wordpress theme 2 Apr 22, 2009 11:48 PM


All times are GMT -6. The time now is 07:22 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.