Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

Problems with Sidebar Display in firefox


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jul 22, 2009, 01:06 PM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
Ok..I may have messed things up. My bullets are not lining up the proper way in Firefox. Everything looks great in IE (which is unusual for me).

What've I've done is create a custom header for each of the text widgets that I've using. (Couldn't get the code mentioned elsewhere here to work) I've had then to add a blank image in between to get some spacing that my client wants in between each text widget.

Could the problem might be the Flexipage widget? I've never had problems before with it but then I've never done it quite like this before.

The best way is to have you look at a test site

I've tried moving the text widgets around but it doesn't seem to help.I have the feeling it (Notice the ebook doesn't have a bullet...it's under the header)may also have something to do with my image headers also. I've notice to get the proper alignment of the images boxes I've had to center all but one and if I don't do a left alignment then it gets moved way to the right.

Any suggestions?
  #2  
Old Jul 22, 2009, 10:11 PM
Flynn's Avatar
Flynn
 
3,745 posts · Oct 2008
Munich, Germany
The widgets below the book image are moving inside the book because it is floated to the left. Add something after the book image to stop the float such as <div style="clear:both;height:1px"></div>

The reason this doesn not happen with floated images in posts is that the div.post-footer has clear:both

Increasing the margin-bottom of widgets worked well when I tried it on your site (except for the float issue), the images wouldn't be needed

div.widget {
margin-bottom: 50px;
}

or, to limit it to flexipages widgets

div.flexipages_widget
margin-bottom: 50px;
}

In that case !important may be required as both .widget and .flexipages_widget are just classes, and on the same element, so basically equally strong

div.flexipages_widget
margin-bottom: 50px !important;
}
  #3  
Old Jul 28, 2009, 09:09 AM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
Ok...I have played with this until I'm blue in the face. Left it and came back a few days later and I'm still not seeing what I'm suppose to do. Think I must be putting things in the wrong places. Exactly where does <div style="clear:both;height:1px"></div> go?

Are you also saying that the black images I'm using can be eliminated by increasing the bottom margin of the widget? (Make sense) Do I do that in the CSS Inserts? It is one of the things I tried but it didn't seem to make a difference but I likely did something wrong.

Just hate it when I can get things looking good in IE but not Firefox. This theme though is teaching me so much.
  #4  
Old Jul 29, 2009, 09:33 AM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
Ok...This is what I've done. I want to start with the widgets or at arrows first. I've tried entering the code <div style="clear:both;height:1px"></div> in the CSS Inserts and also directly in the book widget. There doesn't seem to be any change. They still seem to be floating upwards in Firefox. I know I must be missing something.

I want to remove the blank images but thought I would try to deal with one problem at a time. They were the only way that I knew of to fix it but then that's becuase I'm not a programmer. If you think they are part of my problem I can remove them and then try this?

Thanks so much for your support. This site has been a challenge for me because the original site designed (not by me) was by a graphic designer who had images all over the site. Trying to get the mindset changed has been interesting.


Quote:
Originally Posted by Flynn
The widgets below the book image are moving inside the book because it is floated to the left. Add something after the book image to stop the float such as <div style="clear:both;height:1px"></div>

The reason this doesn not happen with floated images in posts is that the div.post-footer has clear:both

Increasing the margin-bottom of widgets worked well when I tried it on your site (except for the float issue), the images wouldn't be needed

div.widget {
margin-bottom: 50px;
}

or, to limit it to flexipages widgets

div.flexipages_widget
margin-bottom: 50px;
}

In that case !important may be required as both .widget and .flexipages_widget are just classes, and on the same element, so basically equally strong

div.flexipages_widget
margin-bottom: 50px !important;
}
  #5  
Old Jul 30, 2009, 10:40 AM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
I hope that you can help me yet. I'm at a stopping point because I still seem to be struggling with this.
  #6  
Old Jul 31, 2009, 04:40 AM
juggledad's Avatar
juggledad
 
21,699 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Add the
HTML Code:
<div style="clear:both;height:1px"></div>
after the <img in each occurance of the text widget For Example
HTML Code:
<img src="http://www.sandynorton.com/sandygluckman/wp-content/uploads/2009/07/schedule.gif" alt="schedule" title="schedule" width="194" height="39" class="alignleft size-full wp-image-415" />
<div style="clear:both;height:1px"></div>
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #7  
Old Jul 31, 2009, 09:26 AM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
Thank you so much! I knew I had a mental block. I had it on one image but not the rest. Makes sense. Now I can look at the rest of his instructions although I've goot it looking alright, I'd rather do it the right way. Plus, it will make it easier down the road.

Again, thanks!
  #8  
Old Jul 31, 2009, 01:36 PM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
Hi,

Ok...I got the problem of floating images taken care of, thank you.

Now I'm trying to set up the right spacing between text boxes. I was using a blank image which work, but means I have to add it each time. In reviewing the instructions below I'm not quite getting it. Is this added at CSS Inserts or is it added to the Widget Container? I've tried in both place but not sure I'm doing it right.

Right now this is what I have on the Widget Container

margin: 0 15px 15px 0; I believe this will affect only the text widget and not the flexi page widget?

I've added

div.flexipages_widget
margin-bottom: 50px;
}

to the CSS Insert but don't see a change. I'm sure once again I'm missing something simple. I don't mind using a blank image until I can get this sorted out. At this point it works but it's now the right way to do it I know.

Sleenie




Increasing the margin-bottom of widgets worked well when I tried it on your site (except for the float issue), the images wouldn't be needed

div.widget {
margin-bottom: 50px;
}

or, to limit it to flexipages widgets

div.flexipages_widget
margin-bottom: 50px;
}

In that case !important may be required as both .widget and .flexipages_widget are just classes, and on the same element, so basically equally strong

div.flexipages_widget
margin-bottom: 50px !important;
}
  #9  
Old Jul 31, 2009, 03:02 PM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
Ok...I'm now offically getting frustrated at myself. I have been using custom images in my sidebar for the header. Needed more spacing between widgets and got that handled. Got the floating imagees in Firefox handled thx to the fourm.

Now, for some reason some of the images aren't showing up them up on the pages I need them to be. I could have sworn they were there before.

I'm using flexipages and those show up fine. Most of the header images do also. On the home page they all show up exactly as they are suppose to.

I have no sidebar widgets on most of the pages EXCEPT the speaker pages. For some reason, it seems to skip and couple of them although I have checked and checked and they seem to be configured the same. I'm using the Widget Context plug for this. I have speaker/* on all of the appropriate widgets. So how come some show up and others don't?

Did I maybe make a change in the theme that for some reason did this too me?

Site is sandystestsite A page that is not showing correctly is here.

I'm just getting ready to move this site this weekend. Still have lots to do with linking etc. so this has defintiely put a damper on things.
  #10  
Old Aug 2, 2009, 09:07 AM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
Just a quick update to the probem with the sidebar and my widgets. The culprit seems to be the Widget Context plugin. It worked at one time or at least I thought it did. Anyway, I deactivated and the problem was solved. Of course now I hve widgets on all of my pages which I don't want. I'm wondering the the custom images I'm using for the headers is creating the probem.

Main thing it is not a theme problme that I can see. Just maybe the wrong way I'm setting the sidebar texts.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unwanted display of plugins in right sidebar Chester Sidebars & Widgets 4 Sep 10, 2009 04:11 AM
Google Translate widget shows way to right of sidebar in Firefox daisy24 Sidebars & Widgets 2 Mar 24, 2009 05:14 PM
Problems with adding image/graphic in sidebar Nefeli Sidebars & Widgets 5 Feb 25, 2009 07:16 AM
right widgets cut off in IE, Firefox-right sidebar text smaller than on left sidebar daisy24 Sidebars & Widgets 2 Feb 23, 2009 10:59 AM
RIGHT sidebar: Don't display on Categories: Not working Ponics Atahualpa 3 Wordpress theme 6 Dec 27, 2008 06:47 AM


All times are GMT -6. The time now is 10:32 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.