Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

[SOLVED] Page was updated and is now missing Header


  #1  
Old Nov 24, 2017, 05:13 PM
markzip
 
60 posts · Jan 2010
WP 4.9
Ata 3.7.5
Problem page: http://clairebolderson.com/training
this single page is missing the header.

Header includes image and menu.

Other pages such as:
http://clairebolderson.com/journalis...ne-journalism/
and
http://clairebolderson.com/moderating-speaking/
are unaffected.

Have tried disabling all plugins and nothing changed. Have disabled cache and refreshed.

This site is rarely changed, so there's not a lot of clues for me to figure this out.
  #2  
Old Nov 24, 2017, 08:05 PM
juggledad's Avatar
juggledad
 
23,560 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
So what changes have you made? If it is not a plugin, then it is something else you have done. The first step is to check to see if the header is missing from the actual source of the page, so go to the page and in your browser, find the option to view the source. You will probably need to turn on the browsers developers tools to see that option.

Once you have it, copy the source to a text file and do a search for '<!-- Header -->' then scroll down and see if you see if you see things like the logoarea and the menu items etc.

Let me know what you find.

p.s. I know the what the issue is but I'm going to walk you thru how to discover the problem yourself. I'm on the east coast US so I'll look for a response in the morning.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Nov 25, 2017, 12:27 AM
markzip
 
60 posts · Jan 2010
Thanks for the note, JuggleDad

Unfortunately, it was not I who changed the page. Another editor did it and then told me of the error. Looking at the page revision history did not help much. A few small changes in the text here and there, the removal of a pdf embed, a couple of tiny formatting things.

Here's the header code. It looks fairly conventional, containing the logo area, the search box, the image, the menu and the bar.
Code:
<!-- Header -->
		<td id="header" colspan="1">

		<table id="logoarea" cellpadding="0" cellspacing="0" border="0" width="100%"><tr><td rowspan="2" valign="middle" class="logoarea-title"><h2 class="blogtitle"><a href="http://clairebolderson.com/">Claire Bolderson</a></h2><p class="tagline">Journalist, Commentator, Moderator, Trainer</p></td><td class="feed-icons" valign="middle" align="right"><div class="clearfix rss-box"><a class="email-icon" href="http://feedburner.google.com/fb/a/mailverify?uri=ClaireBoldersonBlog&amp;loc=en_US" title="Subscribe via email">Email Feed</a><a class="posts-icon" href="http://clairebolderson.com/feed/" title="Subscribe via RSS">RSS Feed</a></div></td></tr><tr><td valign="bottom" class="search-box" align="right"><div class="searchbox">
					<form method="get" class="searchform" action="http://clairebolderson.com/">
					<div class="searchbox-form"><input type="text" class="text inputblur" onfocus="this.value=''" 
						value="" onblur="this.value=''" name="s" /></div>
					</form>
				</div>
				</td></tr></table> <div class="horbar2">&nbsp;</div> <div id="imagecontainer" class="header-image-container" style="background: url('http://clairebolderson.com/wp-content/themes/atahualpa/images/header/new-banner8.jpg') top center no-repeat;"><div class="codeoverlay"></div></div> <div class="horbar2">&nbsp;</div> <div id="menu1"><table cellpadding="0" cellspacing="0" style="margin: 0 auto"><tr><td align="center">
				<ul id="rmenu2" class="clearfix rMenu-hor rMenu">
<li class="page_item page-item-811"><a href="http://clairebolderson.com/"><span>Home</span></a></li>
<li class="page_item page-item-809"><a href="http://clairebolderson.com/blog/"><span>Blog</span></a></li>
<li class="rMenu-expand page_item page-item-737 page_item_has_children"><a href="http://clairebolderson.com/journalism/"><span>Journalism</span></a>
 <ul class="rMenu-ver">
	<li class="page_item page-item-741"><a href="http://clairebolderson.com/journalism/radio-journalism/"><span>Radio Journalism</span></a></li>
	<li class="page_item page-item-828"><a href="http://clairebolderson.com/journalism/tv-journalism/"><span>TV Journalism</span></a></li>
	<li class="page_item page-item-849"><a href="http://clairebolderson.com/journalism/online-journalism/"><span>Online Journalism</span></a></li>
	<li class="page_item page-item-847"><a href="http://clairebolderson.com/journalism/print-journalism/"><span>Print Journalism</span></a></li>
</ul>
</li>
<li class="page_item page-item-1916 current_page_item"><a href="http://clairebolderson.com/training/"><span>Training</span></a></li>
<li class="page_item page-item-820"><a href="http://clairebolderson.com/moderating-speaking/"><span>Moderating / Speaking</span></a></li>
<li class="page_item page-item-963"><a href="http://clairebolderson.com/contact/"><span>Contact</span></a></li>
<li class="page_item page-item-853"><a href="http://clairebolderson.com/about/"><span>About</span></a></li>
</ul></td></tr></table></div>
 <div class="horbar1">&nbsp;</div>
		</td>
		<!-- / Header -->
It may well be that I have been looking at this for too long and I am simply missing some extra div tag somewhere. I ran the page through the W3C Validator, and nothing jumped out. Just the usual warnings about ampersands and stuff.

Would include full page HTML, but that's to much for the vBulletin system text box.

TIA

Zip
  #4  
Old Nov 25, 2017, 04:13 AM
juggledad's Avatar
juggledad
 
23,560 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Ok, so you see that the html is there for the header, that means some CSS must be hiding it. To figure out what
1) go to ATO->Export/Import and export your settings so you have a backup.
2) go to ATO->Add HTML/CSS inserts->CSS Inserts and copy the contents to a text file
3) delete the contents of the CSS Inserts and hit the big green 'Save changes' button
4) go look at the page - is the header there? If so, something in the CSS is the cause

5) move half of the CSS that is currently in the text file back to 'CSS Inserts' and save it
6) go look at the page - is the header there? if not go back to step 5

7) if the header IS there then you have narrowed the cause if the issue so pull that CSS back out and put it in a text file.
8) move a couple lines of the CSS back in, save and test till you find the offending line(s) of CSS

remember to always move a batch of CSS from the selector thru the closing '}' for that chunck of CSS.

I'll be waiting to see what you find.

Note, if you don't want to effect the live site, another way to do this would be to
1) go to ATO->Configure CSS & JS->CSS: Compress? and make sure it is set to 'No'
2) copy the entire source of the page to a text file. Save the file with an extension of .html (a file name something like missingheader.html).
3) open the file in your browser.
4) in your text editor fine the line:
HTML Code:
/* Chrome and Safari don't like clearfix in some cases.
Also, adding height and font-size for IE6 */
the CSS after the .clearboth CSS is the start of the CSS Inserts
5) move the remaining CSS to a text file and save the missingheader.html file, save it, go to the browser and do a refresh. You should see the changes immediately.
6) copy some of the CSS back into the missingheader.html file, save it, go to the browser and do a refresh. if the issue shows up, the CSS you just added contains the problem.

I do this and/or use the inspector developer option in FireFox to look at sites and find the problems. Copying the file to a text file and pulling out the CSS is the way I discovered what was happening in this site.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Nov 25, 2017, 08:05 PM
markzip
 
60 posts · Jan 2010
FML,
I'm on the road, and so am on my laptop. When I was examining the CSS inserts earlier, I didn't scroll the text box down to the very end.

D'oh!

The very last entry was:

Code:
body.page-id-1916 div#imagecontainer {
background-image: url(http://yourdomain.com/wordpress/wp-content/uploads/page-id-7.jpg) !important;}
body.page-id-1916 td#header {display: none;}
And, yes, the page in question is id-1916. So it was being told expressly "do not show the header on that page".

Now I just have to wonder how that code got there. It's difficult to imagine this particular Editor fiddling around in there...

Thanks, as ever, for your invaluable help, JuggleDad

Zip

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Updated to 3.7.18: Site title, tagline, header and menu bar have all disappe cfibanez New Versions, & Updating 2 Sep 8, 2014 07:06 PM
[SOLVED] Updated to 3.7.13: admin bar still missing - metaslider not showing vandermark New Versions, & Updating 1 Dec 10, 2013 02:28 AM
Updated to 3.7.10 Version and Header changed. How do I fix it? hrtsmakefamily New Versions, & Updating 1 Dec 9, 2012 04:04 PM
Problem: Missing header image on page danroseman Header configuration & styling 6 Aug 8, 2011 04:16 AM
help, I lost my admin page, site still up header missing dataqueen.net. dataqueen Header configuration & styling 1 May 20, 2010 02:13 PM


All times are GMT -6. The time now is 02:21 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.