Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Pretty Permalinks, htaccess, and the ata-images folder


  #1  
Old Jul 21, 2014, 01:57 PM
Poorman
 
4 posts · Jul 2014
Hello and thanks to everyone that has contributed to this forum. I'm learning WP and have had many of my questions answered here just browsing through posts. But I finally have a question I haven't found the answer to:

I just changed to Pretty Permalinks, and updated my htaccess file manually. On the homepage everything looks fine. However if I click on a post or category, the background and a few other images aren't coming up. So it would seem that it doesn't know to look in the 'ata-images' folder for these other pages.

My wordpress url is: systemaddict.webfactional.com
My site url is: systemaddict.org

Any help is greatly appreciated.
  #2  
Old Jul 21, 2014, 06:43 PM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
you have two different domain names?
how are the two domains related?
where does each domain name point to? ie what folder?
where is the htaccess file?
what is the permalink you areusing

The ata-image location is only for the header images, logo and favicon. Other images in your posts are stored by wordpress in the media files (wp-content/uploads)

also can you provice an exact url showing the issue.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jul 21, 2014 at 06:45 PM.
  #3  
Old Aug 4, 2014, 03:45 PM
Poorman
 
4 posts · Jul 2014
Hello juggledad, thanks for your response. Please ignore what I said about having 2 different URLs and the htaccess file. I thought that setting was some sort of domain forwarding thing but I have since changed them both to systemaddict.org

My problem is with the background image, not the images for posts. But yes I do have that image in the 'ata-images' folder. I have this line in the setting Overall Style & Config.>Body, Text & Links>Body Style

background: url(wp-content/ata-images/bgmain.jpg) repeat top left;

And everything is fine. But if I change the permalink structure, that image no longer shows up when I go to one of my category pages (mixes, songs, etc.). You suggest I put this image in the "wp-content/uploads" folder? Can I just FTP them there or should it be uploaded through the WP interface?

The URL with the issue is my site URL (http://systemaddict.org/). However because the site is live I have set it to the default permalink structure so it isn't displaying the problem right now. If you would like to see the problem I will switch it over at your request. My apologies for the delayed response, I thought I was subscribed to this thread, but am now and will respond immediately.
  #4  
Old Aug 4, 2014, 05:16 PM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I have a little time to look at it tonight if you flip it over.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Aug 4, 2014, 05:32 PM
Poorman
 
4 posts · Jul 2014
Thanks so much.

I have switched it over. So when you click on one of the categories (songs, mixes, etc.) you will see the background goes away that I defined in Overall Style & Config.>Body, Text & Links>Body Style

background: url(wp-content/ata-images/bgmain.jpg) repeat top left;

and also some of the widget text headers I created using this in the CSS (Calendar, Newsletter, etc.):

div#menu2 ul.rMenu {
background: url(wp-content/ata-images/2E2E2E-60.png) repeat top left;
border: transparent;
border-top: solid;
border-left: solid;
border-right: solid;
border-width:3px;
}

Thanks for your help.
  #6  
Old Aug 4, 2014, 06:40 PM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
you need to change
HTML Code:
background: url(wp-content/ata-images/bgmain.jpg) repeat top left;
to
HTML Code:
background: url(/wp-content/ata-images/bgmain.jpg) repeat top left;
note the '/' before wp-content'
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Aug 4, 2014, 07:50 PM
Poorman
 
4 posts · Jul 2014
Wow, a single-character solution, I love it.

Thanks for your help, I can't imagine how many hours I would have spent on this.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] If I change permalinks, widget images disappear amynking Sidebars & Widgets 2 Mar 2, 2010 11:30 AM
Cannot remove images from header folder. . . . Dankw Header configuration & styling 0 Jan 29, 2010 06:07 PM
.htaccess for permalinks HenryGomez Atahualpa 3 Wordpress theme 4 Feb 5, 2009 05:09 PM


All times are GMT -6. The time now is 09:31 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.