Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

How to use an image with hotspots as the logo


  #1  
Old Apr 15, 2014, 01:09 PM
rps
 
11 posts · Apr 2014
Toronto, Canada
We are a university department and the logo image has (1) our department name, and (2) the name of the university. I would like a click on (1) to go, as it does now, to our department home page; a click on (2) should go to the home page of the university.

I am familiar with creating image maps, but am at a loss as to how to incorporate the HTML data, since the 'Style & Edit HEADER AREA' (Atahualpa 3.4.9) simply asks for the name of the image file under 'Show Logo Image?'.

(Due to issues too boring to go into here, I am, unfortunately, not in a position to update the theme to the most recent version.)

Is there any way to include hotspot information for the logo image?
  #2  
Old Apr 15, 2014, 02:45 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
You could add a "New Widget Area(s)" in place of %logo and add whatever code you want to it/them. You could also just add the image map code in the same box where %logo is.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Apr 17, 2014, 08:43 AM
rps
 
11 posts · Apr 2014
Toronto, Canada
Thanks for this information. Unfortunately, I didn't know how to go about the first thing you suggest. With regard to the second, though, that works but... When I replace %logo in the box with the image map code, all is well with the image but the search box and RSS icon disappear. I see in the Atahualpa theme settings, that %logo = "The logo area, including the logo icon, the blog title & description, the search box and the RSS/Email icons".

So, it isn't surprising I can't see them any longer. Could you please advise me on how I can have my image map and the missing search box at the same time?

Thanks very much!

Last edited by rps; Apr 17, 2014 at 09:44 AM. Reason: Noticed a problem
  #4  
Old Apr 17, 2014, 11:29 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
leave %logo in the 'Configure Header Area' option but blank out the 'Show Logo Image?' option.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Apr 17, 2014, 12:17 PM
rps
 
11 posts · Apr 2014
Toronto, Canada
This has the desired effect, in that I can now see the search box. The downside is that there is white space where the logo would be if there were one - so I can have this space either above or below my hotspotted logo (depending on whether I insert the image map code before or after %logo) but not, it would seem, have my image occupy the space that the Logo Image would if there were one defined.

Is that correct, or am I missing something?
  #6  
Old Apr 17, 2014, 01:42 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
This is where you will probably need to use some CSS to hide what you don't want showing and position what you do want showing.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #7  
Old Apr 17, 2014, 01:46 PM
rps
 
11 posts · Apr 2014
Toronto, Canada
I figured that might well be the case, but thanks for the confirmation. You've been a great help, it's appreciated

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remove space between logo image and search bar in logo area SC801 Header configuration & styling 2 Oct 14, 2010 11:39 AM
[SOLVED] Header image not loading/fading & also overlaying logo image shilldiy Header configuration & styling 5 Jul 16, 2010 06:22 AM
If I Leave The Logo Image Field Blank, It Displays Broken Image Icon in Header psaltriparus Header configuration & styling 1 Oct 20, 2009 09:30 AM
[SOLVED] why insert image into image header in place to the blogtitle (like a logo) ? gilles Header configuration & styling 1 Sep 5, 2009 04:14 AM
replace "3 cubes" logo with custom logo image liontigerbear Header configuration & styling 3 May 13, 2009 02:07 PM


All times are GMT -6. The time now is 09:47 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.