Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

Images in Configure Header Area causes Bad Request


  #1  
Old Nov 19, 2013, 11:02 AM
MiaH
 
12 posts · Nov 2013
Running WP 3.7.1 and Atahualpa 3.7.12. Brand new install, no plugins yet.

The theme works like a charm, except for the “Style and Edit Head Area”. Whenever I add %image to Configure Header Area or a logo image, saving causes a Bad Request. The problem does not occur if I don’t add either and stick to bars and categories.

The problem occurs both while using the default image folders and when placing the images in a different directory. Image folders are set to 755, image files to 644.

The problem occurs on all my installed browsers, and also from work. I already tried to reinstall both WP and the theme.

Any inputs on a solution on this one?

/M.
  #2  
Old Nov 19, 2013, 11:49 AM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
First I've heard of the is, sounds like something server specific. So when you add %image to the 'Configure Header Area' option and then press save, you get an error…right?

any more info of the error
1 where do you see the message
2) is there anything in the error log?
3) try adding
HTML Code:
define('WP_DEBUG', true);
and see if anything shows.

What platform is the server running?
What version of PHP?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Nov 19, 2013, 01:10 PM
MiaH
 
12 posts · Nov 2013
Where should I add the debug?

Server is running:
Apache version 2.2.24
MySQL version 5.0.96-community
PHP version 5.3.23

When adding either %image or a logo image, then pressing the save button a blank page with the following text is displayed:

Bad Request

Your browser sent a request that this server could not understand.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

The error log says:
File does not exist: /home/goddesso/public_html/400.shtml, referer: http://www.goddessovdoom.com/wp-admi...hualpa-options
  #4  
Old Nov 19, 2013, 01:50 PM
MiaH
 
12 posts · Nov 2013
Nevermind about the debug - found it The problem remains the same.
  #5  
Old Nov 19, 2013, 02:56 PM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
All the versions seem fine. Can you check to see if you have 'magic quotes' turned on. you can find this out by editing atahualpa's index.php file (dashboard->appearances->editor) and adding as teh last line
HTML Code:
<?php phpinfo(); ?>
view the site and then take that line back out.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Nov 20, 2013, 01:02 AM
MiaH
 
12 posts · Nov 2013
magic_quotes_gpc is on.
magic_quotes_runtime and sybase are off.
  #7  
Old Nov 20, 2013, 05:17 AM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
try turning the magic quotes off
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Nov 20, 2013, 11:52 AM
MiaH
 
12 posts · Nov 2013
Added magic_quotes_gpc = off; to php5.ini. Magic quotes gpc turned off according to phpinfo, but still getting the error.

Deleted everything including the database, and made a new install with the php5.ini in the root folder of the WP-installation. No effect.

Got the following messages when installing Atahualpa 3.7.12 from the dashboard afterwards, with the debug turned on:

Notice: Undefined index: images_root in /home/goddesso/public_html/wp-content/themes/atahualpa/functions/bfa_get_options.php on line 316

Notice: Undefined index: ata_images_dir in /home/goddesso/public_html/wp-content/themes/atahualpa/functions/bfa_get_options.php on line 316

Notice: Undefined index: widget_center_top in /home/goddesso/public_html/wp-content/themes/atahualpa/functions/bfa_get_options.php on line 316

Notice: Undefined index: widget_center_bottom in /home/goddesso/public_html/wp-content/themes/atahualpa/functions/bfa_get_options.php on line 316

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-content/themes/atahualpa/functions/bfa_get_options.php:316) in /home/goddesso/public_html/wp-includes/pluggable.php on line 899
  #9  
Old Nov 20, 2013, 04:06 PM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Go to the new image option and press the 'save', the. Do the same for the center area option. That should get rid of the 'undefined index' messages

see if it fixes the issue

also have you edited any files in the theme or wordpress other than wp-config.php?
Did you add any blank lines to wp-config.php?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Nov 21, 2013 at 11:41 AM.
  #10  
Old Nov 21, 2013, 11:11 AM
MiaH
 
12 posts · Nov 2013
Undefined indexes gone.

I have only set the needed usernames and passwords for the DB and the authentication keys in the wp-config.php. No blank lines compared to the wp-config-sample.php.

Otherwise the installation is completely untouched, except for adding and removing the phpinfo to see if the magic quotes were turned off and uploading Atahualpa 3.7.12.
  #11  
Old Nov 21, 2013, 11:44 AM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
If you send me a PM with an admin ID/pw I'll poke a bit when I get a chance.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #12  
Old Nov 21, 2013, 01:55 PM
MiaH
 
12 posts · Nov 2013
I rolled back to Atahualpa 3.6, and the same error still occurs. Apparently it's not a problem with the theme. I never had this problem with earlier versions of neither WP nor Atahualpa.
  #13  
Old Nov 21, 2013, 02:07 PM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
you could try an install of an older version of WP - create a playsite and try that to see if it is the latest version of WP causing it.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #14  
Old Nov 21, 2013, 02:32 PM
MiaH
 
12 posts · Nov 2013
I just did, and what a bunch of fun it was! Running WP 3.6 with Atahulpa 3.6 displayed this message at the login screen.

Notice: wp_register_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/goddesso/public_html/wp-includes/functions.php on line 3012

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-login.php on line 384

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-login.php on line 396

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 695

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 696

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 697

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 698

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 699

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 700

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 703

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 704

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 705

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 706

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 709

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 710

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 711

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 712
  #15  
Old Nov 21, 2013, 06:09 PM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what happens if you swap to twenty twelve?
try atahualpa 3.7.1
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #16  
Old Nov 22, 2013, 08:41 AM
MiaH
 
12 posts · Nov 2013
When logging in, the only thing returned was this:

Notice: wp_register_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/goddesso/public_html/wp-includes/functions.php on line 3012

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-login.php on line 384

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-login.php on line 396

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 678

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 679

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 680

Warning: Cannot modify header information - headers already sent by (output started at /home/goddesso/public_html/wp-includes/functions.php:3012) in /home/goddesso/public_html/wp-includes/pluggable.php on line 875

Had to delete Atahualpa 3.6 via ftp to be able to log in. No problems with Twenty Twelve.
Updated to Atahualpa 3.7.1 with WP 3.6. Got the following notice on front page:

Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/goddesso/public_html/wp-includes/functions.php on line 3012

Update to Atahualpa 3.7.1 with WP 3.6 gives the same notices and warnings as 3.6. Still unable to log in. Update to WP 3.7.1 with Atahualpa 3.7.1 gives the original Bad Request.
  #17  
Old Nov 22, 2013, 01:46 PM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I don't know what more to offer. I don't see this problem, no one else has reported it and that leads me to suspect it is something unique about your environment. The only way I could do more is if I was to get into your system and play and that goes beyound free help.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #18  
Old Nov 22, 2013, 02:09 PM
MiaH
 
12 posts · Nov 2013
No worries Thanks for the help. I'll update if I figure it out.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Feature Request for Header Images kal New Versions, & Updating 0 Jun 9, 2010 06:01 AM
Configure header area for adsense debeerj Header configuration & styling 5 Jan 22, 2010 07:24 AM
Using is_front_page() in the ATO - Configure Header Area option? david y Header configuration & styling 19 Dec 22, 2009 12:26 PM
Configure Header Area not working for me... help! agrossman Header configuration & styling 3 Aug 23, 2009 07:15 AM


All times are GMT -6. The time now is 08:27 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.