Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

[SOLVED] Slideshow Cutting Off Images


  #1  
Old Sep 21, 2013, 09:52 AM
PainFreeComputing
 
20 posts · Dec 2009
I'm currently TRYING to use the NextGEN Gallery to insert a slideshow into a page. I'd post this issue on the NextGEN Gallery support forum, but they're obviously having serious problems over there. Nothing is getting answers, there are so many posts. So, here goes.

Like the Subject says, the Gallery is the NextGEN Gallery by Photocrati. However, I had similar issues with the Slideshow and the SliceShow plugins. So I'm thinking the problem may indeed be in Atahualpa (ouch!).

Problem: Images are cut of at the bottom, and the container even resizes for the truncated images. It's somewhat random, some display normally, others get truncated and the container resizes to fit. I can't detect a pattern. Same issue in multiple browsers.

What I did to troubleshoot:
  1. Tried other display options in NextGEN (different effects--fade, slide, etc.). Using the Flash slideshow is NOT an option for my site.
  2. Disabled ALL other plugins.
  3. Replaced NextGEN Gallery with Slideshow and then SliceShow--had similar issues.
  4. Re-activated NextGEN Gallery and ALL other plugins that I needed, but changed theme to Twenty-Thirteen theme, and the problem disappears completely.

I'm left to conclude that there's a conflict between Atahualpa and the NextGEN gallery (as well as some similar plugins).

Any help would surely be appreciated.

Thanks.
Jack

Last edited by PainFreeComputing; Sep 21, 2013 at 10:43 AM. Reason: Added email subscription.
  #2  
Old Sep 21, 2013, 11:48 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Version of atahualpa and wp?
What is the ulr of a page displaying the issue?
  #3  
Old Sep 21, 2013, 12:06 PM
PainFreeComputing
 
20 posts · Dec 2009
Quote:
Originally Posted by juggledad
Version of atahualpa and wp?
What is the ulr of a page displaying the issue?
Atahualpa 3.7.12
WP 3.6.1
http://test.culinarymgmnt.com/faulkner/cafesiena

Something is even keeping the page from rendering completely.

Jack

Last edited by PainFreeComputing; Sep 21, 2013 at 12:18 PM. Reason: Edited to add version info as requested.
  #4  
Old Sep 21, 2013, 12:39 PM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
everything looks fine to me. what isn't rendering?

btw this image gets a not-found
HTML Code:
http://test.culinarymgmnt.com/faulkner/wp-content/CMS-images/images/background.gif
  #5  
Old Sep 21, 2013, 12:51 PM
PainFreeComputing
 
20 posts · Dec 2009
Quote:
Originally Posted by juggledad
everything looks fine to me. what isn't rendering?
I guess I'll take a look from another computer. Thanks.
Quote:
Originally Posted by juggledad
btw this image gets a not-found
HTML Code:
http://test.culinarymgmnt.com/faulkner/wp-content/CMS-images/images/background.gif
Now I have a DIFFERENT issue, but I do see a pattern and it may be a consequence of the URL rewriting that I'm doing. Did you happen to browse any other pages? The /faulkner in the background image URL only appears on pages that have /faulkner in their URLs. All pages at the server root directory level have the correct background image. Pages that appear (due to URL rewriting) at a second-level (like /faulkner) have a broken URL for the background image, and I suspect other custom images.

I suspect I could work around this be changing the "/" characters in the URLs to something else, but I was hoping to use the URLs as they already are.

Is that clear as mud? Got any input for me?

Thanks.
Jack
  #6  
Old Sep 21, 2013, 01:06 PM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
You're right, clear as mud. Where are you doing the rewrite and why?
What happens if you don't do the rewrite?
  #7  
Old Sep 21, 2013, 01:17 PM
PainFreeComputing
 
20 posts · Dec 2009
Quote:
Originally Posted by juggledad
You're right, clear as mud. Where are you doing the rewrite and why?
What happens if you don't do the rewrite?
I'll try to give examples, rather than explain.

The folowing pages work properly--that is, the background image works fine:
http://test.culinarymgmnt.com
http://test.culinarymgmnt.com/about-us
http://test.culinarymgmnt.com/food-services
http://test.culinarymgmnt.com/faulkner

Their background image is at
http://test.culinarymgmnt.com/wp-con...background.gif

The following pages have a broken URL for their background image:
http://test.culinarymgmnt.com/faulkner/cafeteria
http://test.culinarymgmnt.com/faulkner/grille
http://test.culinarymgmnt.com/faulkner/cafesiena
http://test.culinarymgmnt.com/faulkner/coffeecup

Their background image URL is
http://test.culinarymgmnt.com/faulkn...background.gif (same as the others, but with /faulkner added).

By "rewrite", I'm just referring to how Wordpress gives the option for pretty URLs, search-friendly URLs, or whatever they call it. Oh, "Permalinks" is their term. It uses Apache's mod_rewrite to do this.

Why do I rewrite the URLs? I like it to appear that they're in a directory hierarchy, as they would in a non-Wordpress, static-page setup. That, and I'm anal OCD, I guess.

Jack

Last edited by PainFreeComputing; Sep 21, 2013 at 01:24 PM.
  #8  
Old Sep 21, 2013, 01:31 PM
PainFreeComputing
 
20 posts · Dec 2009
Quote:
Originally Posted by juggledad
What happens if you don't do the rewrite?
And to answer your last question, I just tested it. It works properly using WP's default permalink configuration.

So, in conclusion, using a / in a page's permalink will cause Wordpress to generate an incorrect background-image URL. I doubt this is a theme-specific issue, more likely global.

Jack
  #9  
Old Sep 21, 2013, 01:57 PM
PainFreeComputing
 
20 posts · Dec 2009
I'm not sure what I've done to break this, but now NONE of the pages have the correct background-image URL except the "main" page.

And, I did not add the /faulkner to the Permalinks. It's apparently done automatically because they're "child pages" of the /faulkner page.

Jack
  #10  
Old Sep 21, 2013, 02:05 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Use a full path for the background image instead of a relative path.
HTML Code:
http://test.culinarymgmnt.com/wp-content/CMS-images/images/background.gif
instead of
HTML Code:
/wp-content/CMS-images/images/background.gif
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #11  
Old Sep 21, 2013, 02:09 PM
PainFreeComputing
 
20 posts · Dec 2009
Quote:
Originally Posted by lmilesw
Use a full path for the background image instead of a relative path.
HTML Code:
http://test.culinarymgmnt.com/wp-content/CMS-images/images/background.gif
instead of
HTML Code:
/wp-content/CMS-images/images/background.gif
You lost me there.

The background image location is specified in the Atahualpa Theme Options | NEW Image Locations. It says "Base directory for images. No leading or trailing slashes. If the 'Relative location of header images?' is set to 'atahualpa' this option is ignored and the default Ataualpa folders will be used."

Jack
  #12  
Old Sep 21, 2013, 02:24 PM
PainFreeComputing
 
20 posts · Dec 2009
I may have a browser issue. The page source shows the background image in the same place on all pages now:
Code:
background-image:url(wp-content/CMS-images/images/background.gif)
But for some reason, the background is not showing in my browser. The odd thing is, the favicon and logo ARE showing up.

And when I look at the given URL for the background image:
http://test.culinarymgmnt.com/wp-con...background.gif
It's there.

I'll just check from another computer.

Jack
  #13  
Old Sep 21, 2013, 02:34 PM
PainFreeComputing
 
20 posts · Dec 2009
Just verified, same issue with Safari on the iPad.

It baffles me because when i view the page source, the background-image URL is CORRECT and it's the same one as on the site's home page, which DOES display.

Off to look at httpd logfiles, to see if it's throwing 404 errors...

Jack
  #14  
Old Sep 21, 2013, 02:53 PM
PainFreeComputing
 
20 posts · Dec 2009
The httpd logs tell all. Apache logged the following GET request when I went to http://test.culinarymgmnt.com/faulkner/

Code:
GET /faulkner/wp-content/CMS-images/images/background.gif
I don't recall this behavior on any of my other Atahualpa sites.

Jack
  #15  
Old Sep 21, 2013, 04:10 PM
PainFreeComputing
 
20 posts · Dec 2009
Okay, fixed. But I'd cal it a workaround. I went back to Atahualpa Theme Settings | Body, Text, and Links. Changed the background-image to a fully qualified URL as lmilesw suggested. That works, but in my opinion, it's a workaround for something that's inherently broken. It's something that won't be portable when I move this out of "test" and into "live" status.

Thanks for the help.

Jack
  #16  
Old Sep 21, 2013, 07:59 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I just noticed something else in your syntax which may preclude having the full path. There is a missing leading slash to your relative path.

You showed
HTML Code:
background-image:url(wp-content/CMS-images/images/background.gif)
It should be
HTML Code:
background-image:url(/wp-content/CMS-images/images/background.gif)
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #17  
Old Sep 21, 2013, 08:08 PM
PainFreeComputing
 
20 posts · Dec 2009
Quote:
Originally Posted by lmilesw
I just noticed something else in your syntax which may preclude having the full path. There is a missing leading slash to your relative path.

You showed
HTML Code:
background-image:url(wp-content/CMS-images/images/background.gif)
It should be
HTML Code:
background-image:url(/wp-content/CMS-images/images/background.gif)
Most definitely! When you first made the suggestion about using the full path, I didn't know what you were referring to. I thought the line of code you cited was generated by Atahualpa, based on Atahualpa Theme Options | NEW Image Locations.

But I'm fairly certain you're correct, and I'll go back and try that. Using relative paths has never been a problem on my other Atahualpa sites, so that must be it. Yep, just confirmed it.

Sometimes the simplest little mistakes are the hardest to identify. Thanks for the help.

Thanks.
Jack

Bookmarks

Tags
nggallery nextgen gallery

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Header Images Right Side overlapping prior, cutting off question dyoung50 Header configuration & styling 2 Feb 28, 2012 05:07 PM
[SOLVED] NextGEN Slideshow: Images don't show up in sequence jillin Plugins & Atahualpa 8 Nov 13, 2010 04:02 PM
Frontpage Slideshow not loading images in IE 7 or 8 lucy Plugins & Atahualpa 6 Sep 8, 2010 06:26 AM
rotating slideshow with linked images in header (vSlider won't work) viewdesigninc Header configuration & styling 1 Aug 8, 2009 05:53 AM
rotating slideshow with linked images, on the homepage viewdesigninc Plugins & Atahualpa 1 Aug 4, 2009 06:08 PM


All times are GMT -6. The time now is 07:10 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.