Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

[SOLVED] Widget background images do not show up


  #1  
Old Sep 15, 2013, 05:32 PM
DanDan
 
41 posts · Aug 2010
I want to have a rollover button in a widget. Using code that I have used before successfully I added the following to the css:

#tickets
{
display: block;
width: 180px;
height: 120px;
background: url(http://betsysbargains.com/wp-content...ox_tickets.jpg) no-repeat 0 0;

}

#tickets:hover
{
background-position: 0 -120px;
}

#tickets span
{
position: absolute;
top: -999em;
}

then added the following to a widget text box and uploaded the image:

<a id="tickets" href="/category/ticket-town/" title="tickets"><span>tickets</span></a>


The link shows up and works but the background image does not. Reading some of the other posts on this subject, I checked and magic_quotes are off on my server. Suspecting some other server problem, I copied the same code to another atahualpa site on the same server, changing nothing, and it works fine.

What else could be stopping it from working on one site when it works on another?

Thanks,

Dan

Last edited by juggledad; Sep 15, 2013 at 06:31 PM.
  #2  
Old Sep 15, 2013, 06:32 PM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
just put your code in and it works for me.
Do you have a caching plugin active?
what happens if you shut off all your plugins?
what is the url?
  #3  
Old Sep 15, 2013, 08:24 PM
DanDan
 
41 posts · Aug 2010
It muat have been a bad install. I just installed wordpress/atahualpa under a different domain name, put in the button code and it works fine. I will just change the domain name and move the graphics over to the new site. I am not that far along in the site build.

Thanks for looking at it for me,

Dan

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Images inside Widget only show on Home Page allyevans Sidebars & Widgets 2 Nov 6, 2010 05:32 PM
IE dont show images in header widget Tiux Header configuration & styling 1 Jul 27, 2009 10:39 AM
Need gallery widget to show images on a schedule, with links paulae Sidebars & Widgets 1 Jun 18, 2009 04:16 AM
[SOLVED] How to get a background image show thru background color juggledad Header configuration & styling 3 Apr 18, 2009 05:03 AM


All times are GMT -6. The time now is 10:17 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.