Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

[SOLVED] Widget Graphics not Linking on Home Page and Front Page


  #1  
Old Oct 24, 2012, 08:24 PM
tbaxter
 
92 posts · May 2012
Germantown, MD
Seems like a similar problem to http://forum.bytesforall.com/showthread.php?t=18344, but I'm not using any cache plugins...

Page: http://www.todddawsondesign.com/test/angus/
ATA 3.7.9
WP 3.4.2

The home page and the News page (which will have posts on it) don't show the graphics I've loaded into a text widget in the right hand column. Any ideas?

To get rid of the default widgets there, I just opened the sidebar on the Widgets page and deleted the ones there... THEN I read JD's instructions on how to do it right... would that have any effect?
  #2  
Old Oct 24, 2012, 08:54 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
What images do you have in the sidebar and how are they placed there?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Oct 24, 2012, 09:07 PM
tbaxter
 
92 posts · May 2012
Germantown, MD
Some social media icons, which I originally posted to to the Atahualpa Images folder via ftp, but then tried adding them through the Media Library. Neither one works.
  #4  
Old Oct 24, 2012, 11:15 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
You need to put the full path... Not just /wp-content...
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Oct 24, 2012, 11:54 PM
tbaxter
 
92 posts · May 2012
Germantown, MD
Any particular reason why relative links work on interior pages but not on "home" pages?
  #6  
Old Oct 25, 2012, 04:19 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
the path to an image can be thought as being made of three parts: The domain name, the directory and the filename.
http://yourdomain.com/wp-content/uploads/2012/10/ FaceBook_32x32.png

When using relative paths to an image, the key is how you start it.
If you start with ../ you are telling the browser to go up one directory level from the relative location you are currently at. The relative path is effected by your permalink structure

If you start with just / you are saying to the browser 'tack the domain name in front of this path' and that should work in all cases.

if you want to see this in action, set up a text widget with
HTML Code:
Full Path
<img src='http://www.todddawsondesign.com/test/angus/wp-content/uploads/2012/10/FaceBook_32x32.png'>
path with ../ before wp-content
<img src='../wp-content/uploads/2012/10/FaceBook_32x32.png'>
just / before wp-content
<img src='/wp-content/uploads/2012/10/FaceBook_32x32.png'>
nothing before wp-content
<img src='wp-content/uploads/2012/10/FaceBook_32x32.png'>
and go to
1) the home page
2) a single post page
3) a page page
then change the permalink structure - use a custom one and test again
then use a custom one and add '/x' somewhere in the path and test again
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Oct 25, 2012 at 06:39 AM.
  #7  
Old Oct 25, 2012, 06:40 AM
tbaxter
 
92 posts · May 2012
Germantown, MD
Thank you SO much JD! That gave me a much clearer understanding of what the symbology does and means, and after testing found only one worked in all cases (the full url).

I confess I didn't do the permalinks change, since I have no clue what that's about (and in reading some of the info on it detected conflicting info, so didn't want to try). Plus, not being a programmer, I have no clue what a /x would do or why, or where it should go, or anything.

But I really appreciate the walk through, and the testing. Very helpful.

Bookmarks

Tags
right sidebar, widgets

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Creating a static front page creates extra Home page jillin Atahualpa 3 Wordpress theme 3 Oct 21, 2010 05:24 AM
[SOLVED] Home Page Linking to Random page?? twomomsdesigns Page & Category Menu Bars 3 Jun 21, 2010 05:53 PM
Default Non-static Front Page (Home Page) Is Missing (Atahualpa Theme) SavvyBaker Center area post/pages 0 Jan 18, 2010 04:02 PM
[SOLVED] Home page versus Front page ldsmedia Atahualpa 3 Wordpress theme 7 May 29, 2009 03:30 PM


All times are GMT -6. The time now is 01:44 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.