Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages »

[SOLVED] Problem with table in IE/Firefox


  #1  
Old Oct 22, 2012, 05:42 AM
prooffairy
 
73 posts · Oct 2010
I've built a site which uses a table to position the content on the home page. On Chrome is looks absolutely fine but in IE (version 9) it disappears off the side of the page and in Firefox it overhangs the outside area.

Any help much appreciated!

The site is www.djlansdowneplumbing.co.uk
  #2  
Old Oct 22, 2012, 06:20 AM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
why are you using multiple <tbody> statements in one table?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Oct 22, 2012, 06:58 AM
lmilesw's Avatar
lmilesw
 
10,176 posts · Jul 2009
Central New York State USA
Your images are pushing the table cells wider if you use the following CSS it will constrain the images in the table to 100% of the width of the 33% width cell.
HTML Code:
#table1 img {
    width: 100%;
}
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #4  
Old Oct 22, 2012, 07:28 AM
prooffairy
 
73 posts · Oct 2010
Thanks.

Didn;'t realise I had multiple tbody tags, I copied part of the table as I had to add an extra row so think that's where they crept in. Think I've deleted the extra ones now.

Added the CSS and it looks good in Firefox now but is still not displaying properly in IE
  #5  
Old Oct 22, 2012, 07:40 AM
lmilesw's Avatar
lmilesw
 
10,176 posts · Jul 2009
Central New York State USA
I would just size my images to the width needed.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old Oct 22, 2012, 07:48 AM
prooffairy
 
73 posts · Oct 2010
I have sized my images to the width needed - each is 150px wide - but obviously that's still not working in IE!
  #7  
Old Oct 22, 2012, 10:30 AM
lmilesw's Avatar
lmilesw
 
10,176 posts · Jul 2009
Central New York State USA
Look OK to me in IE.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #8  
Old Oct 22, 2012, 10:31 AM
prooffairy
 
73 posts · Oct 2010
Yeah I just this minute fixed it - I forced it to render in IE8 and for some reason that seems to have done the trick!
  #9  
Old Oct 22, 2012, 10:36 AM
lmilesw's Avatar
lmilesw
 
10,176 posts · Jul 2009
Central New York State USA
Tables can be an "interesting" issue. I generally prefer floated divs for just that reason.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #10  
Old Oct 22, 2012, 10:40 AM
prooffairy
 
73 posts · Oct 2010
I'm not a programmer and don't really get divs, hence using tables as I know (more or less) what I'm doing there!

Bookmarks

Tags
table

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with table Octavio Salles Center area post/pages 1 Nov 18, 2010 06:28 AM
[SOLVED] Table works fine in all browsers except Firefox. Please help! Nolie Center area post/pages 1 Nov 15, 2010 11:23 AM
[SOLVED] CSS Problem with float in Firefox only bplazar Atahualpa 3 Wordpress theme 6 Feb 2, 2010 03:15 PM
[SOLVED] Problem with table styling Edu_Sanzio Atahualpa 3 Wordpress theme 3 Jul 9, 2009 05:22 AM


All times are GMT -6. The time now is 04:31 PM.


Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.