Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Montezuma Theme »

[SOLVED] remove automatic gallery slideshow


  #1  
Old Oct 19, 2012, 04:51 AM
baignoire
 
10 posts · Oct 2012
hi there,
grats and thx for the very promising theme !! I am currently testing it and quite like it !!
a small question : how can i remove the automatic slideshow on wp standard post galleries ???
i use another feature to show the galleries so i wish i could get rid of it...
possible ? easy ? thx to let me know
cheers
raf

Last edited by baignoire; Oct 19, 2012 at 05:12 AM.
  #2  
Old Oct 19, 2012, 05:39 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Quote:
how can i remove the automatic slideshow on wp standard post galleries ???
I'm not sure what you mean. Any post I have with a galery of images just shows the images.

did you try disabling all your plugins to see if any of them are causing an issue?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Oct 19, 2012, 05:56 AM
baignoire
 
10 posts · Oct 2012
hi again,
thx for caring
i mean this :
Auto gallery slideshow
Galleries created with the standard WordPress “gallery” shortcode will get a “colorbox” slideshow applied to it automatically. In the HTML source code the gallery thumbs keep linking to the full attachment pages with the big image embedded, so that search engines can spider those (SEO Feature) while users get the quick, convenient slideshow (which can be stopped). TODO: Provide an extra link for users to get to the attachment pages as well, e.g. for leaving comments on individual images.
source : http://wordpress.bytesforall.com/wor...mes/montezuma/

Publish a standard gallery inside a post and you ll see the slideshow (well, at least i see it : http://rafonthenet.net/lfa/un-article-pour-voir/ (no plugin installed!))

thx
raf
  #4  
Old Oct 19, 2012, 08:36 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What plugin are you using. When I activate 'Lightbox Gallery' it takes over from the in theme slideshow.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Oct 19, 2012, 08:43 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Being able to configure this in the theme options may be something that will be added. For now if you don't want the auto slideshow...
  • Open get_javascript.php via Appearance>Editor
  • Search for slideshow and replace true with false
  • Go to the Montezuma theme options and open any of the main or sub templates for editing
  • Without making any changes click on the "Save Changes" button at the bottom. This is just so the changes made to the get_javascript.php file get "registered" with Montezuma.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old Oct 19, 2012, 08:44 AM
baignoire
 
10 posts · Oct 2012
hi there
i am used to using and enjoying "easy fancybox" : when activated, the two lightboxes (theme automatic + easy fancybox one) appear one above the other...
i ll give a try with "lightbox gallery" as you suggested and see if i like it
thanks for help.

edit : i just gave a try with "lightbox gallery" : it uses the same 'colorbox' box as the native theme gallery... my problem with it is that it doesn't fit large images to the available screen size...
i ll try to figure out a workaround for this..

thanks for fast help !!

raf

Last edited by baignoire; Oct 19, 2012 at 08:47 AM.
  #7  
Old Oct 19, 2012, 09:03 AM
baignoire
 
10 posts · Oct 2012
Quote:
Originally Posted by lmilesw
Being able to configure this in the theme options may be something that will be added. For now if you don't want the auto slideshow...
  • Open get_javascript.php via Appearance>Editor
  • Search for slideshow and replace true with false
  • Go to the Montezuma theme options and open any of the main or sub templates for editing
  • Without making any changes click on the "Save Changes" button at the bottom. This is just so the changes made to the get_javascript.php file get "registered" with Montezuma.
hi
very strange !!
if i deactivate "easy fancybox" plugin then follow the above steps, then the colorbox is deactivated and images file open as expected, without any gallery effect...
but if then i activate "easy fancybox" and reload page, the native 'colorbox' shows up again !! i need to deactivate plugin and re-save get_javascript.php + any template in montezuma otpions for 'colorbox' to stop working...
i am not sure why, but it looks like having a js gallery script active (via plugin) overwrites the setting in get_javascript.php (???)
i m a bit confused..
cheers
raf
  #8  
Old Oct 19, 2012, 09:11 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I just tested easy fancybox with a [gallery] in twenty-eleven and no silde show show up. If you add a single image or multiple seperate images, then the slide show shows up. This seems to be a bug with easy fancybox. You might want to try it yourself and then report it to the plugin author.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Oct 19, 2012, 09:31 AM
baignoire
 
10 posts · Oct 2012
Quote:
Originally Posted by juggledad
I just tested easy fancybox with a [gallery] in twenty-eleven and no silde show show up. If you add a single image or multiple seperate images, then the slide show shows up. This seems to be a bug with easy fancybox. You might want to try it yourself and then report it to the plugin author.
thanks juggledad for testing and reporting
hmm, i'm having it working fine on multiple sites and themes, also i ve checked now it is runing fine on test site with twenty ten / eleven / twelve...
did you made sure you have a gallery that links to image files ( [gallery link="file"] shortcode ) ?
  #10  
Old Oct 19, 2012, 09:44 AM
baignoire
 
10 posts · Oct 2012
hi again

finally managed to get it to work : i followed the steps given by imilesw but instead of just turniing 'true' to false', i commented out the whole js 'if' statement :
Code:
/*
if( jQuery().colorbox ) {
	$('.gallery figure a span').colorbox({rel: 'gal', slideshow: false, slideshowSpeed: 3500, opacity: 0.7, href: function(){
		 var src = $(this).prev('img').attr('src').replace( /-\d+x\d+./, '.' ); // full src = remove '-150x150' from thumb src
		 return src;
	}});
}
*/
didn't check if it throws me tons of js errors but the 'colorbox' seems to be disabled

thanks for help guys !!

regards,
raf
  #11  
Old Oct 19, 2012, 09:59 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
No I just used [gallery] and that does not work with 'easy fancybox'. changing it to [gallery link='file'] and it does work and I see the issue, but I still think this is 'easy fancybox' issue.

but since you have solution I will mark this as solved.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Tags
remove slideshow

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gallery plugin with slideshow/thumbnail navigation instead of lightbox bswb97 Plugins & Atahualpa 3 May 10, 2012 03:29 AM
Centering a gallery or slideshow with NextGen yukoner Center area post/pages 2 Mar 29, 2012 07:18 AM
[SOLVED] Help - slideshow gallery pro on atahualpa leonn Atahualpa 3 Wordpress theme 9 Nov 8, 2011 05:17 AM
[SOLVED] How to remove automatic Chitika ads in posts ? Arom Center area post/pages 2 Jan 18, 2011 12:09 PM


All times are GMT -6. The time now is 04:37 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.