Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Montezuma Theme »

[SOLVED] A few problems I've been having...


  #1  
Old Sep 27, 2012, 12:27 AM
danielmckay
 
17 posts · Sep 2012
Your theme doesn’t say who the author was on any posts. We are a multi-author blog and this is pretty important. Is there code I can change to add the author to the post?

When I follow the instructions to change icons (menu1, menu2) by changing the second number (px). I put that in the css code on montezuma options at the bottom, and i don't see any change after pressing save. I've also tried putting .page-(whatever) instead and it still didn't work. here is an example of the code
Can someone walk me through this? I have pages that I want to change the stars.

I have this:
/* Part 1- for default state: */
#menu1 .page-about > a > i { background-position: 0px -2352px; }
#menu1 .page-blogging > a > i { background-position: 0px -1104px; }
#menu1 .page-business-ideas > a > i { background-position: 0px -1344px; }
#menu1 .page-economics > a > i { background-position: 0px -888px; }
#menu1 .page-politics > a > i { background-position: 0px -1464px; }
/* Part 2 - for hover state: */
#menu1 .page-about:hover > a > i, #menu1 .page-about.active > a > i { background-position: -24px -2352px; }
#menu1 .page-blogging:hover > a > i, #menu1 .page-blogging.active > a > i { background-position: -24px -1104px; }
#menu1 .page-business-ideas:hover > a > i, #menu1 .page-business-ideas.active > a > i { background-position: -24px -1344px; }
#menu1 .page-economics:hover > a > i, #menu1 .page-economics.active > a > i { background-position: -24px -888px; }
#menu1 .page-politics:hover > a > i, #menu1 .page-politics.active > a > i { background-position: -24px -1464px; }

Does it also matter, it appears there are some defaults that I dont have (such as contact us etc.) further up on menu1

Also, is there a way to change the width of the columns? I would like the middle column (where the posts are) to be wider, thus leaving a little less white space on either side.

Thank you kindly for your support.

Last edited by danielmckay; Sep 27, 2012 at 12:40 AM. Reason: added code example
  #2  
Old Sep 27, 2012, 04:51 AM
juggledad's Avatar
juggledad
 
23,597 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What is the URL?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Sep 27, 2012, 10:01 PM
danielmckay
 
17 posts · Sep 2012
http://ideafart.com

thank you!
  #4  
Old Sep 27, 2012, 10:22 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Take a look in the PHP Limited Code drop down at the top of the theme options page. There is code in there for the author and suggestions on where to place it. In the CSS Settings>Choose CSS Grid there are instructions on setting column widths.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Sep 27, 2012, 11:51 PM
danielmckay
 
17 posts · Sep 2012
Thanks! I have got the author changed.

Still working on the page icons and the width. I can't figure out the column width for the life of me. The instructions don't tell you where to put the code - I've searched. I found the grid files using FTP but don't think i'm supposed to edit those. I cannot find where to put this code or edit, searching for "row" doesn't lead to anything meaningful on the css files.

Last edited by danielmckay; Sep 28, 2012 at 01:53 AM.
  #6  
Old Sep 28, 2012, 06:12 AM
juggledad's Avatar
juggledad
 
23,597 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
column width depends on the css you apply to the element. Read teh doc at MTZ->CSS Settings->Editing CSS and ifthat isn't clear enough - do a google search on responsive themes and read about them - it is a different way of thinking when building your layout

here is a small example, remember the site is broken into 12 columns. if you want a 3 column left sidebar, a 7 column center area and a 2 column right sidebar, you would use
HTML Code:
<div class="row">
  <div class="col3">...column on the left, 3 "units" wide...</div>
  <div class="col7">...column in the middle, 7 "units" wide...</div>
  <div class="col2">...column on the right, 2 "units" wide...</div>
</div>
(remember it has to add to 12) if you wanted 1 column, 4 column, 2 column 5 column you would use
HTML Code:
<div class="row">
  <div class="col1">...column on the left, 1 "units" wide...</div>
  <div class="col4">...column in the middle, 4 "units" wide...</div>
  <div class="col2">...column on the right, 2 "units" wide...</div>
  <div class="col5">...column on the right, 5 "units" wide...</div>
</div>
hope that helps
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Sep 28, 2012, 03:52 PM
danielmckay
 
17 posts · Sep 2012
thank you, I will look into it!

Do you have suggestions for the pages icons. I have read the css instructions, appended the edited code into the css menu1 file and pressed save.. the icons do not change. i have the code I used above. I have also tried putting .page-(pagename) and that did not solve the problem.
  #8  
Old Sep 28, 2012, 11:15 PM
danielmckay
 
17 posts · Sep 2012
I've tried the other solutions proposed here and nothing is working - I check the source code and menu1 still shows the old menu without my pasted code...

Here is what I do:

Create menu = link it to menu 1 and add my pages

Go to the CSS setting and replace the 2nd px numbers.

Go to CSS menus_menu1 and paste this code:
#menu1 .cat-blogging > a > i { background-position: 0px -1104px; }
#menu1 .page-entrepreneurship > a > i { background-position: 0px -1344px; }
#menu1 .page-politics > a > i { background-position: 0px -1464px; }
#menu1 .page-economics > a > i { background-position: 0px -888px; }
#menu1 .page-about > a > i { background-position: 0px -2352px; }

#menu1 .cat-blogging:hover > a > i, #menu1 .cat-blogging.active > a > i { background-position: -24px -1104px; }
#menu1 .page-entrepreneurship:hover > a > i, #menu1 .page-entrepreneurship.active > a > i { background-position: -24px -1344px; }
#menu1 .page-politics:hover > a > i, #menu1 .page-politics.active > a > i { background-position: -24px -1464px; }
#menu1 .page-economics:hover > a > i, #menu1 .page-economics.active > a > i { background-position: -24px -888px; }
#menu1 .page-about:hover > a > i, #menu1 .page-about.active > a > i { background-position: -24px -2352px; }

press save.. clear cache refresh page... nothing... view source nothing changed.
  #9  
Old Sep 28, 2012, 11:22 PM
danielmckay
 
17 posts · Sep 2012
also tried changing from page to cat and vice-a-versa.. no change.. the source page doesnt update.
  #10  
Old Sep 29, 2012, 05:34 AM
juggledad's Avatar
juggledad
 
23,597 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
change
{ background-position: -24px -1104px; }
to
{ background-position: 0 -1104px; }
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #11  
Old Sep 29, 2012, 03:26 PM
danielmckay
 
17 posts · Sep 2012
I changed all of them.. appears nothing happened. The source code still doesn't show an updated menu1
  #12  
Old Sep 29, 2012, 04:06 PM
danielmckay
 
17 posts · Sep 2012
I guess I have ran into a bigger problem ---

Some users are complaining that the images on the home page cover text and tabs.

The problem doesn't carry over to the post page.

I have attached a screenshot

how would I go about fixing this?
Attached Thumbnails
Click image for larger version

Name:	Screen shot 2012-09-29 at 2.05.11 PM.png
Views:	272
Size:	59.6 KB
ID:	2017  
  #13  
Old Sep 29, 2012, 07:52 PM
juggledad's Avatar
juggledad
 
23,597 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
first, you should always turn off caching plugins when you are making changes if you wish to see the changes right away.

see what happens if you shut off the caching plugin.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #14  
Old Sep 29, 2012, 08:09 PM
danielmckay
 
17 posts · Sep 2012
I figured it out (I had to backup - then copy into the css file directly from file manager)

What about the image over text?
  #15  
Old Oct 8, 2012, 06:34 AM
juggledad's Avatar
juggledad
 
23,597 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
see PATCH 113-01: featured images behave 'strangely' may cover text, not show till hover
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #16  
Old Oct 10, 2012, 05:57 PM
danielmckay
 
17 posts · Sep 2012
That did it, solved.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
CSS Problems al805 Atahualpa 3 Wordpress theme 6 Apr 1, 2011 08:58 PM
3.6.1 problems Sangennaru New Versions, & Updating 5 Feb 4, 2011 10:29 AM


All times are GMT -6. The time now is 11:35 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.