Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Languages & Translations »

[SOLVED] Getting WPML's language option to display on the blog page


  #1  
Old Sep 24, 2012, 02:40 PM
griffinjay
 
16 posts · May 2009
We're able to get the WPML plugin to display the "This post is also available in: Spanish" option to display at the top of individual blog posts but we'd like to have that be visible at the top of each post that's been translated when viewing the entire blog: http://peacewinds.org/blog

The Atahualpa theme is listed as one of those "tested by WPML team" on their Theme Compatibility page: http://wpml.org/documentation/theme-compatibility/

I've been getting help from Harshad, a support staffer at WPML via this discussion thread:
http://wpml.org/forums/topic/getting...the-blog-page/

I've given him admin and FTP access but thus far, no success. I've assumed that the code needs to be added to the index.php file but it breaks the site when I do. And now his last comment confuses me (I'm not much of a techie):

Quote:
Can you please contact the theme developers, and get the exact filename to edit, so we can put the code into the same file. Or is it another way to add the php code via theme options?
I don't know what to tell him so I thought I'd try here.
  #2  
Old Sep 24, 2012, 04:59 PM
juggledad's Avatar
juggledad
 
23,551 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
try editing index.php and add
HTML Code:
	<? if function_exists('icl_post_languages') {
	      icl_post_languages($post->ID);} ?>
after line 16 which is
HTML Code:
	<?php while (have_posts()) : the_post(); $bfa_ata_postcount++; ?>
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Sep 25, 2012, 08:24 AM
griffinjay
 
16 posts · May 2009
Thanks, J.

I had tried something similar but the problem was the blog page had to be 'translated' even though the blog page is blank/empty.

Problem solved.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Somehow the option &quot;NO&quot; for the BLOG TITLE and the BLOG TAGLINE don't work justbridge Header configuration & styling 11 Feb 22, 2011 06:09 AM
Page Option "Do Not Display Body Title" Not Working amyuhrich Center area post/pages 8 Jan 18, 2011 06:40 PM
[SOLVED] Can't make my blog theme in my language. trollinski Installing & running WordPress 1 Oct 22, 2009 06:29 PM


All times are GMT -6. The time now is 01:06 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.