Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

With iPhone/iPad, my website links work only ONCE, then loop to 'newest entry'


  #1  
Old Sep 7, 2012, 02:02 PM
misterfreedom
 
5 posts · Sep 2012
Hello from an unsavvy user (i have no knowledge of php/html)

Navigation of my website is perfectly fine with PC/Mac desktop/laptops, but when viewed with iPhone/iPad all links only redirect to the proper page when clicked the FIRST time. All subsequent clicked links loop back to the latest post (For instance when clicking "older entries" for the second time, it loops back to home page.)
Details:
* My website is www.misterfreedom.com
* WP 3.4.1 with Atahualpa 3.7.8 (customized by a 3rd party who admits not understanding the problem)
* I have tried with and without iPhone compatibility plug-in (all mobile related plugins are disabled and deleted now.)
* My hosting service (register.com) says I have no record for "m." redirecting in my DNS, but have a catchall in my A record (therefore the redirect to m.misterfreedom.com with iPhone viewing)
* I am not sure when this started happening, nor could i find the same issue documented in this forum.
* Currently installed/activated plugins are: Add Meta Tags/April's Super Function Pack/Column Matic/Contact From7/Custom Meta/Google Analyticator/Google Analytics for WP/InstantUpgrade/NextGEN Gallery/Page Links to/Really Simple CAPTCHA/the Social Links/WP Data backup/WP Facebook like plugin/WP-Highslide/WP MulticolLinks/WP re-CAPTCHA

Any experience with this issue? Thank you so much for your time and thoughts.
  #2  
Old Sep 7, 2012, 03:51 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I would try getting rid of the catch all. You don't need a mobile redirection for the iPad. None of my sites do and the all work fine.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Sep 7, 2012, 04:57 PM
misterfreedom
 
5 posts · Sep 2012
Thank you for your fast reply.
From my cPanel, it doesn't seem i have the 'wild card redirect' option on (see attached jpeg). I have asked register.com if there is another way to tweek the A records.
Thank you again for your help
Attached Thumbnails
Click image for larger version

Name:	Website redirect.jpg
Views:	413
Size:	83.0 KB
ID:	1991  
  #4  
Old Sep 7, 2012, 05:34 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Quote:
WP 3.4.1 with Atahualpa 3.7.8 (customized by a 3rd party who admits not understanding the problem)
what did this 3rd party 'customize'?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Sep 7, 2012, 05:42 PM
misterfreedom
 
5 posts · Sep 2012
He put the site together and edited the templates via editor for colors/layout etc, will ask him if that can be explained.

Also, I found out how to get rid of the wildcard from the cPanel, but there is no more access to the website from iPhone now... Will try to go back and remember how to revert to previous A Records.
  #6  
Old Sep 7, 2012, 06:57 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Quote:
He put the site together and edited the templates via editor for colors/layout etc, will ask him if that can be explained
he shouldn't have had to edit any templates, it's all done in the theme options. Any extra CSS can be added in the 'Add HTML/CSS Inserts' option
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Sep 10, 2012, 02:35 PM
misterfreedom
 
5 posts · Sep 2012
Hello,
the web designer did not 'edit templates' (excuse my previous erroneous wording) but indeed edited the CSS.
In my A records, i do not have a * redirect anymore. When i tried to also remove the m. redirect (see photo) it rendered the access to my site from an iPhone impossible.
Attached Thumbnails
Click image for larger version

Name:	cPanel A records.jpg
Views:	401
Size:	93.8 KB
ID:	1992  
  #8  
Old Sep 10, 2012, 02:49 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
not sure what to suggest. i use my ipad to access many wordpress sites and don't have a problem. You also might look at the .htaccess file to see if it is doing anything

if you swap to twenty-eleven does the same thing happen?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Sep 10, 2012, 03:31 PM
misterfreedom
 
5 posts · Sep 2012
In the public_html folder, the .htaccess file is empty. There is however a .htaccess_old file that contains this (i replaced with ****** myself here):
\# -FrontPage-

Options None

<Limit GET POST>
order deny,allow
deny from all
allow from all
require group authors administrators
</Limit>
<Limit PUT DELETE>
order deny,allow
deny from all
</Limit>
AuthType Basic
AuthName misterfreedom.com
AuthUserFile /home/********/public_html/_vti_pvt/service.pwd
AuthGroupFile /home/********/public_html/_vti_pvt/service.grp

I will ask the web designer to revert to 20-11, since i do not want to take the chance to ruin it all.
Thank you!

Bookmarks

Tags
iphone, links, mobile view, previous entry, redirect to home page

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Wordpress app for iPhone/iPad paulae Installing & running WordPress 5 Mar 9, 2011 12:58 AM
[SOLVED] How to make Post Gallery Widget work in new Center Column Above The Loop Wid New WordPress Fan Forum How-To 5 Jan 18, 2011 01:02 AM
[SOLVED] Links to video on the loop page Igor Forum How-To 2 Dec 3, 2009 08:20 PM
Mobile and iPhone themes? paulae Plugins & Atahualpa 9 Oct 21, 2009 01:29 PM
[SOLVED] Comment forms not showing on iPhone joshj Page & Category Menu Bars 5 Sep 14, 2009 02:14 PM


All times are GMT -6. The time now is 01:02 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.