Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

Problems with Webfonts


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Sep 7, 2012, 07:32 AM
riw777
 
27 posts · Jun 2009
Y'all:

I've tried following the instructions in various threads to no avail... So, I'm giving up and asking for help with this one.

1. I've uploaded all my typeface files to a single directory, http://www.thinkinginchrist.com/webfonts

For instance, http://www.thinkinginchrist.com/webfonts/23F205_8_0.ttf

2. I've added the following to my css inserts in Atahualpa:

@font-face {font-family: 'ProximaNova-Regular';
src: url('http://www.thinkinginchrist.com/webfonts/23F205_8_0.eot');
src: url('http://www.thinkinginchrist.com/webfonts/23F205_8_0.eot?#iefix') format('embedded-opentype'),
url('http://www.thinkinginchrist.com/webfonts/23F205_8_0.woff') format('woff'),
url('http://www.thinkinginchrist.com/webfonts/23F205_8_0.ttf') format('truetype');}

There are three more definitions in there for the other formats of this face, but it's easiest just to concentrate on one for the moment.

Which was generated by myfonts.com.

3. I also added:

body {font-family: "ProximaNova-Regular";}
p {font-family: "ProximaNova-Regular";}

to my css inserts, and:

font-family: 'ProximaNova-Regular';

to "Body Style" under "Body, Text, and Links," in the theme options.

But the font still doesn't show up on my wordpress page... Another question --there is italics, bold, etc., there, as well --will those pick up automatically, or is there some other css I must insert to get all the styles working?
  #2  
Old Sep 7, 2012, 10:45 AM
lmilesw's Avatar
lmilesw
 
9,967 posts · Jul 2009
Central New York State USA
I would just put the font-family code in the Body, Text, and Links box as well as any of the page options in Style and edit Pages.

The font appears to be working when I test with Firebug.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Dec 22, 2012, 09:18 AM
riw777
 
27 posts · Jun 2009
Okay, thanks... Maybe it's just that I can't see the font on my machine for some reason --this has happened to me before, for some reason. *sigh*

Thanks for your help.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
CSS Problems al805 Atahualpa 3 Wordpress theme 6 Apr 1, 2011 07:58 PM
3.6.1 problems Sangennaru New Versions, & Updating 5 Feb 4, 2011 09:29 AM


All times are GMT -6. The time now is 08:01 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.