Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

A plugin issue using IE...


  #1  
Old Feb 21, 2012, 11:11 AM
ARealpolitik's Avatar
ARealpolitik
 
130 posts · Jun 2010
I know you guys do not like IE and neither do I. The plugin Infinite Scroll works great in all browsers except IE. Actually it was working as well in IE till recently then decided to quit...

Gives me the error on page below:
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET4.0C; .NET CLR 1.1.4322)
Timestamp: Tue, 21 Feb 2012 18:08:18 UTC

Message: Syntax error, unrecognized expression: link
Line: 1
Char: 47062
Code: 0
URI: theblogfarm.com/wp-includes/js/jquery/jquery.js?ver=1.7.1
I took out the http:// above so it would not appear as a link.

I realize you guys do not necessarily support plugins and the problems they cause, but I was wondering if you could shine some light on what exactly this means, why it only shows in IE (go figure) and possibly a fix.

Appreciate any suggestions... other than don't use IE.

Last edited by ARealpolitik; Feb 21, 2012 at 11:13 AM.
  #2  
Old Feb 21, 2012, 11:34 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
This is a recurrence of an issue from last year... what changed?
Are you saying it was working and all of a sudden stopped and you had done nothing such as install or update a plugin. Are you using v2.0b2.120111 of the infinite-scroll plugin?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Feb 21, 2012, 11:49 AM
ARealpolitik's Avatar
ARealpolitik
 
130 posts · Jun 2010
Yep, I am using that version, and yep I might have added another plugin temporarily. I use certain plugins like broken link checker, fix stuff, then remove the plugin. Probably a bad practice. I wish the plugin section would contain a tracking date for when it was added. It stopped working on both sites and the one site, the tree, has not had plugins added.

For some reason, gut feeling, I think it stopped working when I installed an update to an existing plugin to both sites.

So when the error says, 'unrecognized expression: link' does this mean the version has changed, been written incorrectly, updated js to an unrecognizable version for use with that specific plugin, or possibly any or all of those?

Can I fix it by removing or editing that link?
  #4  
Old Feb 21, 2012, 12:19 PM
ARealpolitik's Avatar
ARealpolitik
 
130 posts · Jun 2010
I hope that is you in there... Can change you to admin if you would like to dig deeper?

Last edited by ARealpolitik; Feb 21, 2012 at 12:29 PM.
  #5  
Old Feb 21, 2012, 05:04 PM
ARealpolitik's Avatar
ARealpolitik
 
130 posts · Jun 2010
So, any idea or ideas as to what I could do? Can I fix it by removing or editing that link? Error said unrecognizable... exactly what does that mean?
  #6  
Old Feb 21, 2012, 05:41 PM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Interesting, on my MAC in Safari, I get the infinite scroll, but on my PC in IE8 I get no error just the nav bar at the bottom with the 'Older Entries >>'
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Feb 22, 2012, 08:11 AM
ARealpolitik's Avatar
ARealpolitik
 
130 posts · Jun 2010
Hmmm, I get the error so I automatically assumed that the error was related to the scroll not working. Now I wonder... Nice to know the scroll works on a Mac, tks JD.

I tried the site using IE9 on a friends computer and it didn't work, what a pain...
  #8  
Old Feb 22, 2012, 08:52 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Have you tried temporarily deactivating all the other plugins as a test?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #9  
Old Feb 22, 2012, 06:46 PM
ARealpolitik's Avatar
ARealpolitik
 
130 posts · Jun 2010
Hard to do since this is not on a test bed and have many users in at any given time. Do you think this is a js version problem? I am currently using 1.7.1 which is the newest I think. Could Infinite Scroll use an older version where an upgrade to another plugin created the problem. But then it works on everything except the dreaded IE...
  #10  
Old Feb 22, 2012, 06:54 PM
ARealpolitik's Avatar
ARealpolitik
 
130 posts · Jun 2010
I just did some research and found that certain mouseover functions in IE8 break the 1.7.1 js, there are work arounds but I do not know enough about this stuff to start messing with that. I am wondering, if all the code I have placed in html/css inserts to build my menus might be breaking the js in IE... wow, this stuff hurts my head.
  #11  
Old Feb 23, 2012, 07:00 AM
ARealpolitik's Avatar
ARealpolitik
 
130 posts · Jun 2010
Hey Larry, I did go into the Tree and deactivated all plugins but infinite scroll. Still did not work... When it did work I did not get the 'error on page' message. Do you think it is not working due to an update to the 1.7.1 js?
  #12  
Old Feb 23, 2012, 07:09 AM
ARealpolitik's Avatar
ARealpolitik
 
130 posts · Jun 2010
I am sure this is a foolish question but... can I just remove that line of code? lol

URI: theblogfarm.com/wp-includes/js/jquery/jquery.js?ver=1.7.1

..or will it affect everything else.
  #13  
Old Feb 23, 2012, 07:30 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Quote:
I am sure this is a foolish question but... can I just remove that line of code? lol

URI: theblogfarm.com/wp-includes/js/jquery/jquery.js?ver=1.7.1

..or will it affect everything else.
well...since it is part of the wordpress code (note the folder it is coming from) I would expect that it would cause some serious issues...
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unusual plugin/login issue jasonchamb Plugins & Atahualpa 7 Nov 8, 2009 01:19 PM
[SOLVED] Excerpts and Wordpress Video Plugin Issue paulbuijs Excerpts, Read more, Pagination 1 Oct 23, 2009 10:36 AM
[SOLVED] Can't edit posts - edits vanish - Virus? Theme Issue? WP Issue? jfrenaye Atahualpa 3 Wordpress theme 1 Aug 4, 2009 07:14 AM
sliding panel plugin and ie css issue bushtool Header configuration & styling 2 Jul 6, 2009 09:52 AM


All times are GMT -6. The time now is 01:38 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.