Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » Forum Usage » Forum How-To »

[SOLVED] Help with Facebook Share button after post


  #1  
Old Feb 17, 2012, 07:07 AM
GiveMeDap
 
6 posts · Feb 2012
Hi,

I've searched around but can't find exactly the same issue I'm having or maybe I'm misunderstanding (i'm new to all this, sorry). I currently have the Share and Follow plugin to include a share button after each post for Facebook, Twitter, and Email. The Twitter share button works fine but the Facebook button is where I'm having problems.
When someone clicks on the Facebook share button it shares the link to the sites home url and not the individual post. How can I fix this. I'm sure it isn't a plugin problem because I have gone through 2 other plugins and ran into the same issue. Has anyone else had this issue?

From what i read in previous thread people have had issues getting the right thumbnail or description up. I'm not sure if this is the same problem I'm having. My site thumbnail with logo shows up with the main url but not the post url.

Thanks in advance!
  #2  
Old Feb 17, 2012, 07:23 AM
juggledad's Avatar
juggledad
 
23,560 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What version of Atahualpa and WP?
What is the url?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Feb 17, 2012, 07:47 AM
GiveMeDap
 
6 posts · Feb 2012
Atahualpa 3.7.3 and Wordpress 3.3.1

Url: www.givemedap.com

Any help would be much appreciated. Thanks!
  #4  
Old Feb 17, 2012, 08:44 AM
juggledad's Avatar
juggledad
 
23,560 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what happens if you go to the post's page and do the share from there?

I think the way it works is it does a share for THE PAGE YOU ARE ON. So if you are on the home page and add a share for the first post (remember this is a multi post page) the share is for the home page, not th epost. If you want a share on the post, then ou need to go to the post page and do the share.

This has nothing to do with the theme, if you want it to work differently, you will need to contact the plugin developer.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Feb 19, 2012 at 05:27 AM.
  #5  
Old Feb 18, 2012, 11:54 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I happened to have that plugin installed on my test site and it works fine. The only difference I see is that my share buttons don't show on excerpts. Do you by any chance have more than one share plugin installed?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old Feb 18, 2012, 09:44 PM
GiveMeDap
 
6 posts · Feb 2012
Sorry for the late reply.

jugglesdad: I've tried with several computers and it only shares the main URL on both the home page and when I click the individual post.

limilesw: no I only have this plugin as my only social plug in. I have tried dis-activating it and installing a new social plugin but it seems to do it with every plugin I have tried.
  #7  
Old Feb 18, 2012, 10:19 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Have you tried deactivating ALL OTHER plugins to see if the social plugin works?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #8  
Old Feb 18, 2012, 10:24 PM
GiveMeDap
 
6 posts · Feb 2012
I haven't tried deactivating ALL, but would that be necessary if the twitter and email share buttons work fine? It's just the Facebook button that links the user to the main URL and not the post. Although when I hover over the share button, I see that it reads the link for the post's URL. I just dont understand why after you click on the button it would only share the main URL.

I will try to deactivating all and see what happens
  #9  
Old Feb 18, 2012, 10:38 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Deactivating all but the plugin in question is just a troubleshooting step to eliminate the possibility of a plugin conflict. As I said the plugin works fine for me but I don't see the social icons on excerpts like I do on your site.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #10  
Old Feb 19, 2012, 05:28 AM
juggledad's Avatar
juggledad
 
23,560 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
one other thing to check is how you have your permalinks set. as a debuugging test change your permalinks to the default and try it - don't forget to change them back to what you now have.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #11  
Old Feb 19, 2012, 11:48 PM
GiveMeDap
 
6 posts · Feb 2012
Yes! it was changing the permalinks to defualt. THanks Juggledad!

Bookmarks

Tags
facebook, plugin, share, social

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to share post info (excerpt/image) in facebook ortixia Atahualpa 3 Wordpress theme 1 Jan 28, 2011 05:31 PM
Share Post on FaceBook without any use of plugins (( Atahualpa )) irvin Atahualpa 3 Wordpress theme 5 Dec 18, 2010 07:04 AM
[SOLVED] Facebook Share button not sharing posts separately Karen Forum How-To 4 Dec 6, 2010 02:30 AM
Facebook share button doesn't display my pics ! drey Plugins & Atahualpa 2 May 9, 2010 02:45 PM


All times are GMT -6. The time now is 03:39 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.