Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

"Don't link first level parent items in Page Menu Bar" with WP menus?


  #1  
Old Nov 14, 2011, 08:11 PM
lehacarpenter
 
33 posts · Oct 2009
Hi, one more question:

Can I still use Ata's "Don't link first level parent items in Page Menu Bar?" = Yes

with the WP menus? I have not been able to get this to work.

Thank you!!

Leha
  #2  
Old Nov 14, 2011, 08:30 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
That function is not used when using the WordPress menus. To create a top level menu with the WordPress menu just create a custom menu item and put a hashtag (#) in the url field for the menu.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Nov 19, 2011, 12:14 AM
mimi's Avatar
mimi
 
70 posts · Feb 2009
over there...
Do your hover + selected states in the menu bar behave as they should with WP3 Menu, on Custom Links, or do they all default to "Background color: Hover" ?

I am talking about Custom Links and Sub pages of course. It seems there is a styling issue.
  #4  
Old Nov 19, 2011, 05:29 AM
mimi's Avatar
mimi
 
70 posts · Feb 2009
over there...
Might be easier to explain the problem with a link.

Last edited by mimi; Nov 19, 2011 at 05:46 AM.
  #5  
Old Nov 19, 2011, 05:34 AM
juggledad's Avatar
juggledad
 
23,596 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
If you are using a custom wordpress menu, not all the Atahualpa menu settings may work. You are responsible for the styling yourself.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Nov 19, 2011, 05:52 AM
mimi's Avatar
mimi
 
70 posts · Feb 2009
over there...
Quote:
Originally Posted by juggledad
If you are using a custom wordpress menu, not all the Atahualpa menu settings may work. You are responsible for the styling yourself.
I am not sure if we understood each over, I am NOT using a "custom wordpress menu".

I am using the built in word press menu. It's built into WordPress.

Can you help?
  #7  
Old Nov 19, 2011, 06:29 AM
juggledad's Avatar
juggledad
 
23,596 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Wordpress Custom menu = dashboard->appearances->menu
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Nov 19, 2011, 06:37 AM
mimi's Avatar
mimi
 
70 posts · Feb 2009
over there...
Quote:
Originally Posted by juggledad
Wordpress Custom menu = dashboard->appearances->menu
Been there already... it's pretty straight forward. As mentioned already, the problem is well explained over here.

I having googling since yesterday, and there isn't much help out there.

I have just read this article, which seem to be the "solution", but it's too advanced for me.
  #9  
Old Nov 19, 2011, 06:41 AM
mimi's Avatar
mimi
 
70 posts · Feb 2009
over there...
That looks good too!
  #10  
Old Nov 19, 2011, 07:37 AM
mimi's Avatar
mimi
 
70 posts · Feb 2009
over there...
Been reading a bit more, I am trying the following code:

Code:
#menu1 .current-menu-item {
background:white !important;
}
#menu1 .current-menu-item li a:first-child { 
color:green !important;
}
#menu1 .current-menu-item a { 
color:red !important;
}
The "background:white" doesn't do anything (not too worry about this one, as it takes the colors from ATA's setting).

The "color:green" affects ALL the sub pages/first-child if when the parent if selected (as before/no good).

The "color:red" works as advertised.

I have to say that this problem is present, wether you are using a Custom Link or not.

So it should be looked into, because it makes the WordPress Menus pretty much useless as is stands.
Try it for yourself and you will see what I mean.


One option at the minute, is to have the selected background state the same as normal state, to make it look less ugly/weird, and using different font colors on different states, but it will still affect the "parent" menu and child when selected.
  #11  
Old Nov 19, 2011, 08:40 AM
mimi's Avatar
mimi
 
70 posts · Feb 2009
over there...
I have moved one, although I don't know what I am doing, I came up with a way to get the text color to "work", with the following code:

Code:
#menu1 .current-menu-item li a:first-child { 
color:white !important;
}

#menu1 .current-menu-item li a:hover { 
color:green !important;
}
Could not find a way to get the "Background color: Hover" to work.

If someone is interested and wants to join in, here is a post clearly explaining the problem in a few words.

And the following code was suggested, which didn't work, so I altered it and came up with the above line.

Code:
#menu .current-menu-item {
background:white; 
}
#menu .current-menu-item li a:first-child { 
color:white!important;
}
#menu .current-menu-item a { 
color:black !important ;
}
I think you guys/girls should look into it, because soon or later you might want to take advantage of the new WordPress Menu, as it's very flexible and quick to setup. I came to think that not many of you might know how powerful it is.

At least my little tweak gets "some of" the job done. I am not a coder, far from it.

Last edited by mimi; Nov 19, 2011 at 09:00 AM. Reason: Amended the first CODE.
  #12  
Old Nov 19, 2011, 09:16 AM
mimi's Avatar
mimi
 
70 posts · Feb 2009
over there...
Final teak for today (then I go bed...), I got it working!!!, but watch out;
I don't know what I am doing:

Code:
#menu1 .current-menu-item hover {
background: white; 
}

#menu1 .current-menu-item li a:first-child { 
color: #555555 !important;
}

#menu1 .current-menu-item li a:hover { 
color:green !important;
background: white !important;
}

Please amend and/or participate if need be, don't be shy.

Last edited by juggledad; Nov 19, 2011 at 12:28 PM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Don't link first level parent items in Page Menu Bar? thekjub9 Page & Category Menu Bars 5 Jul 30, 2014 07:49 AM
Don't link first level parent items? rackphoto New Versions, & Updating 4 Mar 14, 2011 05:04 PM
[SOLVED] Don't link first level parent items in Page Menu Bar? - Not working nberryman Atahualpa 3 Wordpress theme 18 Feb 28, 2011 12:46 AM
[Suggestion] Don't link first level parent items in CATEGORIES menu bar ymf Page & Category Menu Bars 2 Nov 17, 2010 09:16 PM
Don't link first level parent items in page menu bar Vnugrda Page & Category Menu Bars 5 Oct 20, 2010 05:42 PM


All times are GMT -6. The time now is 03:02 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.