Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

Local backup: looks fine, but text widgets are gone


  #1  
Old Nov 1, 2011, 10:06 AM
EnricoWP
 
18 posts · Oct 2011
I made local backup of my blog (I use xampp in my desktop), it looks fine, but I have to rebuild my text widgets (desappeared), it's normal?
  #2  
Old Nov 1, 2011, 01:08 PM
juggledad's Avatar
juggledad
 
23,687 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
are you saying after you did a backup, you site is messed up
or are you saying you did a backup, then restored it and there is an issue?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Nov 2, 2011, 02:59 AM
EnricoWP
 
18 posts · Oct 2011
I'm saying i did a backup and restored in my local server. It works fine, but my text widgets are gone.
  #4  
Old Nov 2, 2011, 06:05 AM
juggledad's Avatar
juggledad
 
23,687 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
how did you do the backup and restore? step by step
where were the text widgets? sidebars? in a new widget area?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Nov 2, 2011, 11:55 AM
EnricoWP
 
18 posts · Oct 2011
I did the backup as usually, it works perfectly, but the text widgets in sidebars are gone.

1) Backup datatabase
2) Backup data
3) Export Atahualpa settings
4) Create local database empty
5) Modify db backup with Notepad++ (sobstitution www.mysite.tld with 127.0.0.1/mysite)
6) Import db backup modified
7) Restore data folders
8) Modify wp-config.php

Result: all works perfectly, but everytime I have to restore text widgets in sidebars manually. Any idea?

Last edited by EnricoWP; Nov 2, 2011 at 11:57 AM.
  #6  
Old Nov 2, 2011, 12:53 PM
juggledad's Avatar
juggledad
 
23,687 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
when you changed the url, wordpress resets things(according to my experience).
you would have to change the wordpress url and site address before doing the export.

this is not a backup/restore it is a backup from one location and a restore to another, since teh url changes, 'stuff' happens.

it's like you create a custom menu, then update the theme and you have to go back and reset the custom menu because WordPress reset it. It looks like Wordpress thinks a theme update is a new theme so it changes things.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Nov 2, 2011, 04:25 PM
EnricoWP
 
18 posts · Oct 2011
I never had this problem, with other themes...so it is an Atahualpa's problem, i think. But no problem, it isn't a tragedy, just a bit boring because i have to remake text widgets everytime.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Automatic Backup of theme AND contents needed quintain Plugins & Atahualpa 6 Jul 5, 2011 04:12 AM
What's the Best Backup Plan for a WP Atahualpa website? Shepherd Jim Plugins & Atahualpa 3 Jan 7, 2011 08:19 AM
php in text widgets? lauras2010 Sidebars & Widgets 3 Oct 8, 2010 04:02 PM
BUGFIX 342: Can't change text font, in text widgets Leoni Old Version fixes and change logs 3 Aug 5, 2009 05:30 AM


All times are GMT -6. The time now is 03:09 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.