Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Excerpts, Read more, Pagination »

Atahualpa still strips my <a> html tag


  #1  
Old Oct 27, 2011, 10:15 AM
86owen
 
44 posts · Mar 2011
I have set up a site on http://gogg.gagnavist.is and the first post on the frontpage has two links, one to a PDF file and one to a website. But the links wont appear until you click Lesa meira (read more). I have these settings under configure EXCERPTS
Excerpt length = 55
Don't strip these tags = <p><a><span><em><strong>
Then I have only excerpts in all the dropdowns below and 0 in the Show the first X posts on HOME page as full posts? field.
Im using atahualpa 3.6.7

Can anybody help me on this ?
  #2  
Old Oct 27, 2011, 11:15 AM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The reason is because of the complexity of excerpts. To build an excerpt, the code counts the words and words are defined as things between spaces. when you add '<span>' to th e'Don't strip these tags, then the span code is part of the word found (i.e. the code '<span style="font-size: small;">' counts as three words)

My suggestion is to either bump up the number of words in the excerpt or manually create the excerpt in the post.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Oct 27, 2011, 11:19 AM
86owen
 
44 posts · Mar 2011
I set the word count to 100 but nothing changed... I also removed <span> and <em> from the dont strip these tags field.

This is really strange.
  #4  
Old Oct 27, 2011, 01:15 PM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
you sure you still have the <a> in there?
go to ato->export/import settings and export your settings and attach them to a reply
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Oct 28, 2011, 02:21 AM
86owen
 
44 posts · Mar 2011
Attached is a screenshot of this setting page and the export doc.
Attached Thumbnails
Click image for larger version

Name:	atahualpa.png
Views:	382
Size:	37.8 KB
ID:	1588  
Attached Files
File Type: txt ata-gogggagnavistis-20111028.txt (21.3 KB, 766 views)
  #6  
Old Oct 28, 2011, 03:54 AM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Try disabling your plugns to see if there is a conflint. Your settings work for me and I copied your post
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Oct 28, 2011, 05:38 AM
86owen
 
44 posts · Mar 2011
Ok, it looks like this plugin is the issue here, http://wpcal.firetree.net/ Event calendar

Would you know by any chance why the heck it interferes with my posts ?

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
transferring a html page onto Atahualpa mick s Center area post/pages 9 Apr 14, 2011 01:32 PM
How can i attach html codes to the home page with atahualpa header rcmadawala Atahualpa 3 Wordpress theme 2 Oct 16, 2010 11:41 AM
HTML/CSS inserts in Atahualpa 3.4.1 (for custom header image slider) csb Header configuration & styling 3 Nov 16, 2009 07:02 PM
Atahualpa left / right text html plugin corrupted: Pamela Sidebars & Widgets 1 Oct 14, 2009 07:12 PM
Atahualpa 3.4.2 bug - html entities instead of UTF8 chars in meta fields pgc Atahualpa 3 Wordpress theme 5 Aug 13, 2009 09:14 AM


All times are GMT -6. The time now is 09:33 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.