Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

ATA W3 Cache and maxcdn reloaded


  #1  
Old Jul 6, 2011, 01:06 AM
scrollpost
 
17 posts · Jan 2010
Hi
Site: http:scrollpost.com

I am trying to optimize my site and I am using http://tools.pingdom.com to test.

Why are files in ata's image folder (/atahualpaxxx/images/xxx.png) inaccessible directly - so they can be loaded on a CDN - and how do I change this? BTW this is not 100% consistent - inputbackgr-blue.gif for example is open. All files are 755.

>>One more point: The inaccessible images are the ones that have been turned off for display, but for some reason there is code somewhere trying to retrieve them anyway - BUT this is slowing down the page load times (according to pingdom).

Thanks
Jack

Last edited by scrollpost; Jul 6, 2011 at 01:19 AM.
  #2  
Old Jul 6, 2011, 05:52 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
try changing the permissions to '644'
I ran pingdom on a fresh install with no errors showing and that is what the permissions are set to for 'rss-gray.png' for example
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jul 6, 2011, 08:13 AM
scrollpost
 
17 posts · Jan 2010
Thanks. But nothing changed.

Maybe this is a bug? Whether it is 644 for 755 pr 775 shouldn't make a difference anyway.
I am using ATA 364. Perhaps there was a bug that was corrected in a later version?

The key issue as I see it is the "bad" image files are those that don't want themselves displayed.
For example, the wordpress comment system is off, replaced by intense debate.
Maybe pingdom is seeing these files as inaccessible?
  #4  
Old Jul 6, 2011, 08:31 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I suspect that pingdom is looking in the CSS and trying to retrieve any url that is in it, but not knowing their process, that is a guess.

as for the privileges, it could be tied to the privilege of the folder, the parent folder and .htaccess, restrictions set by the host or something else that I'm unaware of.

privileges and access to files have nothing to do with the theme, they are controlled by the server (Apache)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Jul 6, 2011, 09:51 AM
scrollpost
 
17 posts · Jan 2010
These days a simple WP installation doesn't generate an htaccess file, but a multi-site one does.
I am using multi-site.

I believe this could be the offending htaccess line:
RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]

All the privileges are set correctly.

I have written to the host company.
  #6  
Old Jul 6, 2011, 11:35 AM
scrollpost
 
17 posts · Jan 2010
Answer from the host company:
Quote:
Thank you for contacting us. I have disabled the FilesMatch Apache configuration entry at /etc/httpd/cont/httpd.conf (under scrollpost.com VHOST).
What was it matching? Or not? It wasn't suffix related. Another .png was getting through.

Well well well! This itself shaves off a few seconds on the pingdom score.
And it's not about cacheing, optimizing, encoding or compressing!
Just a simple non-memory related configuration mistake!
  #7  
Old Jul 6, 2011, 12:34 PM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Actually, a single site will create an htaccess file the minute you set the permalinks to something other than the default.

As for what a apache setting was matching...beats me, I'm not a apache guru and it's not a theme issue...
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
WP-Table Reloaded code insert johnnybravo Plugins & Atahualpa 8 May 31, 2011 02:35 AM
Issue with WP-Table-Reloaded Christophermathis New Versions, & Updating 2 Jan 10, 2011 11:57 AM
Anyone using W3 Total Cache or CDN Tools with ATA? lhanft Plugins & Atahualpa 2 Dec 12, 2010 11:29 AM
Caching WordPress with WP-Cache 2, WP Super Cache & PHP Speedy Flynn Installing & running WordPress 9 Dec 3, 2009 04:15 PM
New to WP...Got Ata 3.3..?'s on Ata vs Montezuma and TOP THINGS TO CUSTOMIZE - FIX? Brasshatgroup New Versions, & Updating 5 Jun 1, 2009 06:22 AM


All times are GMT -6. The time now is 05:34 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.