Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Excerpts, Read more, Pagination »

Thumbnail Cropping Not Working


  #1  
Old Jul 5, 2011, 10:48 AM
sar
 
17 posts · Aug 2010
Using:
Wordpress 3.2
Ata 3.6.7

I would like to display only excerpts on all pages. I have set theme options to show only excerpts on all pages and I have changed the thumbnail size to 150x150 in Ata theme options and in Wordpress media settings. I have cropped all images (applied to only thumbnails) so that heads won't be cut off when the thumbnail shows up in the excerpt. However, after having done all this, the thumbnail images that I cropped, don't show up. There is a thumbnail, but it is the uncropped version. I have tried everything... I tried thumbnail editing with NextGEN gallery and it does the same thing. I also use Regenerate Thumbnails... did that and nothing changed. I changed to the Twenty Ten and Twenty Eleven themes and thumbnails work fine (cropped thumbnail shows up). After reading Wordpress Codex, I noticed that the information below is not in the functions.php file. Do I need to add this for the "cropped" version of my thumbnail to work? Please help! I have been struggling with this for weeks and have read everything I can and have found no solution! I assumed it would be easy to crop an image, apply it to a thumbnail and have it show up in post excerpts.

From Wordpress:
Themes have to declare their support for post images before the interface for assigning these images will appear on the Edit Post and Edit Page screens. They do this by putting the following in their functions.php file:

if ( function_exists( 'add_theme_support' ) ) {
add_theme_support( 'post-thumbnails' );
}





This is what I found in Ata functions.php:

if ( function_exists( 'add_theme_support' ) ) { // Added in 2.9

// Since 3.4.5: WP 2.9 thumbnails support:
add_theme_support( 'post-thumbnails' );
if ($bfa_ata['post_thumbnail_crop'] == "Yes")
set_post_thumbnail_size( $bfa_ata['post_thumbnail_width'], $bfa_ata['post_thumbnail_height'], true );
else set_post_thumbnail_size( $bfa_ata['post_thumbnail_width'], $bfa_ata['post_thumbnail_height'] );
add_image_size( 'single-post-thumbnail', 400, 9999 ); // Permalink thumbnail size

// Since 3.5.4:
add_theme_support('automatic-feed-links');
}



Thank you in advance!
  #2  
Old Jul 5, 2011, 11:05 AM
juggledad's Avatar
juggledad
 
23,570 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What is the URL?
Do you have all BUGFIX's for 367 applied? (they can be found in the 'New Version & Updates' forum and sub forum)
--if not, apply them before we go any further and re-test
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jul 5, 2011, 11:18 AM
sar
 
17 posts · Aug 2010
I am building on MAMP... I have applied all bug fixes. Also, I just notices that nothing is working within the Post Thumbnail CSS (in Post Thumbnail options) and the Style IMAGES. I have changed borders and colors and nothing is working.
  #4  
Old Jul 5, 2011, 04:47 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
How are you generating the thumbnail. If you just put <img> in don't strip these tags the image will show. If you use the featured image function the setting for thumbnails in Atahualpa should work. I just tested.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Jul 5, 2011, 07:29 PM
sar
 
17 posts · Aug 2010
I am using the Featured Image option within the post. The thumbnail will show up but not the thumbnail that I previously cropped in the media sub-panel. Also, as stated below, none of theme options for styling images or styling thumbnails are working. I previously applied the bug-fixes for 3.6.7. I have not changed anything in the theme files. I have checked for plug-in conflicts and still have not found a solution.
  #6  
Old Jul 5, 2011, 08:48 PM
sar
 
17 posts · Aug 2010
I am now able to style the theme options for images but not for thumbnails. Captions are now working. The only way I could get them to work was by switching back to the Twenty ELEVEN theme and changing the Default Post Format to STANDARD. I then switched back to ATA and styled the images and thumbnails through the ATA theme options. However, the styles that I applied to images are now being applied to the icons (print icon, e-mail icon and comment icon) in my post footer. Are there compatibility options with Wordpress 3.2?

Last edited by sar; Jul 5, 2011 at 09:22 PM.
  #7  
Old Jul 5, 2011, 10:44 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Do any changes to the CSS in the Post Thumbnail CSS box take affect?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #8  
Old Jul 6, 2011, 09:16 AM
sar
 
17 posts · Aug 2010
Changes in Post Thumbnail CSS do not take effect.
  #9  
Old Jul 6, 2011, 10:39 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I am using 3.2 and can style the thumbnails fine in the theme options.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thumbnail with a image zoom mirco65 Header configuration & styling 4 May 19, 2011 07:59 AM
Help solving thumbnail problems cwjorgensen Excerpts, Read more, Pagination 2 Mar 5, 2011 05:44 AM
thumbnail styling bugs? Jeff G Center area post/pages 0 Jun 15, 2010 01:27 PM
Auto-thumbnail from post kjetil Post-Kicker, -Byline & -Footer 0 Jul 31, 2009 03:46 PM


All times are GMT -6. The time now is 05:37 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.