Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

Header widgets out of place in IE


  #1  
Old Jun 20, 2011, 11:40 AM
lakewooditsupport
 
48 posts · Jun 2011
England, United Kingdom
I finally managed to get to get a java link to overlay the header image area, by creating two header widgets. It works and appears perfectly in all browsers bar internet explorer 9. It is out of place to the right by 90px. I have tried changing settings with the widgets but cant seem to get anywhere?

Here is the code for the widgets

PHP Code:
<?php bfa_widget_area('name=contact &cells=4&align3&align<div id="contact" class="header-widget %2$s">&after_widget=</div>'); ?>
<?php bfa_widget_area
('name=Header &cells=4&align3&align<div id="livechat" class="header-widget %2$s">&after_widget=</div>'); ?>
and the CSS inserts are:

Code:
td#header__4 div.widget {
	z-index: 4;
	position: absolute;
	float: right;
	width: auto;
	margin-top: 20px;
	margin-left: 90px;
	}
td#contact__4 div.widget {
	z-index: 4;
	position: absolute;
	float: right;
	width: auto;
	margin-top: 20px;
	margin-left: -80px;
        margin-right: 50px;
	}
I have a feeling its something to do with the width of the widgets?
  #2  
Old Jun 20, 2011, 11:45 AM
lakewooditsupport
 
48 posts · Jun 2011
England, United Kingdom
Sorry I forgot to include a link to the site.

The widget is over the header on the right (livechat)+(contact us) two separate widgets.

http://lakewooditsupport.co.uk/
  #3  
Old Jun 20, 2011, 08:57 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
There are several things going on here. The first is the code for the widget areas is for two 4-celled widget areas one over the other when all you need is one 2-celled widget area. The code for that would be.
HTML Code:
<?php bfa_widget_area('name=Contact and Chat&cells=2&before_widget=<div id="%1$s" class="header-widget %2$s">&after_widget=</div>'); ?>
Another issue is I would avoid absolute positioning as that can be problematic.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #4  
Old Jun 21, 2011, 05:57 AM
lakewooditsupport
 
48 posts · Jun 2011
England, United Kingdom
I tried the code you suggested and it didn't work at all, No widget was created?

I cant think of what other positioning to use as all other methods leave the widgets above the header image.
  #5  
Old Jun 21, 2011, 06:01 AM
lakewooditsupport
 
48 posts · Jun 2011
England, United Kingdom
Okay I just has a little mess with it again and fixed it, it was as I thought just the header width needed adding to the widget code.
It now looks like this:
PHP Code:
<?php bfa_widget_area('name=contact &cells=4&align3&align=width950<div id="contact" class="header-widget %2$s">&after_widget=</div>'); ?><php>
I would still like it to be in just two widgets, as I have two codes giving me 8 header widgets.
  #6  
Old Jun 21, 2011, 06:50 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Larry's code worked for me, remember you have to
1) put the code in and save it
2) go view the page
3) then go to the widget area.

To get rid of old 'New Widget' areas
1) remove and widgets from the widget area
2) remove teh code from where you placed it
3) go view the page
4) go to ato->Add new WIDGET AREAS->Delete custom Widget Areas and delete the widget areas you want gone.

NOTE: in your code you have cells=4 - this will create 4 widget areas
ALSO you have align=width950 which is invalid
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jun 21, 2011 at 07:22 AM.
  #7  
Old Jun 21, 2011, 10:48 AM
lakewooditsupport
 
48 posts · Jun 2011
England, United Kingdom
I have changed the code again and it still didn't work, the code I did originally (messy I know) seems to work on all browsers. If you guys could have a look and see if your getting what I am on your end?
  #8  
Old Jun 21, 2011, 12:37 PM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
unfortunately, I do not have ie9 since it will only run on vista or win7.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Jun 21, 2011, 12:55 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
IE9 looks OK now.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Bookmarks

Tags
header, java script, overlay, widgets

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Place two identical widgets in the same sidebar box.carlo Sidebars & Widgets 2 Jan 9, 2011 02:07 PM
How to place widget in header frugalmommytoday Sidebars & Widgets 5 Oct 28, 2010 10:20 AM
[SOLVED] How do I place widgets within page content? Craig Mattice Plugins & Atahualpa 5 Mar 1, 2010 09:02 AM
Added Widgets to Header area and now Widgets won't go away from Widgets page kippiper Header configuration & styling 5 Nov 12, 2009 04:33 PM
want to place clickable icons in place of links (Home, About, etc.) agrossman Header configuration & styling 2 Aug 13, 2009 02:45 PM


All times are GMT -6. The time now is 03:56 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.