Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages »

[SOLVED] TinyMCE editor removes spaces after comma character


  #1  
Old May 13, 2011, 01:40 AM
rodger43
 
5 posts · May 2011
I am using theme Atahualpa 3.6.7 on http://barbandrodger.com. When I create a post (or page), the resulting code removes any space character that follows a comma. You can see this effect by going to http://barbandrodger.com. You'll see it on the home page.

I went back to Atahualpa 3.6.6. Same problem.

I went back to Atahualpa 3.6.4. Same problem.

When I create a new post, or edit an old one, and then do a preview, I see the same effect. Any word that has a following comma, together with a following space, is run up to the next word with no space in between.

Has anyone else experienced this? Any ideas?

Rodger
  #2  
Old May 13, 2011, 01:46 AM
rodger43
 
5 posts · May 2011
Oh... and I also need to share that the same effect exists in the Edit POST/PAGE INFO ITEMS, where I need to manually add a non-breaking space after any special character like a bullet or vertical line; otherwise, the next text will be presented without an intervening space -- even if a space character is present.
  #3  
Old May 13, 2011, 09:56 AM
lmilesw's Avatar
lmilesw
 
10,176 posts · Jul 2009
Central New York State USA
I am not experiencing that issue. Have you checked for plugin conflicts?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Last edited by lmilesw; May 13, 2011 at 11:32 AM.
  #4  
Old May 13, 2011, 11:15 AM
rodger43
 
5 posts · May 2011
Yes, I have stripped it down to bare bones and the problem persists. When I switch to any other theme the editor renders properly. I will continue to troubleshoot and I will report if I find anything.

Thank you for your reply.
  #5  
Old May 13, 2011, 11:33 AM
lmilesw's Avatar
lmilesw
 
10,176 posts · Jul 2009
Central New York State USA
When I look at your site I see some places, sometimes in the same post, where the space shows and doesn't show. Is that where you put a non-breaking space to compensate?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old May 13, 2011, 08:19 PM
rodger43
 
5 posts · May 2011
Yes, I added a few non-breaking spaces here and there. But here is big news:

I created a new different site from scratch (RodgerAndBarb.com) using WP 3.1.2. Then I installed atahualpa367.zip using the upload method. Without making any other changes, I noticed that all instances where a comma occurred, there was no space following the comma. Even the default date stamp on posts showed May 14th,2011 rather than May 14, 2011. So....

I restored my test site back to the default theme and then deleted atahualpa 3.6.7. Then I installed atahualph by using the search method, which yielded 3.6.4. Suddenly, everything worked as expected.

Along the way I found that the comma problem exists in 3.6.6 as well.

After returning BarbAndRodger.com to atahualpa 3.6.4, I found that I needed to go into each page and post and manually insert a space after each comma and then repost. A pain, but fortunately I hadn't completed many pages there yet so it really wasn't so bad.

I will just stick with 3.6.4 for the time being. If a new atahualpa version appears, I'll give it a try it on a test site.

-Rodger-
  #7  
Old May 14, 2011, 04:34 AM
Huey
 
1 posts · May 2011
I have exactly the same problem. It's not a biggie but that editor in me isn't really happy about it. :/

Also, the styles for calendar are also gone. For instance, in the older version, I've set the date with posts to appear in different colour. In the latest version, the dates just appear the same as those dates without post.

I haven't upgraded the theme for a while so I thought I wanted to do it today (upgrading from 3.5.1) and after playing around with it for a while, I noticed the missing space after comma. I'm going to try downgrading and see if it's back to normal...


- Huey

Last edited by Huey; May 14, 2011 at 04:38 AM.
  #8  
Old May 14, 2011, 05:18 AM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
If you have ATO->Configure CSS & JS->CSS: Compress? set to 'YES' you will see this problem.
This is fixed with BUGFIX 367-01: Odd effects when 'CSS: Compress' = 'Yes'

this compression issue also existed in 3.6.4 but was addressed in BUGFIX 364-02: CSS Compression does not happen if 'Allow debugging?' is 'Yes'
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old May 14, 2011, 08:55 AM
rodger43
 
5 posts · May 2011
Ah yes... we've all been bitten by "isset confusion" at one point or another. Thanks for pointing out the fix. Works great.

-Rodger-

Bookmarks

Tags
comma, space, tinymce

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Inserting horizontal rule removes the content of the whole post Jacek01 Center area post/pages 7 Apr 24, 2011 07:04 PM
[SOLVED] TinyMCE from fromtheranks Plugins & Atahualpa 4 Apr 6, 2011 07:39 PM
Problem locating text and images with layer option in TinyMCE advanced donfos001 Plugins & Atahualpa 0 Nov 3, 2010 11:59 AM
[SOLVED] How to install TinyMCE Advanced plugin shus Plugins & Atahualpa 4 Dec 23, 2009 11:23 PM
TinyMCE Advanced plugin - Do we Atalhualpians like it? Shepherd Jim Plugins & Atahualpa 13 Jun 29, 2009 06:17 PM


All times are GMT -6. The time now is 05:18 AM.


Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.