Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Multiple current-menu-item tags on home page


  #1  
Old May 5, 2011, 10:07 AM
sawyerjw
 
24 posts · Dec 2010
Eastern PA, USA
I'm using Atahualpa 3.6.4 on WP 3.1.2. The URL for the site in question is: http://storage-brain.com

When on the home page, the Home menu tab is colored as the active tab, as it should be. The Resources tab, however, is also colored as the active tab, which looks a bit weird. Looking at the generated code, I'm seeing that both tabs have been assigned classes "current-menu-item" and "current-page-item" even though logically only one of them should have those classes assigned.

If you go to any other page on the site, there is only one active tab, so this glitch only occurs on the home page. I've searched here and not found anything on this, aside from a couple of screen shots that show the same problem.

Is this a known bug, and if so, is there a fix?

Thanks,

John
  #2  
Old May 5, 2011, 11:14 AM
juggledad's Avatar
juggledad
 
23,684 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Have you got all the BUGFIXs applied? (New Versions & Updates)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old May 5, 2011, 11:41 AM
sawyerjw
 
24 posts · Dec 2010
Eastern PA, USA
I've not applied any since I last downloaded it. When I originally downloaded 3.6.4 I applied bug fixes and blew it out of the water. I redownloaded and it's been working since. That was probably about 2 months ago.

I'll check and see if there are any I need to apply and go from there.

Thanks,

John
  #4  
Old May 5, 2011, 02:24 PM
sawyerjw
 
24 posts · Dec 2010
Eastern PA, USA
Patches applied and the problem persists. I applied the patches to my development site which is identical theme-wise to the live site I cited earlier:

http://chontest.com/SB-V2

Thanks.
  #5  
Old May 5, 2011, 04:02 PM
juggledad's Avatar
juggledad
 
23,684 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Is the resource page your home page?
If so go to the menu 1 (page menu) options and blank out thE 'Home link in page menubar' option
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old May 5, 2011, 05:13 PM
sawyerjw
 
24 posts · Dec 2010
Eastern PA, USA
No, but you gave me the clue to the problem. This was a little "feature" left over from the previous version of the site. The Resources tab was a custom link pointing to an anchor on the home page.

Thanks for the help,

John

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Background image for current page item? crashley1784 Page & Category Menu Bars 2 Apr 22, 2011 07:07 PM
[SOLVED] change current category menu item text color cway Page & Category Menu Bars 3 Oct 29, 2010 09:39 AM
Page menu (pages-widget): Current page item in post unelma Sidebars & Widgets 5 Jun 7, 2010 04:11 PM
[SOLVED] Item Padding inside Expaned Page Menus & Color of Items on current page. joshsweiss Page & Category Menu Bars 7 Feb 23, 2010 07:31 AM
[SOLVED] Change Current Menu Item's Background to Transparent rnimchuk Header configuration & styling 2 Sep 15, 2009 06:12 AM


All times are GMT -6. The time now is 03:25 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.