Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

SEO options spoil my meta tag chars encoding


  #1  
Old Apr 20, 2009, 03:56 PM
PetrosPolonos
 
3 posts · Mar 2009
Hi,

My website is in Polish, all UTF-8. When I turn Atahualpa SEO options off, page titles show properly. As soon as I switch it on - Polish chars encoding goes wrong.
See screens attached.

Regards,

Piotr
Attached Thumbnails
Click image for larger version

Name:	SEO_NOT_ok.jpg
Views:	1089
Size:	89.8 KB
ID:	90  Click image for larger version

Name:	SEO_ok.jpg
Views:	991
Size:	86.4 KB
ID:	91  
  #2  
Old Apr 20, 2009, 06:19 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Could you try a SEO plugin such as "All in one SEO" or "Headspace 2" and see if the same error occurs?
  #3  
Old Apr 22, 2009, 12:50 AM
PetrosPolonos
 
3 posts · Mar 2009
Hi,

I emplyed All-in-One before. It solved the encoding problem, but blocked dynamic tags -> Keywords allocation, so I got rid of it. Headspace 2 looks nice. Tags are allocated, chars are encoded properly - I am going to use it. Of course, I will gladly take part in solving the problem anyway.

P.
  #4  
Old Apr 22, 2009, 12:53 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
I'll look into Headspace 2 then to see what he's doing differently. Thanks for trying this out. WpSeo is also considered to be good if your very concerned about SEO
  #5  
Old Aug 14, 2009, 05:25 AM
maf
 
1 posts · Aug 2009
Hi,

This only happens for category and search pages and the reason is that functions/bfa_meta_tags.php line 75 and 83 (Atahualpa 3.4.1) doesn't have a charset in htmlentities, which makes it revert back to iso-8859-1 instead of utf-8.

I changed the hardcoded lines to this to solve the problem temporary:
$bfa_ata_page_title = htmlentities(single_cat_title('', false),ENT_QUOTES,"UTF-8");
and
$bfa_ata_page_title = htmlentities(wp_specialchars($s),ENT_QUOTES,"UTF-8 );

Hope this change makes it to a later release.

Regards,
Magnus Frostlid
http://teknikkonsument.se

Last edited by maf; Aug 14, 2009 at 05:30 AM.
  #6  
Old Aug 14, 2009, 06:22 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
I've added that, thanks

Bookmarks

Tags
encoding, meta, polish chars, seo, utf

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
SEO plugin recommendations scrubbs Plugins & Atahualpa 2 Nov 15, 2010 09:57 AM
All-in-one-SEO not working crippen Plugins & Atahualpa 14 Oct 23, 2009 05:02 AM
atahualpa : Forthcoming V3.3.4 better for SEO? Mick Regan New Versions, & Updating 1 Jun 29, 2009 08:42 PM
Atahualpa 3.3.3 Themes panel options shows the options but it does not work pkmittal81 New Versions, & Updating 7 Jun 11, 2009 06:31 AM
SEO and built-in tags paulae Installing & running WordPress 0 Apr 30, 2009 07:28 AM


All times are GMT -6. The time now is 02:39 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.