Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

Jquery Issue in ATA 3.6.1+


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Feb 3, 2011, 06:55 PM
BradBrown's Avatar
BradBrown
 
54 posts · Mar 2009
I ran across something in the newer versions of Atahualpa that caused me some problems. I rearranged the ATA code a bit to get around it, so I'm good, but I thought I'd mention it here anyway. Other people may encounter this, and I'm also open to ideas for fixes that wouldn't involve editing the ATA code.

My site, http://www.bradbrownmagic.com, uses some scripts that rely on Jquery: Cufon and an image rotator. The code is placed in the Header Inserts section. They stopped working when I upgraded to the newer ATA version. The problem is that beginning with version 3.6.1, things were rearranged in the header. Now Jquery isn't loaded until after the Header Inserts.

The best solution I could come up with was to edit the ATA code so the inserts load after wp_head(). I assume there are situations where this could be a bad thing, or it wouldn't have been changed in ATA in the first place. However, this worked for my issue. Here's what I changed. In header.php, I moved the following line of code from higher up to right before the </head>:
Code:
<?php if( $bfa_ata['html_inserts_header'] != '' ) include 'bfa://html_inserts_header'; ?>
If updating future versions of ATA so the inserts load after wp_head() is a possibility, then that would be great for me.

-Brad
  #2  
Old Feb 3, 2011, 08:09 PM
juggledad's Avatar
juggledad
 
22,382 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I've pass this on to Flynn
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Feb 20, 2011, 05:48 AM
Flynn's Avatar
Flynn
 
3,766 posts · Oct 2008
Munich, Germany
I've added this in 3.6.5, the next version after 3.6.4 which is in the WP viewer queue since 3 weeks now.
  #4  
Old Feb 20, 2011, 02:58 PM
BradBrown's Avatar
BradBrown
 
54 posts · Mar 2009
Thanks!

BTW-If anyone else is running into this, I realized there is another work-around rather than editing the ATA code. If you use the WP Minify plugin, it will load all the external javascript, including jquery, in one combined file that loads at the very top of the head.
  #5  
Old Mar 5, 2011, 12:19 AM
twola
 
27 posts · Sep 2009
Yup ran into the same issue.

Thanks for taking the time to document this.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
jQuery 1.4.2 --> 1.3.1, Problem? Factorfiction Plugins & Atahualpa 1 Jan 30, 2011 03:47 PM
[SOLVED] Ata version 3.5.3 (bfa_ata4) compatability issue with php version php 5.2.12 bettykin Atahualpa 3 Wordpress theme 4 Dec 6, 2010 11:53 AM
[SOLVED] Can't edit posts - edits vanish - Virus? Theme Issue? WP Issue? jfrenaye Atahualpa 3 Wordpress theme 1 Aug 4, 2009 08:14 AM
New to WP...Got Ata 3.3..?'s on Ata vs Montezuma and TOP THINGS TO CUSTOMIZE - FIX? Brasshatgroup New Versions, & Updating 5 Jun 1, 2009 07:22 AM


All times are GMT -6. The time now is 01:00 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.