Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

blank wp-admin page with Atahualpa 3.32 and WP 2.71


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Apr 13, 2009, 07:28 PM
wpuser
 
5 posts · Apr 2009
Hi all, my apologies in advance if this query has already come up:

Activating Atahualpa 3.32 on WP 2.71 stops me from seeing any of my wp-admin pages after logging in. Ie the next page to be shown is blank. the sit however is up and works fine with Atahualpa.

This is a brand new installation of WP 2.71 so only has the standard items installed, there are no modifications at all.

I can only get back into my wp-admin pages by renaming the Atahualpa folder in my themes folder so my installation defaults back to the standard theme.

I appreciate any help or guidance anyone can provide with this wp-admin problem, thanks!
  #2  
Old Apr 14, 2009, 07:14 AM
Flynn's Avatar
Flynn
 
3,754 posts · Oct 2008
Munich, Germany
Does this happen with other non-default themes, too?

Do you have spaces anywhere in the atahualpa theme directory such as /atahualpa 332/?

Did you upload the whole theme including the subdirectories such as /functions/, /js/ etc..?

Disable plugins one by one to see if a plugin is causing this.
  #3  
Old Apr 15, 2009, 05:29 AM
oLi303
 
3 posts · Apr 2009
Berlin, Germany
I have the same problem.
deactivating plugins has a random effect. means: it doesnt matter wich plugin i deactivate. sometimes after deactivating i can see the backend a while, but after adding more pages it happens again. also totally random switching to a default theme fixes it all. no name spaces and yes i uploaded all.
  #4  
Old Apr 15, 2009, 05:35 PM
Flynn's Avatar
Flynn
 
3,754 posts · Oct 2008
Munich, Germany
Perhaps you're running out of PHP memory. Does the error occur with all plugins turned off?
  #5  
Old Apr 16, 2009, 03:35 AM
wpuser
 
5 posts · Apr 2009
Hi, ive tried a number of other non standard themes, all work well, there is no space in the Atahualpa332 folder, and ive uploaded all of the required files and folders, finally I have no plugins activated at all.

how would I check if im running out of PHP memory?

thanks again for the assistance
  #6  
Old Apr 16, 2009, 04:19 AM
Flynn's Avatar
Flynn
 
3,754 posts · Oct 2008
Munich, Germany
You may have a blank line at the bottom of /wp-config.php (a Wordpress file, not Atahualpa) or /wp-content/themes/atahualpa/functions.php

I have no idea where this could be coming from if you didn't manually edit Atahualpa files.
  #7  
Old Apr 16, 2009, 06:00 AM
wpuser
 
5 posts · Apr 2009
yes there was a blank line at the end of the wp-config.php file which i removed but with no success. I have noticed that after activating Atahualpa the experiencing the wp-admin blank page, I then rename the Atahualpa332 folder which resets the site to the default theme, but then some items are missing from the wp-admin dashboard - recent comments, incoming links and plug ins. this is even when they are ticked to display under the screen options inthe top right of the wordpress dashboard screen. so not sure if this is related?

also I thought I would start again from the beginning - so I deleted all of the wordpress and Atahualpa files and folders and then I removed the database from my hosting account. then i created a new database, downloaded fresh copies of wp and Atahualpa, and ftp'ed them again. finally activating Atahualpa has the same problem. so I'm stumped :-(
  #8  
Old Apr 16, 2009, 04:13 PM
Flynn's Avatar
Flynn
 
3,754 posts · Oct 2008
Munich, Germany
And you aren't getting PHP error messages either? Perhaps you can turn on or let your host turn on PHP error notices to get some pointers. Do you have some special hosting setup like nginx or lighthttpd instead of Apache (although I am successfully running it on nginx)?

Try another browser too

Regarding PHP memory, you can see what you have by creating a file with this content

<?php phpinfo(); ?>

saving it as i.e. phpinfo.php, uploading it to yoursite.com/phpinfo.php and calling it in your browser. It'll list a lot of info of your PHP configuration including

memory_limit XX M

You can also try to increase the limit by adding this to the .htaccess file in your Wordpress root directory

php_value memory_limit 32M

But this might not work. You host's global settings may not allow to change something like this through htaccess. Call yoursite.com/phpinfo.php again to see if the memory_limit value has changed.

But if it's already at 32 MB then that should be sufficient for WP, Atahualpa and a good amount of plugins.

Last edited by Flynn; Apr 22, 2009 at 06:15 AM. Reason: Changed php_info() to phpinfo() and "might now work" to "might not work"
  #9  
Old Apr 18, 2009, 10:40 AM
oLi303
 
3 posts · Apr 2009
Berlin, Germany
My memory limit is set to 40M (1 und 1) same problem. what i found out now is: it only happens when i try to edit pages (there are lots of them). Editing/adding posts works pretty good.
  #10  
Old Apr 21, 2009, 08:35 AM
sintetik
 
3 posts · Apr 2009
Hi

I have the same problem. WP 2.3.3 and last Atahualpa 3.32 , site wrks property but admin panel is blank.
  #11  
Old Apr 21, 2009, 10:21 AM
sintetik
 
3 posts · Apr 2009
I've made some experiments, downloaded version 2.2 , 3.2 and tried them.
2.2 all OK
3.2 when I go on some admin pages I've got error - server not response, after 2-3 refresh I see the page.

tomorrow I'll try 3.3 and 3.3.1
  #12  
Old Apr 21, 2009, 04:47 PM
wpuser
 
5 posts · Apr 2009
Flynn, thanks for the sugegstions, but using the method to create a file containing <?php php_info(); ?> returns a blank page for me, so I cant shed any light on my available PHP memory.

Interesting to see that some others are experiencing the same type of problem. I will look at combining some older versions of WP and Atahualpa to see what happens as well.
  #13  
Old Apr 22, 2009, 06:16 AM
Flynn's Avatar
Flynn
 
3,754 posts · Oct 2008
Munich, Germany
Quote:
Originally Posted by wpuser
Flynn, thanks for the sugegstions, but using the method to create a file containing <?php php_info(); ?> returns a blank page for me, so I cant shed any light on my available PHP memory.

Interesting to see that some others are experiencing the same type of problem. I will look at combining some older versions of WP and Atahualpa to see what happens as well.
A typo, sorry, should have been <?php phpinfo(); ?>
I updated the post above.
  #14  
Old Apr 22, 2009, 11:19 AM
sintetik
 
3 posts · Apr 2009
problem solved by increasing memory for PHP up to 32Mb
  #15  
Old Apr 27, 2009, 12:48 AM
wpuser
 
5 posts · Apr 2009
Flynn, I adjusted that file and found out that I had 16MB of php memory, so I asked my web host to set my php memory to 32MB and looks like the problem is solved! I will keep an eye on it as I add more plugins and make mods over time, but for now, thanks for the advice!
  #16  
Old May 9, 2009, 04:08 PM
Flynn's Avatar
Flynn
 
3,754 posts · Oct 2008
Munich, Germany
I'll look into the PHP memory usage for the next version.

32 MB is fairly modest in my opinion but still... definitely want Atahualpa to run anywhere

I may have to break down the 25 theme option tabs into 25 real pages instead of loading them all at once as I do now (for speedier navigation between the menu sections).
  #17  
Old May 12, 2009, 06:58 AM
oLi303
 
3 posts · Apr 2009
Berlin, Germany
I solved the problem today with updating the host to php 5.x.x ( was a php 4.x.x before)
  #18  
Old Dec 23, 2009, 06:14 PM
jhofman
 
3 posts · Dec 2009
I'm experiencing a lot of blank pages and internal "500" errors, so this post was enlightening. My hosting is with 1and1, and in thier FAQs I found this:
Quote:
Can the memory usage limit be increased on shared hosting with a php.ini file?

Due to resource limits on our Shared Hosting machines, it is not possible to allocate more than 20M
of memory to PHP, although phpinfo() may report a higher number. You will be unable to increase
the memory usage limit with a php.ini file.
So I guess I'm screwed unless the Atahualpa options is broken down into more separate pages? I would seriously contribute money for some development on this. Atahualpa is an incredible tool!

Thank you, who ever you are!
  #19  
Old Dec 24, 2009, 04:41 AM
juggledad's Avatar
juggledad
 
21,982 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
You could always move to a host with better options
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #20  
Old Dec 24, 2009, 04:35 PM
jhofman
 
3 posts · Dec 2009
Turns out 1and1 actually DOES allow up to 40MB and I was able to change it with a simple php.ini file. I confirmed that I now have 40MB of memory, but I STILL get blank "pages" page in my admin when I try to run more than 5 plugins.
  #21  
Old Dec 25, 2009, 04:05 AM
juggledad's Avatar
juggledad
 
21,982 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
For what it's worth, I've read that while 1and1 seems to allow you to allocate more memory, your php.ini is overridden by the site - you never get more than the 20MB even though php thinks it can allocate more.

Now this may have changed, but...all your symptoms point to php memory problems
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #22  
Old Dec 25, 2009, 09:29 AM
jhofman
 
3 posts · Dec 2009
This is what they told me:

Quote:
The php memory in the shared hosting server has been increased already to 40MB. You need to create a php.ini file using any text editor in your local computer and place this code memory_limit = 40M; inside it in order to set the php memory to 40 in the server. It is our pleasure to assist you and your understanding is very much appreciated.
And using the phpinfo file described above, I concluded that I have 40MB available:

Quote:
memory_limit 40M 40M
I've got to get to the bottom of this!
  #23  
Old Dec 27, 2009, 06:05 AM
juggledad's Avatar
juggledad
 
21,982 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
can you install WP Security Scan (http://wordpress.org/extend/plugins/wp-security-scan/) and copy/paste the system info from the right hand side.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #24  
Old Jan 17, 2010, 10:30 AM
poe
 
1 posts · Jan 2010
Quote:
Originally Posted by jhofman
I'm experiencing a lot of blank pages and internal "500" errors, so this post was enlightening. My hosting is with 1and1, and in thier FAQs I found this:


So I guess I'm screwed unless the Atahualpa options is broken down into more separate pages? I would seriously contribute money for some development on this. Atahualpa is an incredible tool!

Thank you, who ever you are!
I have 1and1 as a host as well and was getting a blank Posts edit page (Ataualpa 3.4.5, WP 2.9.1). It ended up being that 1and1 uses php4.x.x instead of php5.x.x - see http://faq.1and1.com/scripting_langu...ted/php/9.html on how to direct your pages to utilize php5. Works like a charm now... (had nothing to do w/ memory - I have the same 40M on 1and1)
  #25  
Old Jan 31, 2010, 03:55 AM
ciprianmagda
 
1 posts · Jan 2010
thank you all for your great help! After few days of searching like 12 hours a day to solve this problem, I finally got here and solved my problem. It was a memory problem ideed! I had 12MB of memory alocated by default. First I tried the .htaccess solution and it didn't work. Then I found out that my provider offers up to 64M memory limit, so I created a php.ini file, just paste the code memory_limit = 40M; in it and uploaded it into the root of my website. Then checked the memory limit again and boom! It was 64M!! I logged it into my wordpress dashboard and it works just perfect now! So thanks again for you help! You guys saved my but!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
'read more' links to blank page Matt Pickut Excerpts, Read more, Pagination 10 Jul 13, 2009 01:41 PM
Show Left Sidebar ONLY on _ONE_ page (without keeping a blank space for others) sleizure Sidebars & Widgets 2 Jun 10, 2009 12:38 PM
Please help! I switched to Atahualpa, now important Admin pages have gone blank!!! change-junkie Atahualpa 3 Wordpress theme 1 Apr 23, 2009 08:33 AM
Categories admin page missing paulae Installing & running WordPress 14 Apr 1, 2009 10:03 AM
Blank pages TallyCast Atahualpa 3 Wordpress theme 2 Mar 5, 2009 12:32 PM


All times are GMT -6. The time now is 07:30 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.