Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

3.6.1 compatibility issue with All-in-one SEO pack


  #1  
Old Jan 13, 2011, 03:21 PM
flyboy's Avatar
flyboy
 
115 posts · Sep 2010
Found another bug - or I guess it's more of a compatibility issue than a bug.

In any case, Atahualpa 3.6.1 seems to ignore the All-in-one SEO pack's "Menu Label" option - it pulls the menu label from the post/page title instead.

I tried playing with plugin setting to make sure it's not All-in-one that's causing it, but it wasn't until I reverted to Atahualpa 3.5.3 that the issue was gone. Reverted back to 3.6.1 and it came back

Thanks JD and Flynn for posting updates so quick. You guys are like superheros

Last edited by flyboy; Jan 13, 2011 at 09:10 PM.
  #2  
Old Mar 15, 2011, 09:18 AM
sjedwardz
 
13 posts · Jan 2010
Reading Berkshire
I just found that one when upgrading to 3.6.4!! I've had to revert back to previous version - and that was after sorting out the suhosin problems
  #3  
Old Mar 15, 2011, 01:53 PM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
When you talk about the menu label, are you using a WordPress menu or the Atahualpa menu?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Mar 16, 2011, 12:48 PM
flyboy's Avatar
flyboy
 
115 posts · Sep 2010
Atahualpa menu. Haven't tried the WP menu
  #5  
Old Mar 16, 2011, 04:40 PM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
where is the 'All-in-one SEO pack's "Menu Label" option'?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Mar 16, 2011, 10:44 PM
flyboy's Avatar
flyboy
 
115 posts · Sep 2010
It only appears on pages, it's not available on posts (red thing in the screenshot below)

Thanks for looking into this


Last edited by flyboy; Mar 23, 2011 at 10:36 AM.
  #7  
Old Mar 17, 2011, 06:19 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Duh - I was looking in the ALL in One settings...
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Mar 17, 2011, 11:33 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Ok, I looked into this and it's actually a problem with All in One.

Atahualpa calls the WordPress function wp-list-pages. This function 'Displays a list of WordPress Pages as links' depending on the options that are passed to it. Starting in 3.6.1, Atahualpa started using the link_before (Sets the text or html that precedes the link text inside <a> tag.) and the link_after (Sets the text or html that follows the link text inside <a> tag.) to add a '<span>' and '</span>' before and after the page name.

All in One hooks into 'wp_list_pages' and looks for a string to replace. It can not handle substituting it's page title when the 'link-before' and 'link_after' are used as it's code is currently written. this is a flaw with the All in one code.

If you wish, you can edit bfa_hor_pages.php and change line 6 and remove the code
HTML Code:
&link_before=<span>&link_after=</span>
you will have to do this until someone reports this to 'All In One' and they fix their code.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Mar 23, 2011, 10:34 AM
flyboy's Avatar
flyboy
 
115 posts · Sep 2010
Thanks JD, I'll make a report

Bookmarks

Tags
all in one seo pack, atahualpa 3.6.1, compatibility

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Site Plugin Problem All in One SEO Pack Data couponblazer Installing & running WordPress 1 Nov 10, 2010 06:08 AM
Compatibility with wordpress MU quixysfrance New Versions, & Updating 4 Aug 3, 2010 06:16 AM
Platinum SEO / Frontn Page Description Issue gcarson Plugins & Atahualpa 1 Jan 24, 2010 01:45 PM
[SOLVED] Newbie question - SEO plug ins and Atahualpa built in SEO jkgourmet Plugins & Atahualpa 1 Sep 26, 2009 04:33 PM
All In One SEO PACK Not show in Post new rudianaeva Plugins & Atahualpa 3 Mar 30, 2009 11:58 PM


All times are GMT -6. The time now is 09:40 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.