Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

moved from MAMP to live server, problems with atahualpa351 theme not working


  #1  
Old Jan 6, 2011, 07:28 AM
chowders
 
8 posts · Nov 2010
Problems occurred after moving website from local server.

Get this error on the dashboard:

Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/seniecom/public_html/wordpress/wp-includes/theme.php on line 513

If i try to edit the theme, it says it's broken, can't locate where the files are & it can't find the stylesheet. If i click on the theme it completely breaks and i get a blank page.

Don't know what error means or what to do about it? (this is my first wordpress site)

Website working fine on local host. I have disabled all the plug-ins except the gallery.

I'm using:
atahualpa351

Here's a link to the website: http://seniseneviratne.com/wordpress/
and a couple of the pages:
http://seniseneviratne.com/wordpress/?page_id=189
http://seniseneviratne.com/wordpress/?page_id=269

Can anyone help?
  #2  
Old Jan 6, 2011, 08:06 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what happens if you switch to the twenty-ten theme?
did you 'move' the site from the local server or do a new install?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jan 6, 2011, 08:22 AM
chowders
 
8 posts · Nov 2010
Have changed it to twentyten ok.

Now not able to change it back to Atahualpa (attached screenshot of problem before changing to twentyten).

To move to live server:
I ftp my existing wordpress folder.
I made new database and then imported existing database.

Last edited by chowders; Jan 7, 2011 at 05:51 AM.
  #4  
Old Jan 6, 2011, 08:27 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
did you change the url references in the sql from your local server to the live url?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Jan 6, 2011, 09:14 AM
chowders
 
8 posts · Nov 2010
I changed the url in dashboard/settings before i exported the database (mainly because i looked into changing it in phpMyAdmin but couldn't work out how to do it)

attached: wp_options in database

Is this the right URL?
Attached Thumbnails
Click image for larger version

Name:	Picture 22.png
Views:	404
Size:	62.1 KB
ID:	1002  
  #6  
Old Jan 6, 2011, 10:18 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
It looks like you have n install problem, something is missing. Check to see if in the atahualpa theme folder you have all the files - I note that there is a message in your first image that says the style sheet is missing - so make sure that 'style.css' exists

If I were you, I'd just delete the atahualpa theme folder, download a new copy and install it manually (see - http://forum.bytesforall.com/showthread.php?t=8520)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Jan 7, 2011, 05:52 AM
chowders
 
8 posts · Nov 2010
Hi,
theme working fine now, thanks.

Just wondering if you can help with the linking problem?
:
If i set the permalinks to default the site doesn't link using www.seniseneviratne.com
(you have to put /wordpress)

If i set them to anything else (see attached) i get - page not found

any thoughts?
Attached Thumbnails
Click image for larger version

Name:	Picture 23.png
Views:	390
Size:	54.1 KB
ID:	1008  
  #8  
Old Jan 7, 2011, 06:35 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
the .htaccess file has to be writable by wordpress - go look at http://codex.wordpress.org/Using_Permalinks
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Update blog theme: windows live writer bsekula Forum How-To 2 Oct 2, 2010 11:12 AM
[SOLVED] Atahualpa not working on Windows server? paulc Installing & running WordPress 4 Jun 11, 2010 06:20 PM


All times are GMT -6. The time now is 08:49 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.