Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

After latest update, can't see templates


  #1  
Old Apr 3, 2009, 08:02 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I have upgraded to the very latest version, and now when I'm creating or editing, I do not see my custom templates in the drop-down list. They are in the correct folder, I believe. http://www.skilovers.com/ftpcap.jpg

Is there code elsewhere that I didn't update? I don't recall having to modify anything before to get these to show up.
  #2  
Old Apr 4, 2009, 04:27 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
All your template files have other file permissions (read/write - read - read, 644) than the other PHP theme files (read/write/execute - Read/execute - read/execute, 755). http://www.december.com/unix/ref/chmod.html

Normally 644 should be sufficient, but that may depend on other settings on the web server as well. Perhaps the template files have another owner (i.e.because you uploaded them with another FTP account than the default theme files)

I'd either give the template files a 755 file permission as well, or if their owner is different, change their owner to the owner of the other files. This would be done through the SSH (which on a virtual account you won't have) "chown" command, or by uploading them through the same FTP account the other theme files were uploaded with.
  #3  
Old Apr 4, 2009, 04:35 PM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I doubt that's it; they are all 644 for old Atahualpa too, and they work fine that way.
  #4  
Old Apr 5, 2009, 03:54 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
The top of index.php has changed significantly in 3.3

You'll probably need to re-create your templates, at least the upper part, to include line 1-72 from index.php, everything above <?php get_header(); ?>
  #5  
Old Apr 5, 2009, 04:03 PM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Ah. Makes sense. I'll do that and let you know. Many thanks.

It's too nice outside for me to sit here cogitating any further! Later..

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Latest Comment From Each Post on Homepage And Multi-page pages noyell Post-Kicker, -Byline & -Footer 3 Aug 8, 2009 01:39 PM
Templates viscouse Atahualpa 3 Wordpress theme 2 Jun 12, 2009 10:59 AM
Using my own templates nickcee Atahualpa 3 Wordpress theme 1 May 16, 2009 06:56 PM
Update rmribeiro New Versions, & Updating 1 May 13, 2009 07:19 PM
Update to latest version - will it break? bergonzzi New Versions, & Updating 1 Jan 28, 2009 04:21 PM


All times are GMT -6. The time now is 11:09 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.