Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Post-Kicker, -Byline & -Footer »

%comments in footer stopped working


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Mar 31, 2009, 12:14 PM
Dimitre
 
2 posts · Mar 2009
Hello,

I was using this theme with no problems till last update (Athalualpa 3.3.1). When I installed the new version the following problem occurred: parameter %comments stopped working in FOOTER: Single Post Pages. It works in FOOTER: Homepage /with multi posts/. It also works when I switch to the previous version.


Any help from the author will be greatly appreciated.

Last edited by Dimitre; Mar 31, 2009 at 01:06 PM.
  #2  
Old Mar 31, 2009, 07:45 PM
Flynn's Avatar
Flynn
 
3,754 posts · Oct 2008
Munich, Germany
I had not thought about this but it's a result of the new bfa_postinfo.php

I changed bfa_postinfo.php to use simple Wordpress template tags now instead of the lower-level functions that I had built myself in earlier versions.

Now, with the default Wordpress functions, the default WP behavior (no comments link on single post pages) is being applied as well, leading to the result you describe. The advantage of the new way bfa_postinfo.php is written is that plugins can hook into the post info items and do something with them. Translation/multi-language plugins needs this, for instance.


Since a comment link on a single post page would be a jump to a named anchor on the same page rather than a "real link" it would probably be better accomplished with

At Post/Page Info Items -> FOOTER: Single Post Pages
HTML Code:
<a href="#commentform">Write a comment</a>
And right above the jump target, i.e. right above the comment form, in comments.php, add

HTML Code:
<a name="commentform"></a>
  #3  
Old Apr 24, 2009, 06:40 PM
duping812
 
12 posts · Feb 2009
I tried to add <a href="#commentform"> in the footer for single post pages, but I think it conflicts with my permalinks. The href value changes to "\commentform". Could you tell me why?

here is my test page,
http://thdp.org/tech/website/useful-flickr-tools
  #4  
Old Feb 20, 2010, 05:37 PM
adum's Avatar
adum
 
85 posts · Jun 2009
I'm having this problem to. The issue is that # is converted to \ because it is used an escape for some letters. There has got to be some way to turn that off, I'm not sure how though.
  #5  
Old Feb 21, 2010, 12:36 PM
juggledad's Avatar
juggledad
 
21,944 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
see the solution I just posted in http://forum.bytesforall.com/showthread.php?t=5199
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ordered lists in comments not working nikkidev Comments, trackbacks & pings 8 May 24, 2010 10:05 AM
[SOLVED] Applying Customizations Stopped Working CocteauBoy Atahualpa 3 Wordpress theme 2 Jun 8, 2009 04:48 PM
Post Footer not working right Steve_T Atahualpa 3 Wordpress theme 7 May 22, 2009 11:14 AM
The %date-modified('F jS, Y')% in post footer not working Glottis Post-Kicker, -Byline & -Footer 11 Apr 11, 2009 04:52 AM
Default Comments Feed not working Navi RSS, Feeds & Subscribing 3 Jan 28, 2009 05:02 PM


All times are GMT -6. The time now is 07:02 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.