Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

Site's down, big problems!


  #1  
Old Aug 10, 2009, 01:59 PM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
When I go to http://www.larchmontgazette.com, I get this:
Couldn't write to: /usr/home/web/users/a0018537/html/wp27/wp-content/cache/wp-cache-0e79298b0262d76e1f72cdea21a8a587.html

What on earth?

Something has been wrong for a while now, but at least the site was working from the browser. Uploading an image was not working; I was getting the full path to the image, not the usual media library view of it. And a widget stopped working too. I can't even show you what was not working now because the site seems totally screwed up.

Please, Flynn or Juggledad, help!
  #2  
Old Aug 10, 2009, 02:05 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Can you login at /wp-admin/ ?

Disable WP-Cache, looks like it cannot write its cached files to the harddrive anymore. This should not be caused by Atahualpa, it could be a physical harddrive problem, or a permission problem, but something must have changed the permission for that directory or file then, if it worked before
  #3  
Old Aug 10, 2009, 02:13 PM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I just got an email from the hosting company. Apparently we are over our disk space limit, but why they didn't warn us first, I don't know. I told them to just fix it.

I doubt this is the cause of our other problems, though. I will check back in when we are up and running again.

UPDATE:

OK, we are up and running. Whew!

The photo upload problem seems OK now too.

However, the widget for the Garden Guide still wasn't working properly, but it had been before a few days ago. The Recently in Garden Guide list was appearing on the front page, but it should appear only on Garden Guide articles. I just redid the widget (using a combination of Category Posts and Widget Logic), and now it's OK again. I'm mystified. The Widget Logic code, by the way:
Code:
is_category('Garden Guide') OR in_category('Garden Guide')
.

So I guess things are OK, but it was not fun there for a while!

Thanks, Flynn.

Last edited by paulae; Aug 10, 2009 at 02:25 PM.
  #4  
Old Aug 10, 2009, 02:47 PM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Update to the update:

Well, this is odd. Now the Garden Guide widget is misbehaving again, showing up on the front page, even though the Widget Logic code still looks fine. Totally mystifying.
  #5  
Old Aug 11, 2009, 03:36 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Try explicitly adding "not on the front page" to the Widget Logic code

!is_front_page AND ( is_category('Garden Guide') OR in_category('Garden Guide') )
  #6  
Old Aug 11, 2009, 06:29 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Did you mean I should use the parentheses in red? That removes the widget from the front page but also removes it from the Garden Guide section. Using this code without those parentheses has no effect.

I've left it with the parentheses at the moment.
  #7  
Old Aug 11, 2009, 06:51 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
UPDATE:

OK, this version, which I cadged from the plugin page at WP.org, seems to work:

Code:
is_category('Garden Guide') OR is_single() && in_category('Garden Guide')
What's odd is that for the other categories for which I want to do the same thing, the old code seems to still work, keeping that category's recent posts list off the front page but on the category page and all single posts in that category:
Code:
is_category('Teen Health') OR in_category('Teen Health')
I guess the PHP syntax is flexible? But why did the Garden Guide post list start showing up on the front page, when the others did not?

Last edited by paulae; Aug 11, 2009 at 06:54 AM.
  #8  
Old Aug 11, 2009, 08:21 AM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
HTML Code:
is_category('Garden Guide') OR in_category('Garden Guide')
is_category('Garden Guide') will be true if the PAGE is the archive page for 'Garden Guide'. in_category('Garden Guide') will be true if the POST is in the category 'Garden Guide'

so if you were on the home page and it's not a Category Archive page, the first part is false,
but if there was a post that was in the 'Garden Guide' the second part is TRUE so the action takes place

as for the new code, you should use another set of parentheses to make sure it acts the way you want. Becasue of precedence, the && will be first, then the OR. The way it is right now, the statement will be true if you are on a single page and the post has a category of 'Garden Guide'. It will also be true if you are on a category archive page for the category of 'Garden Guide'.

My take is that if a post that was in the category 'Garden Guide' appeared on the front page, the widget logic said TRUE, so it displayed the widget.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Aug 11, 2009, 08:33 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Ah. I will have to learn more about this, obviously.

EDIT:

But I don't quite understand.....there is an excerpt of a post in Garden Guide on the front page. There are excerpts of many posts from many categories on the front page, yet the other widget logic code wasn't producing rogue lists in the left sidebar for those categories.

Last edited by paulae; Aug 11, 2009 at 09:11 AM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Big Gap Between Header and body copy - How do I get rid of it? targetzero Post-Kicker, -Byline & -Footer 5 Aug 18, 2009 02:09 PM
Help! Big Security Uh Oh! OneSister Atahualpa 3 Wordpress theme 11 Jun 30, 2009 06:03 AM
[SOLVED] How do I change the font for the big title at the top in the header? AlanaBay Header configuration & styling 1 Jun 5, 2009 12:09 PM
[SOLVED] IE 8 doesn't like my site: PHP problems? bcorrigan New Versions, & Updating 3 May 1, 2009 10:14 AM
Big gap before my table renders shilldiy Atahualpa 3 Wordpress theme 4 Apr 14, 2009 02:40 AM


All times are GMT -6. The time now is 11:42 PM.


Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.