Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating » Old Version fixes and change logs »

BUGFIX 364-02: CSS Compression does not happen if 'Allow debugging?' is 'Yes'


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Feb 8, 2011, 07:51 AM
juggledad's Avatar
juggledad
 
22,315 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
NOTE: This fix is not needed if you apply BUGFIX 364-03 since it is included in that fix.
UPDATED 2/27/11 - was missing some code change at the end - the ZIP file reflects the additional changes

Thanks to mdmower for noticing this

(note: this is NOT a critical fix it is cosmetic)

Due to changes in the code in 3.6.x, if you set the 'ATO->Configure CSS & JS->Configure CSS & JS' option to 'Yes', the 'CSS: Compress' option will be ignored.

To fix this, edit CSS.php and find line 11 which should be
HTML Code:
!( isset($bfa_ata_debug) AND $bfa_ata['allow_debug'] == "Yes" ) ) {
and change it to
HTML Code:
!( $bfa_ata_debug == 1 AND $bfa_ata['allow_debug'] == "Yes" ) ) {
change lines 944-951 from
HTML Code:
if ( $bfa_ata['css_compress'] == "Yes" AND 
!( isset($bfa_ata_debug) AND $bfa_ata['allow_debug'] == "Yes" ) ) {
	ob_end_flush();
}	
if ( isset($bfa_ata_preview) OR $bfa_ata['css_external'] == "Inline" OR 
( isset($bfa_ata_debug) AND $bfa_ata['allow_debug'] == "Yes" ) ) {
	echo "</style>\n"; 
}
to
HTML Code:
if ( $bfa_ata['css_compress'] == "Yes" AND 
!( $bfa_ata_debug == 1 AND $bfa_ata['allow_debug'] == "Yes" ) ) {
	ob_end_flush();
}	
if ( isset($bfa_ata_preview) OR $bfa_ata['css_external'] == "Inline" OR 
( $bfa_ata_debug == 1 AND $bfa_ata['allow_debug'] == "Yes" ) ) {
	echo "\n</style>\n"; 
}
or you can replace CSS.PHP with the attached version which has the change applied.
Attached Files
File Type: zip css.php.zip (17.2 KB, 442 views)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Mar 5, 2011 at 04:24 AM.
  #2  
Old Feb 9, 2011, 10:21 AM
lbleier
 
1 posts · Jan 2011
I had high hopes for this but it didnt work. Im still getting this errror:

http://www.shelememorial.com/bug.png
  #3  
Old Feb 9, 2011, 10:39 AM
runnerb0y
 
67 posts · Nov 2010
Your site is displaying perfectly for me. I'm using IE and FireFox.
  #4  
Old Feb 9, 2011, 12:47 PM
juggledad's Avatar
juggledad
 
22,315 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
lbleier - you have a different issue, do a forum search on 'suhosin'
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Feb 13, 2011, 05:25 PM
KatyDigg's Avatar
KatyDigg
 
318 posts · Jul 2009
Thank you, Juggledad

Much appreciated.
__________________
UniServer | WP 4.0 | ThemeFrame 1.2.6 | Montezuma 1.2.3 | ATA 3.7.18
  #6  
Old Feb 27, 2011, 12:42 AM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
BUGFIX 364-02 in css.php line 11 breaks the zebra striping in tables. (No alternate stripes)

Zebra striping works fine with the former code.
  #7  
Old Feb 27, 2011, 04:39 AM
juggledad's Avatar
juggledad
 
22,315 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
The Zebra striping works fine with the new version.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Feb 27, 2011, 11:38 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
Quote:
Originally Posted by juggledad
The Zebra striping works fine with the new version.
Thanks juggledad, my zebras are back with the new code!

LAN
  #9  
Old Mar 4, 2011, 04:11 PM
KatyDigg's Avatar
KatyDigg
 
318 posts · Jul 2009
Implemented

Quote:
Originally Posted by juggledad
UPDATED 2/27/11 - was missing some code change at the end - the ZIP file reflects the additional changes

or you can replace CSS.PHP with the attached version which has the change applied.
Attachment 1191

and I now have the following.....



<style type="text/css"><br>/*=========================================<br>isse t($bfa_ata_debug)=1<br>$bfa_ata_debug=<br>======== =================================<br>*/body{text-align:center;margin:0;padding:0;font-family:verdana,arial,sans-serif;font-size:13px;line-height:1.4;color:#333333;background:#0B3861;paddin g-top:20px;padding-bottom:20px}a:link,a:visited,a:active{color:#24006 B;font-weight:bold;text-decoration:none;}a:hover{color:#468F30;font-weight:bold;text-decoration:underline}ul,ol,dl,p,h1,h2,h3,h4,h5,h6{ margin-top:10px;margin-bottom:10px;padding-top:0;padding-bottom:0;}ul ul,ul ol,ol ul,ol ol{margin-top:0;margin-bottom:0}code,pre{font-family:"Courier New",Courier,monospace;font-size:1em}pre{overflow:auto;word-wrap:normal;padding-bottom:1.5em;overflow-y:hidden;width:99%}abbr[title],acronym[title]{border-bottom:1px dotted}hr{display:block;height:2px;border:none;mar gin:0.5em auto;color:#cccccc;background-color:#cccccc}table{font-size:1em;}div.post,ul.commentlist li,ol.commentlist li{w


In Page Source View.......

and Now W3C Validation shows 13 <br>isset($bfa_ata_debug)=1<br>$bfa_ata_… Errors

What's happening
__________________
UniServer | WP 4.0 | ThemeFrame 1.2.6 | Montezuma 1.2.3 | ATA 3.7.18

Last edited by KatyDigg; Mar 4, 2011 at 04:26 PM.
  #10  
Old Mar 4, 2011, 04:26 PM
KatyDigg's Avatar
KatyDigg
 
318 posts · Jul 2009
BODY STYLE background colors are now (having only recently, today, created new STYLE site!) disabled and the font sizes have changed - reduced!!!!

All was fantastic - until uploaded and installed the above css.php.zip


The BODY STYLE background colors now remain void.
__________________
UniServer | WP 4.0 | ThemeFrame 1.2.6 | Montezuma 1.2.3 | ATA 3.7.18

Last edited by KatyDigg; Mar 4, 2011 at 04:46 PM.
  #11  
Old Mar 4, 2011, 05:32 PM
KatyDigg's Avatar
KatyDigg
 
318 posts · Jul 2009
In the meantime, I have restored back to previous ATA 3.5.3. version and then deleted 3.6.4.

Re-installed 3.6.4.

Voila!!

Back to "normal"

All in a jiffy

I won't be re-installing this css.php fix
__________________
UniServer | WP 4.0 | ThemeFrame 1.2.6 | Montezuma 1.2.3 | ATA 3.7.18
  #12  
Old Mar 5, 2011, 04:21 AM
juggledad's Avatar
juggledad
 
22,315 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I bad , that was caused by some debugging code I forgot to take out (sigh). I've removed it and this fix should be good. Not if you apply BUGFIX: 365-03 you don't need to apply this one since 365-03 includes this fix (and there is no debugging code in it )
Thanks Berean for picking up on that.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Mar 5, 2011 at 04:25 AM.
  #13  
Old Mar 5, 2011, 05:00 PM
KatyDigg's Avatar
KatyDigg
 
318 posts · Jul 2009
Quote:
Originally Posted by juggledad
I bad , that was caused by some debugging code I forgot to take out (sigh). I've removed it and this fix should be good. Not if you apply BUGFIX: 365-03 you don't need to apply this one since 365-03 includes this fix (and there is no debugging code in it )
Thanks Berean for picking up on that.

Thanks, Juggledad, I will take a look at 364-03
__________________
UniServer | WP 4.0 | ThemeFrame 1.2.6 | Montezuma 1.2.3 | ATA 3.7.18

Last edited by KatyDigg; Mar 6, 2011 at 11:22 AM. Reason: 364-03

Bookmarks

Tags
ata 3.6.4, compression

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
BUGFIX 360-01: errors after upgrading to 3.6 juggledad Old Version fixes and change logs 30 Apr 14, 2011 09:12 PM
BUGFIX 364-01: “Title tags in Category Menu Bar” fails to remove muti-line title juggledad Old Version fixes and change logs 2 Feb 10, 2011 04:47 PM
BUGFIX: 3.4.9 Excerpt length not working properly? Kadin Excerpts, Read more, Pagination 14 Oct 28, 2010 10:38 AM
Ran WebSiteOptimization Analysis, Results-"Compression?" Craig Mattice Atahualpa 3 Wordpress theme 0 Mar 26, 2010 09:38 AM
[SOLVED] BUGFIX - 343/344 - COMMENTS FEED ICON area of the css.php has an error juggledad Old Version fixes and change logs 0 Oct 15, 2009 03:54 PM


All times are GMT -6. The time now is 06:19 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.