Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

Mouseover Hover CSS problem IE8


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Dec 3, 2009, 10:12 AM
Ber|Art's Avatar
Ber|Art
 
198 posts · Oct 2009
Europe (NL) ber-art.nl Windows 7x64 WP 3.x Atahualpa 3.7.x
Send a message via Skype™ to Ber|Art
Search Mouseover Hover CSS problem IE8

When I hover over the page menu bar (up and down) in Firefox 3.5 everything is fine, when I do this with IE8 I see empty submenus (so just the backgroud color)? How can I solve this (see for yourself on www.incotrust.be ) I am using WP 2.8.6 and Atahualpa 3.4.4.
  #2  
Old Dec 4, 2009, 10:29 AM
Ber|Art's Avatar
Ber|Art
 
198 posts · Oct 2009
Europe (NL) ber-art.nl Windows 7x64 WP 3.x Atahualpa 3.7.x
Send a message via Skype™ to Ber|Art
Anybody knows the sollution?
  #3  
Old Dec 7, 2009, 12:36 AM
Ber|Art's Avatar
Ber|Art
 
198 posts · Oct 2009
Europe (NL) ber-art.nl Windows 7x64 WP 3.x Atahualpa 3.7.x
Send a message via Skype™ to Ber|Art
Anybody any Idea?
  #4  
Old Dec 11, 2009, 08:16 AM
Ber|Art's Avatar
Ber|Art
 
198 posts · Oct 2009
Europe (NL) ber-art.nl Windows 7x64 WP 3.x Atahualpa 3.7.x
Send a message via Skype™ to Ber|Art
*bump* ...
  #5  
Old Jan 5, 2010, 02:23 AM
Ber|Art's Avatar
Ber|Art
 
198 posts · Oct 2009
Europe (NL) ber-art.nl Windows 7x64 WP 3.x Atahualpa 3.7.x
Send a message via Skype™ to Ber|Art
I tried to deactivate all plugins but still the problem stay's in IE8, Somebody any idea? I want to pay for the sollution!
  #6  
Old Jan 5, 2010, 05:11 AM
juggledad's Avatar
juggledad
 
22,250 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Wow, that is weird. When I look at the menu's sometimes they show up and other times they are blank until I mouse over them, then the text shows up. And on when I mouse over 'Onze Diensten' I see the submenu filled in, but I also see the sub sub menu all blank, but it's not always the submenu for 'Financle Planning' sometimes it's for "Accountancy'! but then I'll go back and they work
----
pause
----
ok, I just got thru ripping out code till I found the culprit - edit css.php and fine this CSS
HTML Code:
*:first-child+html ul.rMenu-ver > li	/* hide from IE5.0 because 
										it gets confused by this 
										selector */
	{
	width: 100%;
	float: left;
	clear: left;		/* same as previous rule set except this is
				   for IE7 and the direct child selector 
				   make inheritence much easier and obvious */
	}
remove it and see if the problem goes away. I think this will fix the IE8 issue, not sure what it might do to previous releases though...
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Jan 5, 2010, 05:20 AM
Flynn's Avatar
Flynn
 
3,765 posts · Oct 2008
Munich, Germany
Sorry for the delay, I had tried and couldn't solve it. I suggest doing away with the menu and using the much easier code below. The menu currently used in Atahualpa is one of the hardest pieces of CSS ever, I will replace it with the code below in one of the next versions.

Add this at Style & Edit Header Area -> Configure Header Area

PHP Code:
<div id="hormenu" class="clearfix">
    <ul id="nav">
        <?php wp_list_pages('title_li='); ?>
    </ul>
</div>
and remove %pages from there

For more wp_list_pages parameters see http://codex.wordpress.org/Template_Tags/wp_list_pages


Add CSS as CSS Insert:


div#hormenu {
background: #666666; /* menu bar background */
}

ul#nav, ul#nav ul {
float: left;
list-style: none;
line-height: 1;
padding: 0;
margin: 0;
}

ul#nav li a {
display: block;
text-decoration: none;
}

ul#nav li {
float: left;
padding: 0;
}

ul#nav ul {
position: absolute;
left: -999em;
height: auto;
width: 150px; /* width of submenus */
}

ul#nav ul ul {
margin-left: 149px; /* same as width of submenus, or -1px if you have borders, to avoid 2 x 1px borders side by side adding up to a 2 px border */
margin-top: -28px; /* adjust to move submenus up/down a bit so the submenu's top border lines up with the parent LI's top border */
}

ul#nav ul li {
width: 100%;
}

ul#nav ul li a {
width: auto;
}

ul#nav li a {
color:#ffffff;
padding: 4px 5px;
background: #666666; /* tab background */
font-weight: bold;
}

ul#nav li a:hover,
ul#nav li.current_page_item a {
background: #E68B04; /* tab hover and current background */
color: #000000;
}


/* Hide/show submenus */

ul#nav li:hover ul ul,
ul#nav li:hover ul ul ul,
ul#nav li.sfhover ul ul,
ul#nav li.sfhover ul ul ul {
left: -999em;
}

ul#nav li:hover ul,
ul#nav li li:hover ul,
ul#nav li li li:hover ul,
ul#nav li.sfhover ul,
ul#nav li li.sfhover ul,
ul#nav li li li.sfhover ul {
left: auto;
}
  #8  
Old Dec 13, 2009, 01:09 AM
Ber|Art's Avatar
Ber|Art
 
198 posts · Oct 2009
Europe (NL) ber-art.nl Windows 7x64 WP 3.x Atahualpa 3.7.x
Send a message via Skype™ to Ber|Art
Help Mouseover (Hover) Page Menubar CSS problem IE8

See: http://forum.bytesforall.com/showthread.php?t=4698

Can someone help me with this?
  #9  
Old Dec 16, 2009, 09:48 AM
Ber|Art's Avatar
Ber|Art
 
198 posts · Oct 2009
Europe (NL) ber-art.nl Windows 7x64 WP 3.x Atahualpa 3.7.x
Send a message via Skype™ to Ber|Art
I want to pay for the solution!
  #10  
Old Jan 5, 2010, 02:19 AM
Ber|Art's Avatar
Ber|Art
 
198 posts · Oct 2009
Europe (NL) ber-art.nl Windows 7x64 WP 3.x Atahualpa 3.7.x
Send a message via Skype™ to Ber|Art
Still nobody has any idea?

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] problem with hover effect in anchor link destination hiccupgirl Atahualpa 3 Wordpress theme 1 Oct 16, 2009 06:25 PM
IE8 and FF3.5 difference Ber|Art Header configuration & styling 1 Oct 13, 2009 07:50 AM
CSS problem beneath Post Title JakeThePeg Post-Kicker, -Byline & -Footer 0 Sep 9, 2009 05:54 AM
Is 3.4 CSS problem resolved? lhanft New Versions, & Updating 1 Jul 10, 2009 08:18 PM
[SOLVED] Problem with code in HTML/CSS Inserts xavison Post-Kicker, -Byline & -Footer 4 Jun 26, 2009 11:59 AM


All times are GMT -6. The time now is 08:28 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.