Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Center area post/pages (http://forum.bytesforall.com/forumdisplay.php?f=32)
-   -   Images stick out side of box, only when captioned (http://forum.bytesforall.com/showthread.php?t=13355)

mad_science Mar 17, 2011 03:39 PM

Images stick out side of box, only when captioned
 
I have my "large" image size set at 720 wide, but if one ads a caption, they get this:
http://hooniverse.com/wp-content/upl...ge-overrun.jpg

Note that the right side of the image is sticking out of the div box. This happens even with the default settings on from ATA 3.5.3 (which I'm currently using). I have no other custom/funky css or styling going on.

If I pull the image size down to 700, it doesn't overrun.

[Major edit to clarify:]
It seems no matter what I put for padding the Images in Posts:Caption Style box to affect the width of the padding around the image, it never gets narrower than about 4 or 6 px, even if I set the border down to 1px.

So, there are two issues, which I'm sure are related...the overrun if pictures are big and the fact that the contents of the styling box for images in posts doesn't quite work right.

owc May 12, 2011 04:30 AM

1 Attachment(s)
I have a similar problem as described in the screenshot:
Attachment 1352

juggledad May 12, 2011 06:05 AM

if you switch to the twenty-ten theme, does the issue still exist?

owc May 12, 2011 06:29 AM

yes, same issue here. the caption is styled 10px larger then the image. so this is a global wordpress setting? or how to change that behaviour?

juggledad May 12, 2011 06:41 AM

If it happens in twenty-ten, then it's not an Atahualpa issue.

owc May 12, 2011 06:53 AM

so it isn't possible to style the caption with atahualpa neither?

owc May 12, 2011 08:18 AM

This one does the job...
Under ATA > Style Images > Caption Text: Style, I have set:
Code:

margin: 0 10px 0 0;
I'm not sure if it is the cleanest solution, but for me it works out.

kdawes01 Mar 13, 2012 04:12 PM

I had the same problem and saw in Firebug that WordPress was putting in a .wp-caption max-width value of 96%. Seemed odd to me, so in the ATA CSS Inserts I put...

.wp-caption {max-width: none; }

Took care of the problem for me!

Ken


All times are GMT -6. The time now is 10:07 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.