Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Excerpts, Read more, Pagination (http://forum.bytesforall.com/forumdisplay.php?f=20)
-   -   Older Entries Link from Homepage gives CSS code in IE/Safari instead of page 2 (http://forum.bytesforall.com/showthread.php?t=14522)

soamelt Jun 7, 2011 12:07 AM

Older Entries Link from Homepage gives CSS code in IE/Safari instead of page 2
 
when i click "older entries" from my homepage in safari instead of .../page/2/ it goes to: /page/2/?bfa_ata_file=css which just gives a page of code instead of rendering the site.
i don't have IE but i'm being told it's not working in IE either.

firefox works properly.
manually typing in .../page/2 works fine.

i'm using Atahualpa 3.5.1 and wordpress 3.1.1

the site is: http://craziestgadgets.com

thank you

juggledad Jun 7, 2011 03:52 AM

when did this start happening?
What did you change?

it happens in FireFox and Safari on the MAC.

Do you have all BUGFIX's for your version applied? (they can be found in the 'New Version & Updates' forum and sub forum)
--if not. apply them before we go any further and re-test

You might want to upgrade - do it manually so you can swap between versions

soamelt Jun 7, 2011 07:55 AM

checking my Google Analytics, there's a steep dropoff on "page 2" views exactly when i installed the theme about a month back. it's always worked fine on my own computer (mac/ff) so i never noticed the issue.

After trying and untrying a few things, and comparing this to my other sites which work fine with the theme, I switched the CSS from external to inline which fixed the issue (although it's slightly less than ideal).

The amount of bugfixes between my version and the current one is pretty daunting, I wouldn't even know where to begin and I'm hesitant to upgrade for now until 3.6.8 is out, as I have php in the theme settings and multiple sites.

Thanks for your response above. Above issue aside, I love the theme and the customizability.

awilder Oct 31, 2011 10:22 AM

We've been experiencing this problem, too. Running Atahualpa 3.7.1 on Wordpress 3.2.1.

The "Newer Entries" and "Older Entries" on the home page are intermittently linking to:
Code:

http://www.100daysofrealfood.com/page/2/?bfa_ata_file=css
or
Code:

http://www.100daysofrealfood.com/page/2/?bfa_ata_file=js
Rather than just:
Code:

http://www.100daysofrealfood.com/page/2/
As a result, when clicking on the link it shows the visitor the CSS or JS file, not the intended page.

We had WP Super Cache installed, and I'm guessing it might have been a conflict there? I just deactivated that and installed W3 Total Cache instead. Haven't seen the problem yet, but since it was intermittent anyway, I don't know if it's actually resolved.

I do not want to go back to inline css/js as a workaround.

Here's our list of active plugins. All are up-to-date:
Ad Squares Widget
Akismet
BackWPup
Collapsing Archives
Facebook Like Thumbnail
Google XML Sitemaps
Image Widget
Jetpack by WordPress.com
My Category Order
nrelate Related Content
Really simple Facebook Twitter share buttons
Subscribe2
Subscribe to Comments Reloaded
Subscription Options
W3 Total Cache
WP-FLV
WP-Print
Any suggestions?

Thanks very much,
Andrew

juggledad Nov 1, 2011 08:02 AM

What is your permalink?

awilder Nov 1, 2011 11:56 AM

/year/month/day/post-name

Thanks,
Andrew

juggledad Nov 1, 2011 12:05 PM

can you pin point a situation when it will happen? I don't see it happening

awilder Nov 1, 2011 03:24 PM

It was an intermittent problem.

I changed caching plugins from WP Super Cache to W3 Total Cache. Haven't seen the problem again since...


All times are GMT -6. The time now is 11:03 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.