Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Sidebars & Widgets (http://forum.bytesforall.com/forumdisplay.php?f=14)
-   -   Right sidebar won't allow widgets to be added (http://forum.bytesforall.com/showthread.php?t=7462)

Kudzu Jun 6, 2010 11:30 AM

Right sidebar won't allow widgets to be added
 
I can easily add more widgets to the left column but the right column won't allow widgets to be dragged to it. I thought maybe there was a max amount I could add (I had 3) so I dragged a widget off the right column to make room for a different widget. Now, I have 2, and it won't allow me to even add the one back that I dragged off.

Any one know of a fix for this?

paulae Jun 6, 2010 11:57 AM

Which versions of WP and the theme? Try disabling all of your plugins, then try adding a widget. Also try switching to the default theme and see if that helps, but often this kind of thing is due to a hinky plugin.

Kudzu Jun 6, 2010 12:24 PM

I'm using WordPress MU 2.9.2 and Atahualpa 3.4.6. I'll try disabling the plugins as you suggested. Thanks for your reply.

Kudzu Jun 6, 2010 01:15 PM

No solution yet. I'll try uploading the theme files again.

paulae Jun 6, 2010 01:47 PM

Disabling plugins didn't help? Was it working before? What had changed?

Are you sure your right sidebar is enabled?

Kudzu Jun 6, 2010 03:20 PM

The only thing that changed was I did an automatic update to existing plugins that were on my site. In a couple of them, I saw an error that said something like the header info was already being used. I don't remember the exact message, but the plugin still continued its update and it reactivated itself.

In my theme page (index.php) I inserted the following line, which is on line 1:

php include("http://kudzujungle.com/site/main-header.php");

The reason I did that was because I wanted my own header and graphics to be used time, then called into each sub blog no matter how many instances of atahualpa I use.

I disabled all the plugins, but that didn't work.

Kudzu Jun 6, 2010 03:41 PM

Now it is letting me add widgets to the right column, but I haven't done anything to know what I did to make the problem go away. I was writing down the configuration settings before I uploaded the files again, but thought I would try dragging a widget again before doing that.

It allowed widget, but none of my plugins were activated, and the theme defaulted back to whatever widgets comes activated with the theme.

Now I noticed the center column doesn't stretch all the way across to the right column.

I'm adding the plugins back one by one to see if I can narrow down the one that isn't compatible with this theme. I had collapsing links and a text box on the right.

paulae Jun 6, 2010 03:49 PM

I'll bet your right inner sidebar is enabled.

Kudzu Jun 6, 2010 04:15 PM

LOL...I'll bet you're right. I turned that on to see if I could add a widget to it, and it wouldn't let me. Now I know how you get 3 or 4 columns out of this theme.

Thanks again!

juggledad Jun 6, 2010 04:58 PM

check your version of php, some hosts (like godaddy was and may still) default to php 4 which causes problems - they have a faq on setting the default to php5. Php4 causes all sorts of greif with the later versions of WP

Another issue can be how much php memory you are trying to use vrs allowed to use (host limits)

Kudzu Jun 6, 2010 07:13 PM

I'm using HostGator with php 5.2.4, but not sure how to find out how much memory is used.

juggledad Jun 6, 2010 07:46 PM

could you send me a pm with a admin id and PW so I could take a look at the site? I'd check it first thing tomorrow.

Kudzu Jun 6, 2010 09:59 PM

Do you mean to Kudzu Jungle or to Hostgator?

juggledad Jun 7, 2010 05:07 AM

To the wordpress site

Kudzu Jun 7, 2010 02:54 PM

Okay juggledad...done.

It's back to not working. I installed the Wizzart comments plugin, to replace the current comment plugin on the right column. The theme doesn't allow me to drag any widgets to the right column again. So, it seems to be happening when I install plugins, even though they don't get activated. Though, I did activate the Wizzart one and tried to drag it. See if it lets you drag it to the right column.

juggledad Jun 7, 2010 03:56 PM

ok, I can't drag eithor, but it ou go to screen options and clicking the 'Enable accessibility mode' you can add widgets in (see the last one on teh right sidebar - it a text widget saying 'thisis a test')

If disabling plugins gets it to work, then I would suspect this is a php memory issue. You might ask Hiostgator to up it for you.

Kudzu Jun 7, 2010 04:57 PM

Host Gator said the max memory on a shared server is 64MB, and that if I need more than that, I have to upgrade.

juggledad Jun 7, 2010 07:12 PM

try adding the 'wp-memory-usage' plugin and see how much memory is being used

Kudzu Jun 7, 2010 10:09 PM

PHP Version : 5.2.13 / 32Bit OS
Memory limit : 64 MByte
Memory usage : 16.39 MByte

I have other WPMU blogs running under the same account, all using the same theme.

mhone Jun 13, 2010 10:41 AM

Hello,

I have the same problem, I can't add any widget on my right column, I have tried removing all my plugins (I have added quite a few recently) and I can't even add a text widget on the right column.

So I don't think it's a memory issue.
Kudzu, did you find a solution in the end?

Thanks for helping me.

juggledad Jun 13, 2010 10:54 AM

mhome,
what version of Atahualpa ande wp?
What is the url?
try swapping to the default theme and seeing if you can add widgets
who is your host?

mhone Jun 13, 2010 07:13 PM

Hello,

I have just updated to version 351 (I had 346) and now my widgets are back! I had swapped to the default theme but nothing had changed, so only with the upsdating to most recent theme version worked, I guess others should do the same.

Thank you!
Teresa


All times are GMT -6. The time now is 12:57 PM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.