Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Comments, trackbacks & pings (http://forum.bytesforall.com/forumdisplay.php?f=19)
-   -   Disable comments (http://forum.bytesforall.com/showthread.php?t=17998)

Harald Jul 17, 2012 01:51 PM

Disable comments
 
I have a problem with the comment box on all single product pages with wp-e-commerce. I have disabled comments in settings and there no comment box on "normal" pages, but on all single productpages there still is. How can I turn it off. I don't know what to do.

I use:
Wordpress 3.4.1
Atahualpa 3.7.7
wp-e-commerce 3.8.8.5

and this is a link to a product page http://www.aferdsjo.se/?wpsc-product=KTA-XE667K2-4G

Please let me know if you have any suggestions on how to solve this.

juggledad Jul 17, 2012 01:57 PM

Do you have the 'allow comments on 'page' pages' option set to NO?
In the comments options section

Harald Jul 17, 2012 03:04 PM

Hi juggledad
Yes it is set to no. The comments only show up on product pages. That is the strange thing. All those product pages are generated by wp-e-commerce as far as I understand.

juggledad Jul 17, 2012 08:39 PM

Did you disable comments at dashboard->settings->discussions ?

Harald Jul 18, 2012 01:02 AM

Yes I did that too. I had not checked the box where one has to be logged in to comments, so I did that to see what happens. When I did I get the message that I have to be logged in to comment. I does that even when comments are set to no in the places you have asked.
As I said, this does only happen on the product pages in wp-e-commerce.

juggledad Jul 18, 2012 04:20 AM

You need to ask the plugin people about this since they are building the page.

Harald Jul 18, 2012 03:30 PM

Yes I know, sorry. I have tried, but they don't have good customer service. So I took a chance trying here since you where able to help me with the shopping cart widget not showing up on the same pages I am talking about now. Thought that it maybe was a similar issue.

dwsproduction Nov 25, 2013 05:39 PM

This one stumped me for a while too and other suggested solutions didn't work. I also noticed some products had no comment boxes and others did.

Here is the solution for my particular problem; Try editing the actual product, go down to Advanced Settings, and right at the bottom of this section use the dropdown menu under Enable Comments and change it to No.


All times are GMT -6. The time now is 11:24 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.