Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Header (http://forum.bytesforall.com/forumdisplay.php?f=43)
-   -   Header images don't show? Read this ... (http://forum.bytesforall.com/showthread.php?t=321)

Flynn Feb 10, 2009 05:57 PM

Header images don't show? Read this ...
 
If your header images don't show check
  • if the file names have spaces or special characters (they should NOT)
  • if there's a space somewhere in the path to the image: /wp-content/themes/atahualpa 3/images/.... (there should be NOT)
  • if the file names end on .jpg, .gif or .png (they should)
  • if your graphics program added something like .LCK after the image name: myimage.gif.LCK (it should NOT)
Related to all images in CSS, not just header images:
  • use absolute paths when using background: url(image) somewhere in the theme options: background: url(/wp-content/themes/atahualpa/images/myimage.gif)
  • If your site is in a subdirectory /blog/ then use background: url(/blog/wp-content/themes/atahualpa/images/myimage.gif)

In version 3.3.3 a wrong Example path to images may be shown in the theme options. Something like

yoursite.com/wordpresshttp://www.yoursite.com/wordpress/wp-content/themes/atahualpa333/images/header/

This should be

http://www.yoursite.com/wordpress/wp...images/header/

or

/wordpress/wp-content/themes/atahualpa333/images/header/

Both would work

adjusterpro Mar 12, 2009 04:21 PM

Flynn, the header image in my blog only shows roughly every third refresh both in IE and Firefox (haven't checked Safari). As directed, I cleared the folder of all but the one desired image and did double check the file per your recommendations above. Still, no dice. Any suggestions would be super appreciated. Thanks!

adjusterpro Mar 12, 2009 05:00 PM

Scratch that, I hadn't properly cleared the folder. All's well now. There was a .LCK file in there for some reason. I'm a bit new to this...

Amanda Apr 2, 2009 11:48 AM

I had the same problem and deleted the .LCK files. Now all works perfectly. I think Dreamweaver creates the .LCK files as part of the check-in/check-out facility. I may be wrong.

imabeliever Apr 10, 2009 12:23 AM

I am having this issue and have checked the file name etc. What else can I do to make my image show up?
Help! Please....
I donated for your time.
Thanks
Laura
imabeliever:)

juggledad Apr 10, 2009 06:20 AM

you should add the name of your site so someone can look at the underlining code.

Also make sure in the Atahualpa theme Options -> Header -> Configure Header Area that you have %image entered. If you don't, the image area won't display

imabeliever Apr 10, 2009 10:24 AM

My site is http//www.kangenworldteam.com

Thank you for looking into this for me.

Flynn Apr 10, 2009 12:03 PM

Laura, I think you mentioned on wordpress.bytesforall.com that you've put the images into
wp-content/themes/atahualpa/images/header/New Directory

Put them into
wp-content/themes/atahualpa/images/header/

instead.


On another note, don't use spaces anywhere in file names or directory names, if it is supposed to run on a web hosting account. Spaces work on Windows but not on Linux, which is usually the operation system of choice on web hosting servers.

imabeliever Apr 10, 2009 12:48 PM

I switched to Montezuma to see if it would work there. Nope....here is the exact directory copied from the "remote site" address window

/httpdocs/wordpress/wp-content/themes/montezuma/images/header/longbeachpic.jpg

what the heck? I am super frustrated

Laura

imabeliever Apr 10, 2009 07:27 PM

Now I got the picture inserted finally...after tearing my hair out! Now the photo shows on almost all pages except "Home" (pretty important) and the about us page

What to do??

nanessa Apr 14, 2009 07:10 AM

Hiya,
I've done all things mentioned above and I still can not for the life of me get ANY pictures to show up in my header. I haven't had any pics show up since I installed it. Is there anything else I should be looking at?
www.thislittlebird.ca

Flynn Apr 14, 2009 05:20 PM

Quote:

Originally Posted by nanessa (Post 4918)
Hiya,
I've done all things mentioned above and I still can not for the life of me get ANY pictures to show up in my header. I haven't had any pics show up since I installed it. Is there anything else I should be looking at?
www.thislittlebird.ca

You have a space in /atahualpa 3/

There shouldn't be a space anywhere, neither in file names nor in directory names

Ricco May 11, 2009 07:52 AM

I've got a problem but I don't know where to change it. The path shown below is wrong, but how to correct it?
http://img4.imageshack.us/img4/8123/wrongb.jpg

ciocchi May 21, 2009 01:48 AM

my header want rotate, only static and rotate each time I reload page.
I set everythnig yes in editor, but nothing?
why?
www.mialchemilla.it
ps. I donate few dollars for a beer...

Flynn May 21, 2009 05:48 PM

Quote:

Originally Posted by ciocchi (Post 6961)
my header want rotate, only static and rotate each time I reload page.
I set everythnig yes in editor, but nothing?
why?
www.mialchemilla.it

What's your setting at Theme Options -> Header Image -> Rotate header images with Javascript? Should be something else than 0

Quote:

ps. I donate few dollars for a beer...
Thank you. I added it to your user name.

Flynn May 21, 2009 05:49 PM

Quote:

Originally Posted by Ricco (Post 6460)
I've got a problem but I don't know where to change it. The path shown below is wrong, but how to correct it?
http://img4.imageshack.us/img4/8123/wrongb.jpg

The example path that is shown is wrong, a bug in 3.3.3. However, while confusing, it does not affect the functionality. Upload your images to /blog/wp-content/themes/atahualpa333/images/header/

ciocchi May 22, 2009 01:03 AM

Quote:

Originally Posted by Flynn (Post 7018)
What's your setting at Theme Options -> Header Image -> Rotate header images with Javascript? Should be something else than 0


Thank you. I added it to your user name.

yes i set it to 3 but nothing (also preload on or off is not working)
I previuos use the trick to do this in 3.3.2 possible this effect on malfunction? ( I delete the old code)

UPDATE:
now is misteriously working.
:-)

ncristine Jul 27, 2009 04:18 PM

Hi There
I'm still missing something. I am not able to even access the images folder.
I've signed in and when I add the path to the admin path it can't find the server.
All I want to do is upload my own custom header to the bytes theme. When I add this path
wordpress/wp-content/themes/atahualpa333/images/header

to

http://humanresourcefullness.com/wp-admin/index.php

or any variation it doesn't work.

What am I missing?

This is for the atahualpa 3 template

I really appreciate your help

juggledad Jul 27, 2009 05:24 PM

In atahualpa header images are in teh directory yourblog.com/wordpress/wp-content/themes/atahualpaxxx/images/header
you may or maynot have the /wordpress' depending on how you did your install of WordPress and the xxx represents the version number of the theme if you named the file that way.

You will need to use an FTP program to upload images to that folder.

ncristine Jul 27, 2009 09:20 PM

It's the directory to the images that I can't find and when I copy and paste the url that you cited here it says forbidden.

bytesforall is the template. How do I get to the folder of images? Where is it?

ncristine Jul 27, 2009 10:27 PM

Hi There
Thank you again for helping.

In his case, his blog is an alias to another site with images. I'm not seeing the template files there. Likely because its an alias.

How about just stopping the rotating images. Is that possible, since it seems we can't get our custom header in.

juggledad Jul 28, 2009 06:09 AM

You have me confused, are you using the 'Atahualpa' theme or the 'bytesforall' theme?

ncristine Jul 28, 2009 11:10 AM

hmmm....that's interesting. It says Current Theme
Atahualpa 3.4.1 by BytesForAll

Version 3.4.1 – Atahualpa is a WordPress/PHP/CSS Framework that lets you build your own unique, professional and browser-safe WordPress theme: 1-5 columns, fluid or fixed width, rotating header images and over 200 theme options. Tutorials, downloads and support at the BFA WP Forum

All of this theme’s files are located in /themes/atahualpa.
-------------------------------------
I've been trying to get to the images file through ftp but there is only php files. Still trying to figure this out. I'm confused when getting a custom header image in there is so hard to do. It says that its possible. hmm...

juggledad Jul 28, 2009 04:30 PM

Bytesfor all is the domain for several themes, one is called 'bytesforall' another is called 'atahualpa' this is where the confusion comes from.

If you use FTP and can get to the WordPress themes folder, you will see a folder called Atahualpa. Inside this folder (along with some PHP and some other folders) will be a folder called 'Images'. Inside this folder you will find a folder called 'Header'. That's where the header iages are located.

ncristine Jul 30, 2009 07:30 PM

Thank you I really appreciate your help.

Esperanza Aug 29, 2009 11:38 AM

I wonder if you can help me. I've downloaded ata 3.4.2. because I wanted the rotating header, I've FTP my images to
/wordpress/wp-content/themes/atahualpa342/images/header

and the images don't appear only the one's that came with the theme.

Do you know what the problem could be?

I would really appreciate your help, I am pretty new at this and I am at lost...:confused:

Thank you

juggledad Sep 8, 2009 04:16 AM

what have you got set at ATO-> Header Image ?
What is the url?

onlinebisnes Sep 9, 2009 02:29 AM

I also had almost the same issue.
I use the latest Atahualpa 3.4.2 with latest wp.2.8.4
most of the setting in Header area > header image are on default.
all was fine until I ftp new header image to header folder,
after that I just got blank header image.
I delete all header image except one also same result.
delete all and put back original header images also same.
any ideal?

juggledad Sep 10, 2009 11:47 AM

what is your url so I can take a look

Taffy Sep 14, 2009 04:12 AM

Hi again Flynn,

Well I have the theme installed (Atahualpa 3.4.1) and up & running :), Philippines Virtual Guide Looking great apart from I cannot get my banners to rotate unless I refresh the page or select a different post, which obviously refreshes anyway...? The images are all displaying, just not rotating !

Also I have no thumbnail display on any page or post, including on the home page, that is displaying excerpts ! Each post has it's own 150 x150 px thumb which (on the old theme at least) did display in the excerpts of each post on the home page.

Finally is there any possibility of getting the option to assign an image in the header rotator to any particular post or page, I think this would be great on a future release...? Even if the rotator itself does not rotate hahaha. :)

Regards Taffy :)

juggledad Sep 14, 2009 04:37 AM

the rotating header code got droped in 3.4/3.4.1 but is back in in 3.4.2 - upgrade your theme version

Taffy Sep 14, 2009 11:37 AM

Quote:

Also I have no thumbnail display on any page or post, including on the home page, that is displaying excerpts ! Each post has it's own 150 x150 px thumb which (on the old theme at least) did display in the excerpts of each post on the home page.

Finally is there any possibility of getting the option to assign an image in the header rotator to any particular post or page, I think this would be great on a future release...? Even if the rotator itself does not rotate hahaha. :)
Hey "Dad" nice one, it works perfectly now :):) Any chance of sorting the other two queries above...? :confused:

juggledad Sep 14, 2009 11:56 AM

I beleive both of these have been answered in the forums, try doing a search

sunnivie Sep 17, 2009 12:38 PM

Juggledad, you helped me solve an image uploading in posts problem yesterday - http://forum.bytesforall.com/showthr...4783#post14783 - thanks so much! I've donated directly to you for your help.

I'm now having trouble customizing my header. I checked all of the avenues Flynn mentioned at the beginning of this thread - no spaces or special characters, the path is correct, and the images are uploaded directly to my server, with just a .jpg format. The header still rotates through the default images, but the image I've uploaded shows up as blank.

My upload image is the same dimensions as the default images. I've also tried removing the default images - same result, my image comes up blank. I then re-uploaded the default images and they continued to work. What am I missing?

www.outfrontcolorado.com.

I'm running WP 2.8.3, Atahualpa 3.4.2.

juggledad Sep 17, 2009 01:02 PM

check the file permission for the image 'OFCBlogBanner_1.jpg' make sure it has the same permissions as the other images - and make sure the case of the file name is the same.

sunnivie Sep 17, 2009 01:13 PM

Juggledad, that did it. You're my hero. I think my problem last time was a permissions issue, also. You'd think I would figure out at some point to just check those first, before bothering you lovely people.

Nevertheless, thank you thank you thank you. When this site is fully up and functional, I will absolutely have you to thank for it.

Masselyn Oct 26, 2009 11:17 PM

Not to beat the poor horse, but I brought in a flash header to a website (link below) which worked wonderful last week when I finally edited the correct files. Today I went back to the site, to assist the client with something else, and the header shows up beautifully in Safari (flash and all) and I get zip/zero/ziltch in Firefox. This was not the case when I loaded it, because I always work in Firefox and I know it was working fine. Anybody have thoughts on what could have changed? My client does not play with the files, and I have not gone in since loading the Flash banner, so I don't think editing the files were the problem (and I checked them, the code still looks sound). Checked this on two different computers, so I don't think it is just me.

Just wondering whether anyone else has seen this - the Great Disappearing Flash Header in Firefox.

:)

http://bowtique.com.au/

juggledad Oct 28, 2009 06:08 AM

It shows up in both Firefox and safari for me. Did you do anything?

dhoward Dec 7, 2009 12:08 PM

I've tried everything I've found on this forum... it isn't displaying my new header image, still the three default images that come with the theme...

www.CallCenterSoftware.com

The images are here:

/wp-content/themes/atahualpa344/images/header/

Wordpress tells me:

Header Images
All header images are located in /wp-content/themes/atahualpa/images/header/. All images in that directory will be rotated. If you don't want rotating header images, leave only one image in that directory.


I removed the images that came with the theme from that directory... and they still display, so they must be cached?

I tried the same image with PNG and with JPG extension, no dice, it won't display.

Tried all the options pre-load yes or no, increasing the rotation time, changing themes to something else, then back again...


Tried all this:

http://forum.bytesforall.com/showthread.php?t=2626


What am I missing?

dhoward Dec 7, 2009 12:15 PM

Clarification:

The images are here:

/wp-content/themes/atahualpa344/images/header/

I removed the default images from that directory, and installed my own. They still don't display.

The configuration page says that images are held here: /wp-content/themes/atahualpa/images/header/

but I know it really means here: /wp-content/themes/atahualpa344/images/header/


Nonetheless, I created this directory: /wp-content/themes/atahualpa/images/header/

and put my image there, and, as expected, it does not work.


All times are GMT -6. The time now is 02:28 AM.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.