Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Installation/Upgrade Issues (http://forum.bytesforall.com/forumdisplay.php?f=58)
-   -   Header Image Problem in Preparation For Upgrade (http://forum.bytesforall.com/showthread.php?t=23523)

BrightonNY Aug 1, 2016 03:36 PM

Header Image Problem in Preparation For Upgrade

The website is on a subdomain.

I'm currently running on ATA 3.7.12 and preparing for upgrade to latest version. I followed the directions precisely as described under IMAGE LOCATIONS. I did not upgrade; this problem is happening on my wesbite when I select RELATIVE LOCATION as wp-content.

My folders are as follows: public_html to wp-content to ata-images to header to head1(header image).
The permissions are 0755 except the header image which is 0644.

No caps and no spaces.

I've tried it several times with the same result.

Here is the problem: http://www.testing.selmarcerini.com

Any help would be greatly appreciated. Thank you.

BrightonNY Aug 1, 2016 03:44 PM

Correction: header image is head01, not head1

juggledad Aug 1, 2016 05:19 PM

Try turning off rotating headers - set ATO->Header Image->Rotate header images with Javascript? to zero (0)

BrightonNY Aug 3, 2016 12:22 PM

This did not work. I've tried to vary some other settings without success.

juggledad Aug 3, 2016 12:52 PM

Export your settings (ATO->export/import settings) and attach them to a reply

BrightonNY Aug 3, 2016 02:26 PM

Settings attached.

BrightonNY Aug 3, 2016 03:52 PM

I created a new subdomain and deleted the 3 default headers and uploaded a copy of the original header in the same header folder. It works fine until I change the setting to wp-content from atahualpa; gives the same error.

This new subdomain is WP 4.5.3 and ATA 3.7.24.

BrightonNY Aug 3, 2016 04:23 PM

CORRECTION: Same problem when changing setting from ATAHUALPA to WP-IMAGES

juggledad Aug 3, 2016 06:54 PM

So it works when you use images in teh atahualpa/images/header folder...right?
Since you have changed the test case, what is the new URL and what is the exact content of the wp-contents/ata-images/header folder?

In copying your settings to my test site, it works fine both ways. This leads me to beleive there is still a permission problem or a files name is 'funny' or a file is corrupt.

When I go to your site and look for errors (In safari) I am seeing the following

Failed to load resource: the server responded with a status of 404 (Not Found)

BrightonNY Aug 4, 2016 12:54 PM

Yes, works fine in the ATA images/header folder so long as I use ATAHUALPA rather than WP-CONTENT.

The wp-content/ata-images/header folder contains only one file: header01.jpg. I had downloaded it from the ATA images folder and then uploaded it to the ata-images/header folder.

I noticed in the error message the last part is .../header/-wp-content. Is that correct? Just wondering where the - ahead of wp-content came from.

The original website is still there. The new subdomain is: http://www.newata.selmarcerini.com

juggledad Aug 4, 2016 03:24 PM

1) you need to put your logo.jpg in the wp-content/ata-images folder

Failed to load resource: the server responded with a status of 404 (Not Found)
2) if you can not enter in the fully qualified path to the image in the browser address bar and see the image, you have a permission or misspelling issue.

For example if you put
HTML Code:

in the address bar, you see the image, but if you put
HTML Code:

you get a not found.

Check the name of the folders, look for something like headerS vrs header or something in uppercase.

It's not your Atahualpa settings, it's something to do with the folders/files

BrightonNY Aug 5, 2016 10:26 AM

I did the following:

1. Created ata-logo folder in wp-content and added logo.gif and logo.png files.

2. Deleted and rebuilt:
wp-content => ata-images => header => header.jpg

3. All in lower case and no spaces.

I really appreciate your help but at this point I need to just live with the problem provided there is some way I can shut off automatic updates. Is there a way to do that?

Thank you.

juggledad Aug 5, 2016 12:41 PM

1) in your settings you state the logo is 'logo.png' If the actual file is 'logo.gif' it will not find it and it must be in the 'wp-content/ata-images' folder

2) You have me confused - is the header image 'header.jpg' or 'header01.jpg'?

can you use an FTP program and go to the 'wp-content' folder and takk a screen snap shot, then go to the 'ata-images' folder and take a snap shot and then go to the 'header' folder and thk a snapshot and attach them to a reply.

something is wrong with the spelling of a file or it's permission.

(actually you can keep using the atahualpa folders - with the major change in theme review that requires all themes must use the customizer for all options or the theme will not pass review, I do not see another release of Atahualpa happening. The number of man-hours that would be involved is staggering. If any issues comes up that can be patched a fix will be released for them.)

BrightonNY Aug 5, 2016 01:29 PM

1. I moved logo.gif to ata-images.

2. When I uploaded a fresh copy of the header, I renamed it to header from header01.

3. I'm not sure how to use FTP as I haven't used it in years and back then I only used it to upload images as I recall. I will work on your request later today and tomorrow.

4. Yes, I'm fine using the ATA folders. But I still want to shut off any kind of automatic updates especially for WP and plugins, etc.

Thank you.

BrightonNY Aug 5, 2016 01:34 PM

Question: Does the name of the header file in ata-images have to be identical to the name of the header file in the ATA files?

I changed the name because the ATA file has upper and lower case letters.

juggledad Aug 6, 2016 03:57 AM

1) you just said you moved 'logo.gif' into ata-images - does that match the name you supplied at ATO->Style & edit HEADER AREA->Show Logo Image?
2) How are you moving the files into ata-images if you are not using FTP?
3) With what ever you are using to move the files, can you create a screeen shot of the contents of at a-images and ata-images/header?
4) after moving the files in to the folders, have you double checked the file permissions?

BrightonNY Aug 7, 2016 12:18 PM

1). This may be a non-issue since I do not use a logo. Under CONFIGURE HEADER AREA I do not have %logo.

2). On the File Manager top menu I am using the UPLOAD and DOWNLOAD icons from/to my PC harddrive. See attached screen shots.

3). The requested screen shots are attached.

4). Yes, I check the permissions each time I make a change.


juggledad Aug 7, 2016 03:13 PM

can you send me a PM with an admin id/pw?

Something is seriously out of whack if you don't have %logo in the option, because the code is trying to create the header and it only does that id the %logo is there.

juggledad Aug 8, 2016 04:25 AM

ok, things got crazy because I was lookaing at the http://www.newata.selmarcerini.com site, which must have %logo in the header config

for the http://www.testing.selmarcerini.com you still have a folder/file permission problem
The images you show of the folders are not for the testing site ehis is:

the images you show are for

Also you are running wp-supercache which is bad when you are doing testing - I shut it off so remember to turn it back on when you are done making changes.

So go back and look at the premissions for the at a-images folder at

all teh folders and files at

amnd the images at


BrightonNY Aug 11, 2016 01:06 PM

I have been distracted from this problem by another one with FILEZILLA for the past few days.

As you suggested in an earlier post, I tried out FILEZILLA to reload the header image. I last used it 3 years ago when I built the website. Now it will not connect to the website files. I've been on the phone several times with HOSTGATOR support and they do not have an answer. I also mentioned this ATA Header problem and they suggested it comes initially from the implementation code of ATA and possibly WP if the ATA code depends on WP to set up the path.

This leads me to another more general question about ATA. Since you such in-depth knowledge, are you one of the developers of ATA?


juggledad Aug 11, 2016 03:10 PM

Yes, I sort of am one of the developers. I've been responsible for the releases for the last few years.

You don't need to use FileZilla, since your file manager shows the permissions, just make sure to look at the right folders and files.

The images you sent were NOT for the testing site. Read my previous post

BrightonNY Aug 11, 2016 05:29 PM

1. I'll re-capture the images tomorrow. Not sure how I managed to screw that up.

2. I'll go through the files again and document their permissions.

2. I agree that I do not need FILEZILLA at this time however the fact that this is happening at the same time as my ATA problem suggests to me that my files have somehow been corrupted. I will probably have to start all over with HOSTGATOR resetting all my files to their defaults and rebuild my website rather than restore from a backup.


juggledad Aug 11, 2016 05:38 PM

I will be VERY surprised if your issues with Filizilla and atahualpa are related.

BrightonNY Aug 12, 2016 02:52 PM

I went through the folders and files and checked their permissions as follows:

- public_html 750
-testing 0755
- wp-content 0755
-ata-images 0755
-header 0755
- header.jpg 0644

Also had some logo folder and images but I do not use a logo. Those folders and files had the same permissions as the ata-images folders and files.

Do you need images for the testing folders and files?


juggledad Aug 12, 2016 06:53 PM

ok, so you have a file called 'header.jpg' and it is in the folder 'header' or
and the 'header folder is in the 'ata-images' folder or
and that is in the wp-content' folder or
or the full path is

If that is the case you should be able to copy and paste that url into the browser and see the image...but if gets a not found

You might want to check all your .htaccess files and see if there is anything preventing access to that file/folder

All times are GMT -6. The time now is 03:13 AM.

Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.