Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Plugins & Atahualpa (http://forum.bytesforall.com/forumdisplay.php?f=16)
-   -   Post info %comments doesn't jump to comments area (using Disqus) (http://forum.bytesforall.com/showthread.php?t=17934)

cognitionetc Jul 6, 2012 08:04 AM

Post info %comments doesn't jump to comments area (using Disqus)
 
Someone asked this question years ago (http://forum.bytesforall.com/showthr...ghlight=disqus) but it seems like it hasn't been solved.

I'm using Wordpress 3.4.1 and Atahuapla 3.7.7 with Disqus commenting system (this is my site: http://www.cognitionetc.com). %comments in the post info footer doesn't go to the Disqus comments, and it doesn't display the number of comments. Even with several comments, the post info just displays "Leave a comment", and when that is clicked on it goes to ../pageurl/#respond, e.g. http://www.cognitionetc.com/2012/07/...ative/#respond which doesn't go to the comment area, just the post page itself.

I can't for the life of me work out how to fix this. Any ideas?

juggledad Jul 6, 2012 08:41 AM

when I go to your site and go to the first post, the DISus at the bottom shows the site loading forever.

cognitionetc Jul 6, 2012 08:45 AM

Thanks for the quick response. I'm not entirely sure what you mean... what exactly is loading forever? I'm not getting anything like that when I go on it.

cognitionetc Jul 6, 2012 09:07 AM

UPDATE: I've just noticed that for posts which had comments prior to when I installed Disqus (such as http://www.cognitionetc.com/2012/05/...e-shakespeare/) the post info actually displays the correct number of comments, but when it is clicked on it goes to ../pageurl/#comments, e.g. http://www.cognitionetc.com/2012/05/...eare/#comments which, while different to pageurl/#respond also doesn't go to the comments.

cognitionetc Jul 6, 2012 09:08 AM

Also note that this is only a problem on the post info sections on the main page (http://www.cognitionetc.com) - the single post pages have no links to comments in the post info, given that the comments are on the page already.

juggledad Jul 6, 2012 10:19 AM

Atahualpa is using the wordpress function have_comments() function to determine weithor or not to build the name=comment link

My guess is that Discus does not have a hook into this function so since ther comments are not stored in WP the function returns 'none' and no link is built

cognitionetc Jul 9, 2012 08:24 AM

Is there a way of changing this function? I can probably find out what function disqus is using and change it to that, but I'm relatively new to coding and so can't work out where the code is in atahuapla that's responsible for this function.

juggledad Jul 9, 2012 09:39 AM

the use of the function is in comments.php


All times are GMT -6. The time now is 06:52 PM.

Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.