Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Atahualpa 3 Wordpress theme (http://forum.bytesforall.com/forumdisplay.php?f=2)
-   -   [SOLVED] automatically adds "-2" to my permalinks - every time I edit or post new pag (http://forum.bytesforall.com/showthread.php?t=12137)

northcoastimports Jan 9, 2011 06:59 PM

[SOLVED] automatically adds "-2" to my permalinks - every time I edit or post new pag
 
I'm having some problems with my permalinks. WP is adding a "-2" to the end of all of my permalinks - even when there is no other page with the same name. Every time I post a new page, and every time I edit, it puts a "-2" after whatever I type in the permalink window.

I don't have anything in the "Trash," all of my pages are published, and I can't change the permalink back.

If I change to a completely new name, it will work ok... but even if I try and change it back to the name that I need it adds "-2"

Any help?

It is only occurring on one installation:

www.northcoastimports.com

Here's an example of an edited page:
www.northcoastimports.com/cc/8dm/8365-2

UPDATE: Apparently, it only occurs when the permalink is a number. I just created a new test page with the permalink "test" and it worked okay. I also created a new test page with the permalink "9999" and it added a "-2"

juggledad Jan 10, 2011 09:59 AM

What do you have set at dashboard->settings->permalinks?

northcoastimports Jan 10, 2011 10:29 AM

Quote:

Originally Posted by juggledad (Post 54266)
What do you have set at dashboard->settings->permalinks?

/%postname%/

juggledad Jan 10, 2011 10:46 AM

do you have any seo plugins that might be messing with this?
temporally swap to the twenty-ten theme and see if the same thing happens.

Maeve Feb 7, 2011 10:54 AM

This seems to be related to a problem that I'm having with Permalinks so I hope it's all right to put it here.


I have several links that have started going to the Dashboard (If I'm logged into WP) or to the WP login page if I'm not.

The links are on this page: http://americanenglishdoctor.com/wordpress/?page_id=14

I'll use the first link for an example.
b,d,h,j,k,l,m,n,p,r,t,v,w,z
Instead of going to the specified link:
http://americanenglishdoctor.com/wordpress/?page_id=124

it automatically inserts /wp-admin/:

http://americanenglishdoctor.com/wor...n/?page_id=124

What can I do to stop that from happening? The links used to work properly.

I'm using Atahualpa 3.4.4.

juggledad Feb 7, 2011 12:08 PM

You need to look at your .htaccess file and see what is in it.

If this just started happening, what change did you make to your site? Did you add a new plugin? That could be cause it.

Try swapping to the default theme, if the issue still occurs, it's not theme related.

Maeve Feb 7, 2011 02:06 PM

Never mind!

I was able to go back into the page and edit the links. How that "wp-admin" ever got into the path beats me.

Thanks


All times are GMT -6. The time now is 08:03 PM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.