Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] automatically adds "-2" to my permalinks - every time I edit or post new pag


  #1  
Old Jan 9, 2011, 06:59 PM
northcoastimports
 
13 posts · Jan 2010
I'm having some problems with my permalinks. WP is adding a "-2" to the end of all of my permalinks - even when there is no other page with the same name. Every time I post a new page, and every time I edit, it puts a "-2" after whatever I type in the permalink window.

I don't have anything in the "Trash," all of my pages are published, and I can't change the permalink back.

If I change to a completely new name, it will work ok... but even if I try and change it back to the name that I need it adds "-2"

Any help?

It is only occurring on one installation:

www.northcoastimports.com

Here's an example of an edited page:
www.northcoastimports.com/cc/8dm/8365-2

UPDATE: Apparently, it only occurs when the permalink is a number. I just created a new test page with the permalink "test" and it worked okay. I also created a new test page with the permalink "9999" and it added a "-2"

Last edited by northcoastimports; Jan 9, 2011 at 07:04 PM. Reason: more info
  #2  
Old Jan 10, 2011, 09:59 AM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What do you have set at dashboard->settings->permalinks?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jan 10, 2011, 10:29 AM
northcoastimports
 
13 posts · Jan 2010
Quote:
Originally Posted by juggledad
What do you have set at dashboard->settings->permalinks?
/%postname%/
  #4  
Old Jan 10, 2011, 10:46 AM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
do you have any seo plugins that might be messing with this?
temporally swap to the twenty-ten theme and see if the same thing happens.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Feb 7, 2011, 10:54 AM
Maeve
 
10 posts · Jun 2009
Arkansas
Send a message via Yahoo to Maeve
This seems to be related to a problem that I'm having with Permalinks so I hope it's all right to put it here.


I have several links that have started going to the Dashboard (If I'm logged into WP) or to the WP login page if I'm not.

The links are on this page: http://americanenglishdoctor.com/wordpress/?page_id=14

I'll use the first link for an example.
b,d,h,j,k,l,m,n,p,r,t,v,w,z
Instead of going to the specified link:
http://americanenglishdoctor.com/wordpress/?page_id=124

it automatically inserts /wp-admin/:

http://americanenglishdoctor.com/wor...n/?page_id=124

What can I do to stop that from happening? The links used to work properly.

I'm using Atahualpa 3.4.4.
  #6  
Old Feb 7, 2011, 12:08 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
You need to look at your .htaccess file and see what is in it.

If this just started happening, what change did you make to your site? Did you add a new plugin? That could be cause it.

Try swapping to the default theme, if the issue still occurs, it's not theme related.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Feb 7, 2011, 02:06 PM
Maeve
 
10 posts · Jun 2009
Arkansas
Send a message via Yahoo to Maeve
Never mind!

I was able to go back into the page and edit the links. How that "wp-admin" ever got into the path beats me.

Thanks

Bookmarks

Tags
change, page, permalink, permalinks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Substitute Post name with "Next Post" and "Previous Page" in post navigation Alternateroute Center area post/pages 2 Nov 18, 2010 09:15 PM
Why is the "select text color" in Edit Post changes my font instead??? I am confused! coolmummy Forum How-To 23 Apr 25, 2010 12:44 PM
edit page does not load but progress message says "done" seaislandman Atahualpa 3 Wordpress theme 0 Jan 20, 2010 01:16 AM
How to get "edit this post" to show on post daisy24 Post-Kicker, -Byline & -Footer 2 Apr 7, 2009 03:56 AM


All times are GMT -6. The time now is 02:28 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.