Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Atahualpa 3 Wordpress theme (http://forum.bytesforall.com/forumdisplay.php?f=2)
-   -   [SOLVED] Home page won't load! Parse error, syntax error (http://forum.bytesforall.com/showthread.php?t=3198)

lhanft Aug 30, 2009 10:01 AM

[SOLVED] Home page won't load! Parse error, syntax error
 
1 Attachment(s)
As far as I can tell, all I was doing was adding some subpages to the site. After adding one of them, when I refreshed the home page I got the following error message:


Parse error: syntax error, unexpected T_STRING in /home/shem/public_html/wp-content/themes/atahualpa342/functions.php(396) : eval()'d code on line 2

I looked at the code but nothing jumped out at me as a glaring error. How can I fix this?

PS attaching functions.php

PSS wordpress 2.8.4
atahualpa 3.4.2

juggledad Aug 30, 2009 10:09 AM

swap to the default theme and remove the last page you created. Then swap back to Atahualpa and see if it works

lhanft Aug 30, 2009 11:01 AM

No, it didn't work.
Here's something weird: the homepage url (http://theagnonschool.org) immediately redirects to the last page I created (and the one I deleted when I switched to the default theme). That page is http://theagnonschool.org/parents/cl...hildhood-news/. In the default theme, when that page tries to load, there's a 404 message (since the page doesn't exist). In Atahualpa, there's the parse error, syntax error message.

What else can I try?

lhanft Aug 30, 2009 11:09 AM

Juggledad,
Thanks for your help. Since I couldn't figure out what I did in creating several new pages -- or which new page -- caused the problem, I just restored last night's database backup, and all is working again.
But I really appreciate your fast help.
Lila

juggledad Aug 30, 2009 02:44 PM

Actually, your problem still exists, just try http://theagnonschool.org/dsfgsd and the error will occur.
1) what do you have at ATO->Style & edit CENTER COLUMN -> Content if NOT FOUND?
2) please set ATO->Configure CSS & JS items to 'Internal', 'Internal', 'NO' and 'YES


All times are GMT -6. The time now is 07:05 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.